Upstream information

CVE-2021-33833 at MITRE

Description

ConnMan (aka Connection Manager) 1.30 through 1.39 has a stack-based buffer overflow in uncompress in dnsproxy.c via NAME, RDATA, or RDLENGTH (for A or AAAA).

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Adjacent Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1186869 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • connman >= 1.40-2.2
  • connman-client >= 1.40-2.2
  • connman-devel >= 1.40-2.2
  • connman-doc >= 1.40-2.2
  • connman-nmcompat >= 1.40-2.2
  • connman-plugin-hh2serial-gps >= 1.40-2.2
  • connman-plugin-iospm >= 1.40-2.2
  • connman-plugin-l2tp >= 1.40-2.2
  • connman-plugin-openconnect >= 1.40-2.2
  • connman-plugin-openvpn >= 1.40-2.2
  • connman-plugin-polkit >= 1.40-2.2
  • connman-plugin-pptp >= 1.40-2.2
  • connman-plugin-tist >= 1.40-2.2
  • connman-plugin-vpnc >= 1.40-2.2
  • connman-plugin-wireguard >= 1.40-2.2
  • connman-test >= 1.40-2.2
Patchnames:
openSUSE Tumbleweed GA connman-1.40-2.2