Upstream information

CVE-2021-33815 at MITRE

Description

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1186865 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • ffmpeg-4 >= 4.4-5.2
  • ffmpeg-4-libavcodec-devel >= 4.4-5.2
  • ffmpeg-4-libavdevice-devel >= 4.4-5.2
  • ffmpeg-4-libavfilter-devel >= 4.4-5.2
  • ffmpeg-4-libavformat-devel >= 4.4-5.2
  • ffmpeg-4-libavresample-devel >= 4.4-5.2
  • ffmpeg-4-libavutil-devel >= 4.4-5.2
  • ffmpeg-4-libpostproc-devel >= 4.4-5.2
  • ffmpeg-4-libswresample-devel >= 4.4-5.2
  • ffmpeg-4-libswscale-devel >= 4.4-5.2
  • ffmpeg-4-private-devel >= 4.4-5.2
  • libavcodec58_134 >= 4.4-5.2
  • libavcodec58_134-32bit >= 4.4-5.2
  • libavdevice58_13 >= 4.4-5.2
  • libavdevice58_13-32bit >= 4.4-5.2
  • libavfilter7_110 >= 4.4-5.2
  • libavfilter7_110-32bit >= 4.4-5.2
  • libavformat58_76 >= 4.4-5.2
  • libavformat58_76-32bit >= 4.4-5.2
  • libavresample4_0 >= 4.4-5.2
  • libavresample4_0-32bit >= 4.4-5.2
  • libavutil56_70 >= 4.4-5.2
  • libavutil56_70-32bit >= 4.4-5.2
  • libpostproc55_9 >= 4.4-5.2
  • libpostproc55_9-32bit >= 4.4-5.2
  • libswresample3_9 >= 4.4-5.2
  • libswresample3_9-32bit >= 4.4-5.2
  • libswscale5_9 >= 4.4-5.2
  • libswscale5_9-32bit >= 4.4-5.2
Patchnames:
openSUSE Tumbleweed GA ffmpeg-4-4.4-5.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 ffmpeg Not affected
SUSE Enterprise Storage 6 ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS ffmpeg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS ffmpeg Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 ffmpeg Not affected
SUSE Linux Enterprise Server 15 ESPOS ffmpeg Not affected
SUSE Linux Enterprise Server 15 LTSS ffmpeg Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS ffmpeg Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 ffmpeg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ffmpeg Not affected
SUSE Linux Enterprise Workstation Extension 15 SP2 ffmpeg Not affected
SUSE Manager Proxy 4.0 ffmpeg Not affected
SUSE Manager Retail Branch Server 4.0 ffmpeg Not affected
SUSE Manager Server 4.0 ffmpeg Not affected