Upstream information

CVE-2021-32918 at MITRE

Description

An issue was discovered in Prosody before 0.11.9. Default settings are susceptible to remote unauthenticated denial-of-service (DoS) attacks via memory exhaustion when running under Lua 5.2 or Lua 5.3.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1186027 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 15 SP2
  • prosody >= 0.11.9-bp152.2.3.1
Patchnames:
openSUSE-2021-751
SUSE Package Hub for SUSE Linux Enterprise 15 SP3
  • prosody >= 0.11.9-bp153.2.3.1
Patchnames:
openSUSE-2021-991
openSUSE Leap 15.2
  • prosody >= 0.11.9-lp152.2.3.1
  • prosody-debuginfo >= 0.11.9-lp152.2.3.1
  • prosody-debugsource >= 0.11.9-lp152.2.3.1
Patchnames:
openSUSE-2021-728
openSUSE Leap 15.3
  • prosody >= 0.11.9-bp153.2.3.1
Patchnames:
openSUSE-2021-991
openSUSE Tumbleweed
  • prosody >= 0.11.10-1.2
Patchnames:
openSUSE Tumbleweed GA prosody-0.11.10-1.2