Upstream information

CVE-2021-32815 at MITRE

Description

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The assertion failure is triggered when Exiv2 is used to modify the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when modifying the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fi`. ### Patches The bug is fixed in version v0.27.5. ### References Regression test and bug fix: #1739 ### For more information Please see our [security policy](https://github.com/Exiv2/exiv2/security/policy) for information about Exiv2 security.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 3.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1189337 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 exiv2 Affected
SUSE CaaS Platform 4.0 exiv2 Affected
SUSE CaaS Platform 4.5 exiv2 Affected
SUSE Enterprise Storage 6 exiv2 Affected
SUSE Enterprise Storage 7 exiv2 Affected
SUSE Linux Enterprise Desktop 15 SP2 exiv2 Affected
SUSE Linux Enterprise Desktop 15 SP3 exiv2 Affected
SUSE Linux Enterprise Desktop 15 SP4 exiv2 Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 exiv2 Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 exiv2 Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 exiv2 Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 exiv2 Affected
SUSE Linux Enterprise Point of Service 11 SP3 exiv2 Affected
SUSE Linux Enterprise Real Time 15 SP2 exiv2 Affected
SUSE Linux Enterprise Server 11 SP1 exiv2 Unsupported
SUSE Linux Enterprise Server 11 SP3 exiv2 Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS exiv2 Affected
SUSE Linux Enterprise Server 12 SP2 BCL exiv2 Affected
SUSE Linux Enterprise Server 12 SP3 BCL exiv2 Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS exiv2 Affected
SUSE Linux Enterprise Server 12 SP3 LTSS exiv2 Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS exiv2 Affected
SUSE Linux Enterprise Server 12 SP4 LTSS exiv2 Affected
SUSE Linux Enterprise Server 12 SP5 exiv2 Affected
SUSE Linux Enterprise Server 15 ESPOS exiv2 Affected
SUSE Linux Enterprise Server 15 LTSS exiv2 Affected
SUSE Linux Enterprise Server 15 SP1 LTSS exiv2 Affected
SUSE Linux Enterprise Server 15 SP2 exiv2 Affected
SUSE Linux Enterprise Server 15 SP2 LTSS exiv2 Affected
SUSE Linux Enterprise Server 15 SP3 exiv2 Affected
SUSE Linux Enterprise Server 15 SP4 exiv2 Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 exiv2 Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 exiv2 Affected
SUSE Linux Enterprise Storage 7 exiv2 Affected
SUSE Linux Enterprise Storage 7.1 exiv2 Affected
SUSE Manager Proxy 4.0 exiv2 Analysis
SUSE Manager Proxy 4.1 exiv2 Affected
SUSE Manager Proxy 4.2 exiv2 Affected
SUSE Manager Proxy 4.3 exiv2 Affected
SUSE Manager Retail Branch Server 4.0 exiv2 Analysis
SUSE Manager Retail Branch Server 4.1 exiv2 Affected
SUSE Manager Retail Branch Server 4.2 exiv2 Affected
SUSE Manager Retail Branch Server 4.3 exiv2 Affected
SUSE Manager Server 4.0 exiv2 Analysis
SUSE Manager Server 4.1 exiv2 Affected
SUSE Manager Server 4.2 exiv2 Affected
SUSE Manager Server 4.3 exiv2 Affected
SUSE OpenStack Cloud 8 exiv2 Affected
SUSE OpenStack Cloud 9 exiv2 Affected
SUSE OpenStack Cloud Crowbar 8 exiv2 Affected
SUSE OpenStack Cloud Crowbar 9 exiv2 Affected