Upstream information

CVE-2021-32490 at MITRE

Description

A flaw was found in djvulibre-3.5.28 and earlier. An out of bounds write in function DJVU::filter_bv() via crafted djvu file may lead to application crash and other consequences.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.5
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Local Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1185895 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-1649
SUSE Enterprise Storage 6
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-Storage-6-2021-1649
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-1649
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-1649
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-1649
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • libdjvulibre-devel >= 3.5.27-11.3.1
  • libdjvulibre21 >= 3.5.27-11.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-1641
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • libdjvulibre-devel >= 3.5.27-11.3.1
  • libdjvulibre21 >= 3.5.27-11.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-1641
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • djvulibre >= 3.5.27-11.3.1
  • djvulibre-doc >= 3.5.27-11.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1641
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • djvulibre >= 3.5.27-11.3.1
  • djvulibre-doc >= 3.5.27-11.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-1641
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • djvulibre >= 3.5.27-11.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2021-1641
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • djvulibre >= 3.5.27-11.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2021-1641
SUSE Linux Enterprise Server 15 SP1-BCL
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-1649
SUSE Linux Enterprise Server 15 SP1-LTSS
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-1649
SUSE Linux Enterprise Server 15-LTSS
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-1649
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-1649
SUSE Linux Enterprise Server for SAP Applications 15
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-1649
SUSE Manager Proxy 4.0
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-1649
SUSE Manager Retail Branch Server 4.0
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-1649
SUSE Manager Server 4.0
  • libdjvulibre-devel >= 3.5.27-3.11.1
  • libdjvulibre21 >= 3.5.27-3.11.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-1649
openSUSE Leap 15.2
  • djvulibre >= 3.5.27-lp152.7.3.1
  • djvulibre-debuginfo >= 3.5.27-lp152.7.3.1
  • djvulibre-debugsource >= 3.5.27-lp152.7.3.1
  • djvulibre-doc >= 3.5.27-lp152.7.3.1
  • libdjvulibre-devel >= 3.5.27-lp152.7.3.1
  • libdjvulibre21 >= 3.5.27-lp152.7.3.1
  • libdjvulibre21-debuginfo >= 3.5.27-lp152.7.3.1
Patchnames:
openSUSE-2021-759
openSUSE Leap 15.3
  • djvulibre >= 3.5.27-11.3.1
  • djvulibre-doc >= 3.5.27-11.3.1
  • libdjvulibre-devel >= 3.5.27-11.3.1
  • libdjvulibre21 >= 3.5.27-11.3.1
Patchnames:
openSUSE-SLE-15.3-2021-1641
openSUSE Tumbleweed
  • djvulibre >= 3.5.28-3.2
  • djvulibre-doc >= 3.5.28-3.2
  • libdjvulibre-devel >= 3.5.28-3.2
  • libdjvulibre21 >= 3.5.28-3.2
Patchnames:
openSUSE Tumbleweed GA djvulibre-3.5.28-3.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 djvulibre Not affected
SUSE CaaS Platform 4.0 djvulibre Released
SUSE Enterprise Storage 6 djvulibre Released
SUSE Linux Enterprise High Performance Computing 12 SP5 djvulibre Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS djvulibre Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS djvulibre Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS djvulibre Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 djvulibre Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 djvulibre Released
SUSE Linux Enterprise Point of Service 11 SP3 djvulibre Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS djvulibre Not affected
SUSE Linux Enterprise Server 12 SP2 BCL djvulibre Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON djvulibre Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP djvulibre Not affected
SUSE Linux Enterprise Server 12 SP3 BCL djvulibre Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS djvulibre Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS djvulibre Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS djvulibre Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS djvulibre Not affected
SUSE Linux Enterprise Server 12 SP5 djvulibre Not affected
SUSE Linux Enterprise Server 15 LTSS djvulibre Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux djvulibre Released
SUSE Linux Enterprise Server 15 SP1 LTSS djvulibre Released
SUSE Linux Enterprise Server ESPOS 15 djvulibre Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 djvulibre Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 djvulibre Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 djvulibre Not affected
SUSE Linux Enterprise Server for SAP Applications 15 djvulibre Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 djvulibre Released
SUSE Manager Proxy 4.0 djvulibre Released
SUSE Manager Retail Branch Server 4.0 djvulibre Released
SUSE Manager Server 4.0 djvulibre Released
SUSE OpenStack Cloud 8 djvulibre Not affected
SUSE OpenStack Cloud 9 djvulibre Not affected
SUSE OpenStack Cloud Crowbar 8 djvulibre Not affected
SUSE OpenStack Cloud Crowbar 9 djvulibre Not affected
SUSE Package Hub 15 djvulibre Released