Upstream information

CVE-2021-3121 at MITRE

Description

An issue was discovered in GoGo Protobuf before 1.3.2. plugin/unmarshal/unmarshal.go lacks certain index validation, aka the "skippy peanut butter" issue.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.6 8.6
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1182185 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4.5/kube-apiserver:v1.18.20
Image caasp45/caasp-kube-apiserver-image
  • kubernetes-1.18-apiserver >= 1.18.20-4.11.3
Container caasp/v4.5/kube-controller-manager:v1.18.20
Image caasp45/caasp-kube-controller-manager-image
  • kubernetes-1.18-controller-manager >= 1.18.20-4.11.3
Container caasp/v4.5/kube-proxy:v1.18.20
Image caasp45/caasp-kube-proxy-image
  • kubernetes-1.18-proxy >= 1.18.20-4.11.3
Container caasp/v4.5/kube-scheduler:v1.18.20
Image caasp45/caasp-kube-scheduler-image
  • kubernetes-1.18-scheduler >= 1.18.20-4.11.3
SUSE CaaS Platform 4.5
  • caasp-release >= 4.5.5-1.19.3
  • kubernetes-1.18-kubeadm >= 1.18.20-4.11.3
  • kubernetes-1.18-kubelet >= 1.18.20-4.11.3
  • release-notes-caasp >= 4.5.20210907-3.22.3
  • skuba >= 2.1.15-3.15.13.2
  • skuba-update >= 2.1.15-3.15.13.2
Patchnames:
SUSE-SUSE-CAASP-4.5-2021-3049
openSUSE Tumbleweed
  • kubernetes1.18-apiserver >= 1.18.20-1.2
  • kubernetes1.18-client >= 1.18.20-1.2
  • kubernetes1.18-client-common >= 1.18.20-1.2
  • kubernetes1.18-controller-manager >= 1.18.20-1.2
  • kubernetes1.18-kubeadm >= 1.18.20-1.2
  • kubernetes1.18-kubelet >= 1.18.20-1.2
  • kubernetes1.18-kubelet-common >= 1.18.20-1.2
  • kubernetes1.18-proxy >= 1.18.20-1.2
  • kubernetes1.18-scheduler >= 1.18.20-1.2
  • kubernetes1.19-apiserver >= 1.19.15-1.1
  • kubernetes1.19-client >= 1.19.15-1.1
  • kubernetes1.19-client-common >= 1.19.15-1.1
  • kubernetes1.19-controller-manager >= 1.19.15-1.1
  • kubernetes1.19-kubeadm >= 1.19.15-1.1
  • kubernetes1.19-kubelet >= 1.19.15-1.1
  • kubernetes1.19-kubelet-common >= 1.19.15-1.1
  • kubernetes1.19-proxy >= 1.19.15-1.1
  • kubernetes1.19-scheduler >= 1.19.15-1.1
  • kubernetes1.20-apiserver >= 1.20.11-1.1
  • kubernetes1.20-client >= 1.20.11-1.1
  • kubernetes1.20-client-common >= 1.20.11-1.1
  • kubernetes1.20-controller-manager >= 1.20.11-1.1
  • kubernetes1.20-kubeadm >= 1.20.11-1.1
  • kubernetes1.20-kubelet >= 1.20.11-1.1
  • kubernetes1.20-kubelet-common >= 1.20.11-1.1
  • kubernetes1.20-proxy >= 1.20.11-1.1
  • kubernetes1.20-scheduler >= 1.20.11-1.1
  • kubernetes1.21-apiserver >= 1.21.5-1.1
  • kubernetes1.21-client >= 1.21.5-1.1
  • kubernetes1.21-client-common >= 1.21.5-1.1
  • kubernetes1.21-controller-manager >= 1.21.5-1.1
  • kubernetes1.21-kubeadm >= 1.21.5-1.1
  • kubernetes1.21-kubelet >= 1.21.5-1.1
  • kubernetes1.21-kubelet-common >= 1.21.5-1.1
  • kubernetes1.21-proxy >= 1.21.5-1.1
  • kubernetes1.21-scheduler >= 1.21.5-1.1
  • velero >= 1.7.0-1.1
  • velero-plugin-for-aws >= 1.3.0-1.1
Patchnames:
openSUSE Tumbleweed GA kubernetes1.18-apiserver-1.18.20-1.2
openSUSE Tumbleweed GA kubernetes1.19-apiserver-1.19.15-1.1
openSUSE Tumbleweed GA kubernetes1.20-apiserver-1.20.11-1.1
openSUSE Tumbleweed GA kubernetes1.21-apiserver-1.21.5-1.1
openSUSE Tumbleweed GA velero-1.7.0-1.1
openSUSE Tumbleweed GA velero-plugin-for-aws-1.3.0-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 kubernetes Affected
SUSE CaaS Platform 4.5 kubernetes-1.18 Released
SUSE Enterprise Storage 6 kubernetes Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS kubernetes Affected
SUSE Linux Enterprise Module for Containers 15 SP1 kubernetes Unsupported
SUSE Linux Enterprise Module for Public Cloud 12 kubernetes Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux kubernetes Affected
SUSE Linux Enterprise Server 15 SP1 LTSS kubernetes Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 kubernetes Affected
SUSE Manager Proxy 4.0 kubernetes Unsupported
SUSE Manager Retail Branch Server 4.0 kubernetes Unsupported
SUSE Manager Server 4.0 kubernetes Unsupported