Upstream information

CVE-2021-29950 at MITRE

Description

Thunderbird unprotects a secret OpenPGP key prior to using it for a decryption, signing or key import task. If the task runs into a failure, the secret key may remain in memory in its unprotected state. This vulnerability affects Thunderbird < 78.8.1.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Changed
Confidentiality Impact High Low
Integrity Impact None Low
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1185086 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Workstation Extension 15 SP2
  • MozillaThunderbird >= 78.10.2-8.27.1
  • MozillaThunderbird-translations-common >= 78.10.2-8.27.1
  • MozillaThunderbird-translations-other >= 78.10.2-8.27.1
Patchnames:
SUSE-SLE-Product-WE-15-SP2-2021-1854
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Workstation Extension 15 SP3
  • MozillaThunderbird >= 78.10.2-8.27.1
  • MozillaThunderbird-translations-common >= 78.10.2-8.27.1
  • MozillaThunderbird-translations-other >= 78.10.2-8.27.1
Patchnames:
SUSE-SLE-Product-WE-15-SP3-2021-1854
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Linux Enterprise Workstation Extension 15 SP4
  • MozillaThunderbird >= 91.8.0-150200.8.65.1
  • MozillaThunderbird-translations-common >= 91.8.0-150200.8.65.1
  • MozillaThunderbird-translations-other >= 91.8.0-150200.8.65.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP4 GA MozillaThunderbird-91.8.0-150200.8.65.1
openSUSE Leap 15.3
  • MozillaThunderbird >= 78.10.2-8.27.1
  • MozillaThunderbird-translations-common >= 78.10.2-8.27.1
  • MozillaThunderbird-translations-other >= 78.10.2-8.27.1
Patchnames:
openSUSE-SLE-15.3-2021-1854
openSUSE Leap 15.4
  • MozillaThunderbird >= 91.8.0-150200.8.65.1
  • MozillaThunderbird-translations-common >= 91.8.0-150200.8.65.1
  • MozillaThunderbird-translations-other >= 91.8.0-150200.8.65.1
Patchnames:
openSUSE Leap 15.4 GA MozillaThunderbird-91.8.0-150200.8.65.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 15 SP2 MozillaThunderbird In progress
SUSE Linux Enterprise Server 15 SP2 MozillaThunderbird In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP2 MozillaThunderbird In progress
SUSE Linux Enterprise Workstation Extension 15 SP2 MozillaThunderbird In progress