Upstream information

CVE-2021-29921 at MITRE

Description

In Python before 3,9,5, the ipaddress library mishandles leading zero characters in the octets of an IP address string. This (in some situations) allows attackers to bypass access control that is based on IP addresses.

SUSE information

Overall state of this security issue: Analysis

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.6
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1185706 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libpython3_9-1_0 >= 3.9.6-4.3.3
  • python39 >= 3.9.6-4.3.4
  • python39-base >= 3.9.6-4.3.3
  • python39-curses >= 3.9.6-4.3.4
  • python39-dbm >= 3.9.6-4.3.4
  • python39-devel >= 3.9.6-4.3.3
  • python39-idle >= 3.9.6-4.3.4
  • python39-tk >= 3.9.6-4.3.4
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-2940
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • python39-tools >= 3.9.6-4.3.3
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2021-2940
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • libpython3_9-1_0-32bit >= 3.9.6-4.3.3
  • python39-32bit >= 3.9.6-4.3.4
  • python39-base-32bit >= 3.9.6-4.3.3
  • python39-doc >= 3.9.6-4.3.1
  • python39-doc-devhelp >= 3.9.6-4.3.1
  • python39-testsuite >= 3.9.6-4.3.3
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-2940
openSUSE Leap 15.3
  • python39 >= 3.9.6-4.3.4
  • python39-32bit >= 3.9.6-4.3.4
  • python39-curses >= 3.9.6-4.3.4
  • python39-dbm >= 3.9.6-4.3.4
  • python39-idle >= 3.9.6-4.3.4
  • python39-tk >= 3.9.6-4.3.4
Patchnames:
openSUSE-SLE-15.3-2021-2940


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Carwos 1 python3 Not affected
HPE Helion OpenStack 8 python Not affected
HPE Helion OpenStack 8 python3 Not affected
SUSE CaaS Platform 4.0 python Not affected
SUSE CaaS Platform 4.0 python3 Not affected
SUSE Enterprise Storage 6 python Not affected
SUSE Enterprise Storage 6 python3 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 python Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 python3 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 python36 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS python Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS python3 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 python Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 python3 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 python39 Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 python Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 python3 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 python39 Released
SUSE Linux Enterprise Module for Python 2 15 SP2 python Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 python3 Not affected
SUSE Linux Enterprise Point of Service 11 SP3 python Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS python Not affected
SUSE Linux Enterprise Server 12 SP2 BCL python Not affected
SUSE Linux Enterprise Server 12 SP2 BCL python3 Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON python Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON python3 Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP python Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP python3 Not affected
SUSE Linux Enterprise Server 12 SP3 BCL python Not affected
SUSE Linux Enterprise Server 12 SP3 BCL python3 Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS python Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS python3 Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS python Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS python3 Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS python Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS python3 Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS python Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS python3 Not affected
SUSE Linux Enterprise Server 12 SP5 python Not affected
SUSE Linux Enterprise Server 12 SP5 python3 Not affected
SUSE Linux Enterprise Server 12 SP5 python36 Not affected
SUSE Linux Enterprise Server 15 LTSS python Not affected
SUSE Linux Enterprise Server 15 LTSS python3 Not affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux python Not affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux python3 Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS python Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS python3 Not affected
SUSE Linux Enterprise Server ESPOS 15 python Not affected
SUSE Linux Enterprise Server ESPOS 15 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python36 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 python Not affected
SUSE Linux Enterprise Server for SAP Applications 15 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python3 Not affected
SUSE Manager Proxy 4.0 python Not affected
SUSE Manager Proxy 4.0 python3 Not affected
SUSE Manager Retail Branch Server 4.0 python Not affected
SUSE Manager Retail Branch Server 4.0 python3 Not affected
SUSE Manager Server 4.0 python Not affected
SUSE Manager Server 4.0 python3 Not affected
SUSE OpenStack Cloud 8 python Not affected
SUSE OpenStack Cloud 8 python3 Not affected
SUSE OpenStack Cloud 9 python Not affected
SUSE OpenStack Cloud 9 python3 Not affected
SUSE OpenStack Cloud Crowbar 8 python Not affected
SUSE OpenStack Cloud Crowbar 8 python3 Not affected
SUSE OpenStack Cloud Crowbar 9 python Not affected
SUSE OpenStack Cloud Crowbar 9 python3 Not affected