Upstream information

CVE-2021-28675 at MITRE

Description

An issue was discovered in Pillow before 8.2.0. PSDImagePlugin.PsdImageFile lacked a sanity check on the number of input layers relative to the size of the data block. This could lead to a DoS on Image.open prior to Image.load.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 7.5
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Local Network
Attack Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1185804 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion OpenStack 8
  • python-Pillow >= 4.2.1-3.14.1
Patchnames:
HPE-Helion-OpenStack-8-2021-1939
SUSE Liberty Linux 8
  • python3-pillow >= 5.1.1-16.el8
Patchnames:
RHSA-2021:4149
SUSE OpenStack Cloud 7
  • python-Pillow >= 2.8.1-4.22.1
Patchnames:
SUSE-OpenStack-Cloud-7-2021-1940
SUSE OpenStack Cloud 8
  • python-Pillow >= 4.2.1-3.14.1
Patchnames:
SUSE-OpenStack-Cloud-8-2021-1939
SUSE OpenStack Cloud 9
  • python-Pillow >= 5.2.0-3.8.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-1938
SUSE OpenStack Cloud Crowbar 8
  • python-Pillow >= 4.2.1-3.14.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-1939
SUSE OpenStack Cloud Crowbar 9
  • python-Pillow >= 5.2.0-3.8.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-1938
openSUSE Leap 15.5
  • python3-Pillow >= 7.2.0-150300.3.12.1
  • python3-Pillow-tk >= 7.2.0-150300.3.12.1
Patchnames:
openSUSE-SLE-15.5-2024-1607


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP5 python-Pillow Already fixed
SUSE Linux Enterprise Desktop 15 SP6 python-Pillow Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP5 python-Pillow Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP6 python-Pillow Already fixed
SUSE Linux Enterprise Module for Python 3 15 SP5 python-Pillow Already fixed
SUSE Linux Enterprise Module for Python 3 15 SP6 python-Pillow Already fixed
SUSE Linux Enterprise Server 15 SP5 python-Pillow Already fixed
SUSE Linux Enterprise Server 15 SP6 python-Pillow Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 python-Pillow Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP6 python-Pillow Already fixed
SUSE Manager Proxy 4.3 python-Pillow Already fixed
SUSE Manager Retail Branch Server 4.3 python-Pillow Already fixed
SUSE Manager Server 4.3 python-Pillow Already fixed
openSUSE Leap 15.5 python-Pillow Released
openSUSE Leap 15.6 python-Pillow Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 python-Pillow Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 python-Pillow Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS python-Pillow Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS python-Pillow Already fixed
SUSE Linux Enterprise Module for Python 3 15 SP4 python-Pillow Already fixed
SUSE Linux Enterprise Server 15 SP4 python-Pillow Already fixed
SUSE Linux Enterprise Server 15 SP4-LTSS python-Pillow Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 python-Pillow Already fixed
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 python-Pillow Released
SUSE Enterprise Storage 4 python-Pillow Affected
SUSE OpenStack Cloud 7 python-Pillow Released
SUSE OpenStack Cloud 8 python-Pillow Released
SUSE OpenStack Cloud 9 python-Pillow Released
SUSE OpenStack Cloud Crowbar 8 python-Pillow Released
SUSE OpenStack Cloud Crowbar 9 python-Pillow Released
openSUSE Leap 15.3 python-Pillow Released


SUSE Timeline for this CVE

CVE page created: Fri May 7 16:01:51 2021
CVE page last modified: Wed May 15 16:31:56 2024