Upstream information

CVE-2021-28657 at MITRE

Description

A carefully crafted or corrupt file may trigger an infinite loop in Tika's MP3Parser up to and including Tika 1.25. Apache Tika users should upgrade to 1.26 or later.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 5.5
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1184892 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP2-Manager-4-1-Proxy-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Proxy-BYOS-EC2-HVM
Image SLES15-SP2-Manager-4-1-Proxy-BYOS-GCE
  • patterns-suma_proxy >= 4.1-6.9.2
  • python3-spacewalk-certs-tools >= 4.1.17-3.17.2
  • python3-uyuni-common-libs >= 4.1.8-3.9.1
  • spacewalk-backend >= 4.1.25-4.32.6
  • spacewalk-base-minimal >= 4.1.26-3.24.8
  • spacewalk-base-minimal-config >= 4.1.26-3.24.8
  • spacewalk-certs-tools >= 4.1.17-3.17.2
  • spacewalk-proxy-broker >= 4.1.5-3.12.2
  • spacewalk-proxy-common >= 4.1.5-3.12.2
  • spacewalk-proxy-management >= 4.1.5-3.12.2
  • spacewalk-proxy-package-manager >= 4.1.5-3.12.2
  • spacewalk-proxy-redirect >= 4.1.5-3.12.2
  • spacewalk-proxy-salt >= 4.1.5-3.12.2
  • susemanager-build-keys >= 15.2.4-3.17.1
  • susemanager-build-keys-web >= 15.2.4-3.17.1
Image SLES15-SP2-Manager-4-1-Server-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Server-BYOS-EC2-HVM
Image SLES15-SP2-Manager-4-1-Server-BYOS-GCE
  • cobbler >= 3.0.0+git20190806.32c4bae0-5.11.1
  • patterns-suma_server >= 4.1-6.9.2
  • py26-compat-salt >= 2016.11.10-6.14.2
  • py27-compat-salt >= 3000.3-6.3.2
  • python3-spacewalk-certs-tools >= 4.1.17-3.17.2
  • python3-uyuni-common-libs >= 4.1.8-3.9.1
  • spacewalk-admin >= 4.1.9-3.12.2
  • spacewalk-backend >= 4.1.25-4.32.6
  • spacewalk-backend-app >= 4.1.25-4.32.6
  • spacewalk-backend-applet >= 4.1.25-4.32.6
  • spacewalk-backend-config-files >= 4.1.25-4.32.6
  • spacewalk-backend-config-files-common >= 4.1.25-4.32.6
  • spacewalk-backend-config-files-tool >= 4.1.25-4.32.6
  • spacewalk-backend-iss >= 4.1.25-4.32.6
  • spacewalk-backend-iss-export >= 4.1.25-4.32.6
  • spacewalk-backend-package-push-server >= 4.1.25-4.32.6
  • spacewalk-backend-server >= 4.1.25-4.32.6
  • spacewalk-backend-sql >= 4.1.25-4.32.6
  • spacewalk-backend-sql-postgresql >= 4.1.25-4.32.6
  • spacewalk-backend-tools >= 4.1.25-4.32.6
  • spacewalk-backend-xml-export-libs >= 4.1.25-4.32.6
  • spacewalk-backend-xmlrpc >= 4.1.25-4.32.6
  • spacewalk-base >= 4.1.26-3.24.8
  • spacewalk-base-minimal >= 4.1.26-3.24.8
  • spacewalk-base-minimal-config >= 4.1.26-3.24.8
  • spacewalk-branding >= 4.1.12-3.12.2
  • spacewalk-certs-tools >= 4.1.17-3.17.2
  • spacewalk-html >= 4.1.26-3.24.8
  • spacewalk-java >= 4.1.36-3.44.1
  • spacewalk-java-config >= 4.1.36-3.44.1
  • spacewalk-java-lib >= 4.1.36-3.44.1
  • spacewalk-java-postgresql >= 4.1.36-3.44.1
  • spacewalk-taskomatic >= 4.1.36-3.44.1
  • spacewalk-utils >= 4.1.16-3.18.2
  • susemanager >= 4.1.26-3.25.1
  • susemanager-build-keys >= 15.2.4-3.17.1
  • susemanager-build-keys-web >= 15.2.4-3.17.1
  • susemanager-doc-indexes >= 4.1-11.34.8
  • susemanager-docs_en >= 4.1-11.34.2
  • susemanager-docs_en-pdf >= 4.1-11.34.2
  • susemanager-schema >= 4.1.21-3.30.6
  • susemanager-sls >= 4.1.28-3.42.1
  • susemanager-sync-data >= 4.1.14-3.23.2
  • susemanager-tools >= 4.1.26-3.25.1
  • susemanager-web-libs >= 4.1.26-3.24.8
  • tika-core >= 1.26-3.5.2
SUSE Linux Enterprise Module for SUSE Manager Server 4.0
SUSE Manager Server 4.0
  • cobbler >= 3.0.0+git20190806.32c4bae0-7.22.3
  • grafana-formula >= 0.2.3-4.16.3
  • patterns-suma_retail >= 4.0-9.19.3
  • patterns-suma_server >= 4.0-9.19.3
  • prometheus-exporters-formula >= 0.7.6-3.19.3
  • pxe-default-image-sle15 >= 4.0.1-20210621145802
  • py26-compat-salt >= 2016.11.10-10.28.3
  • py27-compat-salt >= 3000.3-4.3.3
  • python3-spacewalk-backend-libs >= 4.0.38-3.47.4
  • spacewalk-backend >= 4.0.38-3.47.4
  • spacewalk-backend-app >= 4.0.38-3.47.4
  • spacewalk-backend-applet >= 4.0.38-3.47.4
  • spacewalk-backend-config-files >= 4.0.38-3.47.4
  • spacewalk-backend-config-files-common >= 4.0.38-3.47.4
  • spacewalk-backend-config-files-tool >= 4.0.38-3.47.4
  • spacewalk-backend-iss >= 4.0.38-3.47.4
  • spacewalk-backend-iss-export >= 4.0.38-3.47.4
  • spacewalk-backend-package-push-server >= 4.0.38-3.47.4
  • spacewalk-backend-server >= 4.0.38-3.47.4
  • spacewalk-backend-sql >= 4.0.38-3.47.4
  • spacewalk-backend-sql-postgresql >= 4.0.38-3.47.4
  • spacewalk-backend-tools >= 4.0.38-3.47.4
  • spacewalk-backend-xml-export-libs >= 4.0.38-3.47.4
  • spacewalk-backend-xmlrpc >= 4.0.38-3.47.4
  • spacewalk-base >= 4.0.28-3.45.1
  • spacewalk-base-minimal >= 4.0.28-3.45.1
  • spacewalk-base-minimal-config >= 4.0.28-3.45.1
  • spacewalk-html >= 4.0.28-3.45.1
  • spacewalk-java >= 4.0.44-3.57.5
  • spacewalk-java-config >= 4.0.44-3.57.5
  • spacewalk-java-lib >= 4.0.44-3.57.5
  • spacewalk-java-postgresql >= 4.0.44-3.57.5
  • spacewalk-taskomatic >= 4.0.44-3.57.5
  • spacewalk-utils >= 4.0.21-3.30.3
  • susemanager >= 4.0.34-3.52.3
  • susemanager-doc-indexes >= 4.0-10.36.4
  • susemanager-docs_en >= 4.0-10.36.3
  • susemanager-docs_en-pdf >= 4.0-10.36.3
  • susemanager-sls >= 4.0.35-3.48.3
  • susemanager-tools >= 4.0.34-3.52.3
  • susemanager-web-libs >= 4.0.28-3.45.1
  • tika-core >= 1.26-3.6.3
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.0-2021-2114
SUSE Linux Enterprise Module for SUSE Manager Server 4.1
SUSE Manager Server 4.1
  • cobbler >= 3.0.0+git20190806.32c4bae0-5.11.1
  • golang-github-prometheus-node_exporter >= 1.1.2-3.6.5
  • grafana-formula >= 0.4.1-3.9.2
  • patterns-suma_retail >= 4.1-6.9.2
  • patterns-suma_server >= 4.1-6.9.2
  • prometheus-exporters-formula >= 0.9.1-3.22.1
  • py26-compat-salt >= 2016.11.10-6.14.2
  • py27-compat-salt >= 3000.3-6.3.2
  • python3-spacewalk-certs-tools >= 4.1.17-3.17.2
  • python3-uyuni-common-libs >= 4.1.8-3.9.1
  • spacewalk-admin >= 4.1.9-3.12.2
  • spacewalk-backend >= 4.1.25-4.32.6
  • spacewalk-backend-app >= 4.1.25-4.32.6
  • spacewalk-backend-applet >= 4.1.25-4.32.6
  • spacewalk-backend-config-files >= 4.1.25-4.32.6
  • spacewalk-backend-config-files-common >= 4.1.25-4.32.6
  • spacewalk-backend-config-files-tool >= 4.1.25-4.32.6
  • spacewalk-backend-iss >= 4.1.25-4.32.6
  • spacewalk-backend-iss-export >= 4.1.25-4.32.6
  • spacewalk-backend-package-push-server >= 4.1.25-4.32.6
  • spacewalk-backend-server >= 4.1.25-4.32.6
  • spacewalk-backend-sql >= 4.1.25-4.32.6
  • spacewalk-backend-sql-postgresql >= 4.1.25-4.32.6
  • spacewalk-backend-tools >= 4.1.25-4.32.6
  • spacewalk-backend-xml-export-libs >= 4.1.25-4.32.6
  • spacewalk-backend-xmlrpc >= 4.1.25-4.32.6
  • spacewalk-base >= 4.1.26-3.24.8
  • spacewalk-base-minimal >= 4.1.26-3.24.8
  • spacewalk-base-minimal-config >= 4.1.26-3.24.8
  • spacewalk-branding >= 4.1.12-3.12.2
  • spacewalk-certs-tools >= 4.1.17-3.17.2
  • spacewalk-html >= 4.1.26-3.24.8
  • spacewalk-java >= 4.1.36-3.44.1
  • spacewalk-java-config >= 4.1.36-3.44.1
  • spacewalk-java-lib >= 4.1.36-3.44.1
  • spacewalk-java-postgresql >= 4.1.36-3.44.1
  • spacewalk-taskomatic >= 4.1.36-3.44.1
  • spacewalk-utils >= 4.1.16-3.18.2
  • spacewalk-utils-extras >= 4.1.16-3.18.2
  • susemanager >= 4.1.26-3.25.1
  • susemanager-build-keys >= 15.2.4-3.17.1
  • susemanager-build-keys-web >= 15.2.4-3.17.1
  • susemanager-doc-indexes >= 4.1-11.34.8
  • susemanager-docs_en >= 4.1-11.34.2
  • susemanager-docs_en-pdf >= 4.1-11.34.2
  • susemanager-schema >= 4.1.21-3.30.6
  • susemanager-sls >= 4.1.28-3.42.1
  • susemanager-sync-data >= 4.1.14-3.23.2
  • susemanager-tools >= 4.1.26-3.25.1
  • susemanager-web-libs >= 4.1.26-3.24.8
  • tika-core >= 1.26-3.5.2
  • uyuni-config-modules >= 4.1.28-3.42.1
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.1-2021-2098


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Manager Server Module 4.0 tika-core In progress
SUSE Manager Server Module 4.1 tika-core Released
SUSE Manager Server Module 4.2 tika-core Not affected
SUSE Manager Server Module 4.3 tika-core Not affected