Upstream information

CVE-2021-27928 at MITRE

Description

A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.2 7.2
Vector CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required High High
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1183770 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-2617
SUSE Enterprise Storage 6
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-Storage-6-2021-2617
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-2617
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-2617
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-2617
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb-bench >= 10.4.20-3.9.1
  • mariadb-galera >= 10.4.20-3.9.1
  • mariadb-rpm-macros >= 10.4.20-3.9.1
  • mariadb-test >= 10.4.20-3.9.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-2616
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-2617
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb-bench >= 10.5.11-3.3.1
  • mariadb-galera >= 10.4.20-3.9.1
  • mariadb-rpm-macros >= 10.5.11-3.3.1
  • mariadb-test >= 10.5.11-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-2605
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-2616
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-2617
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • libmariadbd-devel >= 10.4.20-3.9.1
  • libmariadbd19 >= 10.4.20-3.9.1
  • mariadb >= 10.4.20-3.9.1
  • mariadb-client >= 10.4.20-3.9.1
  • mariadb-errormessages >= 10.4.20-3.9.1
  • mariadb-tools >= 10.4.20-3.9.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2021-2616
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • libmariadbd-devel >= 10.5.11-3.3.1
  • libmariadbd19 >= 10.5.11-3.3.1
  • mariadb >= 10.5.11-3.3.1
  • mariadb-client >= 10.5.11-3.3.1
  • mariadb-errormessages >= 10.5.11-3.3.1
  • mariadb-tools >= 10.5.11-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP3-2021-2605
SUSE Linux Enterprise Server 15 SP1-BCL
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-2617
SUSE Linux Enterprise Server 15 SP1-LTSS
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-2617
SUSE Linux Enterprise Server 15-LTSS
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-2617
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-2617
SUSE Linux Enterprise Server for SAP Applications 15
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-2617
SUSE Manager Proxy 4.0
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-2617
SUSE Manager Retail Branch Server 4.0
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-2617
SUSE Manager Server 4.0
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.2.39-3.40.1
  • mariadb-client >= 10.2.39-3.40.1
  • mariadb-errormessages >= 10.2.39-3.40.1
  • mariadb-tools >= 10.2.39-3.40.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-2617
openSUSE Leap 15.3
  • libmariadbd-devel >= 10.5.11-3.3.1
  • libmariadbd19 >= 10.5.11-3.3.1
  • libmysqld-devel >= 10.2.39-3.40.1
  • libmysqld19 >= 10.2.39-3.40.1
  • mariadb >= 10.5.11-3.3.1
  • mariadb-bench >= 10.5.11-3.3.1
  • mariadb-client >= 10.5.11-3.3.1
  • mariadb-errormessages >= 10.5.11-3.3.1
  • mariadb-galera >= 10.4.20-3.9.1
  • mariadb-rpm-macros >= 10.5.11-3.3.1
  • mariadb-test >= 10.5.11-3.3.1
  • mariadb-tools >= 10.5.11-3.3.1
Patchnames:
openSUSE-SLE-15.3-2021-2605
openSUSE-SLE-15.3-2021-2616
openSUSE-SLE-15.3-2021-2617

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • mariadb >= 10.2.39-3.36.1
  • mariadb-client >= 10.2.39-3.36.1
  • mariadb-client-debuginfo >= 10.2.39-3.36.1
  • mariadb-debuginfo >= 10.2.39-3.36.1
  • mariadb-debugsource >= 10.2.39-3.36.1
  • mariadb-errormessages >= 10.2.39-3.36.1
  • mariadb-tools >= 10.2.39-3.36.1
  • mariadb-tools-debuginfo >= 10.2.39-3.36.1
SUSE Linux Enterprise Server 12 SP4-LTSS
  • mariadb >= 10.2.39-3.36.1
  • mariadb-client >= 10.2.39-3.36.1
  • mariadb-client-debuginfo >= 10.2.39-3.36.1
  • mariadb-debuginfo >= 10.2.39-3.36.1
  • mariadb-debugsource >= 10.2.39-3.36.1
  • mariadb-errormessages >= 10.2.39-3.36.1
  • mariadb-tools >= 10.2.39-3.36.1
  • mariadb-tools-debuginfo >= 10.2.39-3.36.1
SUSE Linux Enterprise Server 12 SP5
  • mariadb >= 10.2.39-3.36.1
  • mariadb-client >= 10.2.39-3.36.1
  • mariadb-client-debuginfo >= 10.2.39-3.36.1
  • mariadb-debuginfo >= 10.2.39-3.36.1
  • mariadb-debugsource >= 10.2.39-3.36.1
  • mariadb-errormessages >= 10.2.39-3.36.1
  • mariadb-tools >= 10.2.39-3.36.1
  • mariadb-tools-debuginfo >= 10.2.39-3.36.1
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • mariadb >= 10.2.39-3.36.1
  • mariadb-client >= 10.2.39-3.36.1
  • mariadb-client-debuginfo >= 10.2.39-3.36.1
  • mariadb-debuginfo >= 10.2.39-3.36.1
  • mariadb-debugsource >= 10.2.39-3.36.1
  • mariadb-errormessages >= 10.2.39-3.36.1
  • mariadb-tools >= 10.2.39-3.36.1
  • mariadb-tools-debuginfo >= 10.2.39-3.36.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • mariadb >= 10.2.39-3.36.1
  • mariadb-client >= 10.2.39-3.36.1
  • mariadb-client-debuginfo >= 10.2.39-3.36.1
  • mariadb-debuginfo >= 10.2.39-3.36.1
  • mariadb-debugsource >= 10.2.39-3.36.1
  • mariadb-errormessages >= 10.2.39-3.36.1
  • mariadb-tools >= 10.2.39-3.36.1
  • mariadb-tools-debuginfo >= 10.2.39-3.36.1
SUSE OpenStack Cloud 9
  • mariadb >= 10.2.39-3.36.1
  • mariadb-client >= 10.2.39-3.36.1
  • mariadb-client-debuginfo >= 10.2.39-3.36.1
  • mariadb-debuginfo >= 10.2.39-3.36.1
  • mariadb-debugsource >= 10.2.39-3.36.1
  • mariadb-errormessages >= 10.2.39-3.36.1
  • mariadb-galera >= 10.2.39-3.36.1
  • mariadb-tools >= 10.2.39-3.36.1
  • mariadb-tools-debuginfo >= 10.2.39-3.36.1
SUSE OpenStack Cloud Crowbar 9
  • mariadb >= 10.2.39-3.36.1
  • mariadb-client >= 10.2.39-3.36.1
  • mariadb-client-debuginfo >= 10.2.39-3.36.1
  • mariadb-debuginfo >= 10.2.39-3.36.1
  • mariadb-debugsource >= 10.2.39-3.36.1
  • mariadb-errormessages >= 10.2.39-3.36.1
  • mariadb-galera >= 10.2.39-3.36.1
  • mariadb-tools >= 10.2.39-3.36.1
  • mariadb-tools-debuginfo >= 10.2.39-3.36.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 mariadb Affected
SUSE CaaS Platform 4.0 mariadb In progress
SUSE Enterprise Storage 6 mariadb In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 mariadb In progress
SUSE Linux Enterprise High Performance Computing 15 LTSS mariadb In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS mariadb In progress
SUSE Linux Enterprise Module for Server Applications 15 SP2 mariadb Released
SUSE Linux Enterprise Point of Service Image Server 12 mariadb Unsupported
SUSE Linux Enterprise Server 12 SP2 BCL mariadb Affected
SUSE Linux Enterprise Server 12 SP2 ESPOS mariadb Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS mariadb Affected
SUSE Linux Enterprise Server 12 SP3 BCL mariadb Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS mariadb Affected
SUSE Linux Enterprise Server 12 SP3 LTSS mariadb Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS mariadb In progress
SUSE Linux Enterprise Server 12 SP4 LTSS mariadb In progress
SUSE Linux Enterprise Server 12 SP5 mariadb In progress
SUSE Linux Enterprise Server 15 LTSS mariadb In progress
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux mariadb In progress
SUSE Linux Enterprise Server 15 SP1 LTSS mariadb In progress
SUSE Linux Enterprise Server ESPOS 15 mariadb In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 mariadb Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 mariadb In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 mariadb In progress
SUSE Linux Enterprise Server for SAP Applications 15 mariadb In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 mariadb In progress
SUSE Manager Proxy 4.0 mariadb In progress
SUSE Manager Retail Branch Server 4.0 mariadb In progress
SUSE Manager Server 4.0 mariadb In progress
SUSE OpenStack Cloud 7 mariadb Affected
SUSE OpenStack Cloud 8 mariadb Affected
SUSE OpenStack Cloud 9 mariadb In progress
SUSE OpenStack Cloud Crowbar 8 mariadb Affected
SUSE OpenStack Cloud Crowbar 9 mariadb In progress