Upstream information

CVE-2021-27836 at MITRE

Description

An issue was discoverered in in function xls_getWorkSheet in xls.c in libxls 1.6.2, allows attackers to cause a denial of service, via a crafted XLS file.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1192323 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP3
  • libxls-devel >= 1.6.2-bp153.2.6.1
  • libxls-tools >= 1.6.2-bp153.2.6.1
  • libxlsreader8 >= 1.6.2-bp153.2.6.1
Patchnames:
openSUSE-2022-142
SUSE Package Hub 15 SP4
  • libxls-devel >= 1.6.2-bp154.2.3.1
  • libxls-tools >= 1.6.2-bp154.2.3.1
  • libxlsreader8 >= 1.6.2-bp154.2.3.1
Patchnames:
openSUSE-2022-157
openSUSE Leap 15.3
  • libxls-devel >= 1.6.2-bp153.2.6.1
  • libxls-tools >= 1.6.2-bp153.2.6.1
  • libxlsreader8 >= 1.6.2-bp153.2.6.1
Patchnames:
openSUSE-2022-142
openSUSE Leap 15.4
  • libxls-devel >= 1.6.2-bp154.2.3.1
  • libxls-tools >= 1.6.2-bp154.2.3.1
  • libxlsreader8 >= 1.6.2-bp154.2.3.1
Patchnames:
openSUSE-2022-157
openSUSE Tumbleweed
  • libxls-devel >= 1.6.2-3.1
  • libxls-tools >= 1.6.2-3.1
  • libxlsreader8 >= 1.6.2-3.1
Patchnames:
openSUSE Tumbleweed GA libxls-devel-1.6.2-3.1