Upstream information

CVE-2021-27645 at MITRE

Description

The nameserver caching daemon (nscd) in the GNU C Library (aka glibc or libc6) 2.29 through 2.33, when processing a request for netgroup lookup, may crash due to a double-free, potentially resulting in degraded service or Denial of Service on the local system. This is related to netgroupcache.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.9
Vector AV:L/AC:M/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 2.5 2.5
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
Access Vector Local Local
Access Complexity High High
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1182733 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • glibc >= 2.31-7.30
  • glibc-32bit >= 2.31-7.20
  • glibc-devel >= 2.31-7.30
  • glibc-extra >= 2.31-7.30
  • glibc-i18ndata >= 2.31-7.30
  • glibc-info >= 2.31-7.30
  • glibc-lang >= 2.31-7.30
  • glibc-locale >= 2.31-7.30
  • glibc-locale-base >= 2.31-7.30
  • glibc-locale-base-32bit >= 2.31-7.20
  • glibc-profile >= 2.31-7.30
  • nscd >= 2.31-7.30
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • glibc-devel-32bit >= 2.31-7.20
  • glibc-devel-static >= 2.31-7.30
  • glibc-utils >= 2.31-7.1
openSUSE Tumbleweed
  • glibc >= 2.34-1.2
  • glibc-devel >= 2.34-1.2
  • glibc-devel-static >= 2.34-1.2
  • glibc-extra >= 2.34-1.2
  • glibc-html >= 2.34-1.2
  • glibc-i18ndata >= 2.34-1.2
  • glibc-info >= 2.34-1.2
  • glibc-lang >= 2.34-1.2
  • glibc-locale >= 2.34-1.2
  • glibc-locale-base >= 2.34-1.2
  • glibc-profile >= 2.34-1.2
  • nscd >= 2.34-1.2
Patchnames:
openSUSE Tumbleweed GA glibc-2.34-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 glibc Not affected
SUSE CaaS Platform 4.0 glibc Not affected
SUSE Enterprise Storage 6 glibc Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 glibc Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS glibc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS glibc Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 glibc Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 glibc Not affected
SUSE Linux Enterprise Point of Service 11 SP3 glibc Not affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 glibc Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP2 ESPOS glibc Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS glibc Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS glibc Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP5 glibc Not affected
SUSE Linux Enterprise Server 15 ESPOS glibc Not affected
SUSE Linux Enterprise Server 15 LTSS glibc Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS glibc Not affected
SUSE Linux Enterprise Server BCL 12 SP2 glibc Not affected
SUSE Linux Enterprise Server BCL 12 SP3 glibc Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 glibc Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 glibc Not affected
SUSE Manager Proxy 4.0 glibc Not affected
SUSE Manager Retail Branch Server 4.0 glibc Not affected
SUSE Manager Server 4.0 glibc Not affected
SUSE OpenStack Cloud 7 glibc Not affected
SUSE OpenStack Cloud 8 glibc Not affected
SUSE OpenStack Cloud 9 glibc Not affected
SUSE OpenStack Cloud Crowbar 8 glibc Not affected
SUSE OpenStack Cloud Crowbar 9 glibc Not affected