Upstream information

CVE-2021-25218 at MITRE

Description

In BIND 9.16.19, 9.17.16. Also, version 9.16.19-S1 of BIND Supported Preview Edition When a vulnerable version of named receives a query under the circumstances described above, the named process will terminate due to a failed assertion check. The vulnerability affects only BIND 9 releases 9.16.19, 9.17.16, and release 9.16.19-S1 of the BIND Supported Preview Edition.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1189460 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • bind-utils >= 9.16.20-150400.3.6
  • python3-bind >= 9.16.20-150400.3.6
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA bind-utils-9.16.20-150400.3.6
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • bind >= 9.16.20-150400.3.6
  • bind-doc >= 9.16.20-150400.3.6
  • bind-utils >= 9.16.20-150400.3.6
  • python3-bind >= 9.16.20-150400.3.6
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA bind-utils-9.16.20-150400.3.6
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA bind-9.16.20-150400.3.6
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • bind >= 9.16.20-150400.3.6
  • bind-doc >= 9.16.20-150400.3.6
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA bind-9.16.20-150400.3.6
openSUSE Leap 15.4
  • bind >= 9.16.20-150400.3.6
  • bind-utils >= 9.16.20-150400.3.6
  • python3-bind >= 9.16.20-150400.3.6
Patchnames:
openSUSE Leap 15.4 GA bind-9.16.20-150400.3.6
openSUSE Tumbleweed
  • bind >= 9.16.20-1.4
  • bind-doc >= 9.16.20-1.4
  • bind-utils >= 9.16.20-1.4
  • python3-bind >= 9.16.20-1.4
Patchnames:
openSUSE Tumbleweed GA bind-9.16.20-1.4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 bind Not affected
SUSE CaaS Platform 4.0 bind Not affected
SUSE Enterprise Storage 6 bind Not affected
SUSE Linux Enterprise Desktop 15 SP2 bind Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 bind Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS bind Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS bind Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 bind Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 bind Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 bind Not affected
SUSE Linux Enterprise Point of Service 11 SP3 bind Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP2 BCL bind Not affected
SUSE Linux Enterprise Server 12 SP3 BCL bind Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS bind Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS bind Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP5 bind Not affected
SUSE Linux Enterprise Server 15 ESPOS bind Not affected
SUSE Linux Enterprise Server 15 LTSS bind Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS bind Not affected
SUSE Linux Enterprise Server 15 SP2 bind Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 15 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 bind Not affected
SUSE Linux Enterprise Storage 7 bind Not affected
SUSE Manager Proxy 4.0 bind Not affected
SUSE Manager Proxy 4.1 bind Not affected
SUSE Manager Retail Branch Server 4.0 bind Not affected
SUSE Manager Retail Branch Server 4.1 bind Not affected
SUSE Manager Server 4.0 bind Not affected
SUSE Manager Server 4.1 bind Not affected
SUSE OpenStack Cloud 8 bind Not affected
SUSE OpenStack Cloud 9 bind Not affected
SUSE OpenStack Cloud Crowbar 8 bind Not affected
SUSE OpenStack Cloud Crowbar 9 bind Not affected