Upstream information

CVE-2021-22904 at MITRE

Description

The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authentication logic in Action Controller due to a too permissive regular expression. Impacted code uses `authenticate_or_request_with_http_token` or `authenticate_with_http_token` for request authentication.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1185780 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • ruby2.7-rubygem-actionpack-5.2 >= 5.2.6-1.2
  • ruby2.7-rubygem-actionpack-6.0 >= 6.0.4-1.2
  • ruby3.0-rubygem-actionpack-5.2 >= 5.2.6-1.2
  • ruby3.0-rubygem-actionpack-6.0 >= 6.0.4-1.2
Patchnames:
openSUSE Tumbleweed GA ruby2.7-rubygem-actionpack-5.2-5.2.6-1.2
openSUSE Tumbleweed GA ruby2.7-rubygem-actionpack-6.0-6.0.4-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications rubygem-actionpack-3_2 Not affected
SUSE Linux Enterprise High Availability Extension 15 rubygem-actionpack-5_1 Affected
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-actionpack-5_1 Affected
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-actionpack-5_1 Affected
SUSE OpenStack Cloud 7 rubygem-actionpack-4_2 Unsupported
SUSE OpenStack Cloud Crowbar 8 rubygem-actionpack-4_2 Affected
SUSE OpenStack Cloud Crowbar 9 rubygem-actionpack-4_2 Affected
WebYaST for SLE-11 rubygem-actionpack-3_2 Not affected