Upstream information

CVE-2021-22885 at MITRE

Description

A possible information disclosure / unintended method execution vulnerability in Action Pack >= 2.0.0 when using the `redirect_to` or `polymorphic_url`helper with untrusted user input.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1185715 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 15 SP1
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-3.9.1
Patchnames:
SUSE-SLE-Product-HA-15-SP1-2021-1759
SUSE Linux Enterprise High Availability 15 SP2
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-3.9.1
Patchnames:
SUSE-SLE-Product-HA-15-SP2-2021-1759
SUSE Linux Enterprise High Availability 15 SP3
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-3.9.1
Patchnames:
SUSE-SLE-Product-HA-15-SP3-2021-1759
SUSE Linux Enterprise High Availability 15
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-3.9.1
Patchnames:
SUSE-SLE-Product-HA-15-2021-1759
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • ruby2.5-rubygem-actionpack-doc-5_1 >= 5.1.4-3.9.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1759
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • ruby2.5-rubygem-actionpack-doc-5_1 >= 5.1.4-3.9.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-1759
SUSE OpenStack Cloud 7
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.9-7.12.1
Patchnames:
SUSE-OpenStack-Cloud-7-2021-1650
SUSE OpenStack Cloud Crowbar 8
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.9-7.12.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-1650
SUSE OpenStack Cloud Crowbar 9
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.9-7.12.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-1650
openSUSE Leap 15.2
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-lp152.5.6.1
  • ruby2.5-rubygem-actionpack-doc-5_1 >= 5.1.4-lp152.5.6.1
Patchnames:
openSUSE-2021-797
openSUSE Leap 15.3
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-3.9.1
  • ruby2.5-rubygem-actionpack-doc-5_1 >= 5.1.4-3.9.1
Patchnames:
openSUSE-SLE-15.3-2021-1759
openSUSE Tumbleweed
  • ruby2.7-rubygem-actionpack-5.2 >= 5.2.6-1.2
  • ruby2.7-rubygem-actionpack-6.0 >= 6.0.4-1.2
  • ruby3.0-rubygem-actionpack-5.2 >= 5.2.6-1.2
  • ruby3.0-rubygem-actionpack-6.0 >= 6.0.4-1.2
Patchnames:
openSUSE Tumbleweed GA ruby2.7-rubygem-actionpack-5.2-5.2.6-1.2
openSUSE Tumbleweed GA ruby2.7-rubygem-actionpack-6.0-6.0.4-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 15 rubygem-actionpack-5_1 Released
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-actionpack-5_1 Released
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-actionpack-5_1 Released
SUSE Linux Enterprise High Availability Extension 15 SP3 rubygem-actionpack-5_1 Released
SUSE Linux Enterprise Server for SAP All-in-One 11 SP4 rubygem-actionpack-3_2 Affected
SUSE OpenStack Cloud 7 rubygem-actionpack-4_2 Released
SUSE OpenStack Cloud Crowbar 8 rubygem-actionpack-4_2 Released
SUSE OpenStack Cloud Crowbar 9 rubygem-actionpack-4_2 Released
WebYaST for SLE-11 rubygem-actionpack-3_2 Affected