Upstream information

CVE-2021-21898 at MITRE

Description

A code execution vulnerability exists in the dwgCompressor::decompress18() functionality of LibreCad libdxfrw 2.2.0-rc2-19-ge02f3580. A specially-crafted .dwg file can lead to an out-of-bounds write. An attacker can provide a malicious file to trigger this vulnerability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1192936 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP3
  • libdxfrw-devel >= 1.0.1+git.20220109-bp153.2.3.1
  • libdxfrw-tools >= 1.0.1+git.20220109-bp153.2.3.1
  • libdxfrw1 >= 1.0.1+git.20220109-bp153.2.3.1
  • librecad >= 2.2.0~rc3-bp153.2.3.1
  • librecad-parts >= 2.2.0~rc3-bp153.2.3.1
Patchnames:
openSUSE-2022-67
openSUSE Leap 15.3
  • libdxfrw-devel >= 1.0.1+git.20220109-bp153.2.3.1
  • libdxfrw-tools >= 1.0.1+git.20220109-bp153.2.3.1
  • libdxfrw1 >= 1.0.1+git.20220109-bp153.2.3.1
  • librecad >= 2.2.0~rc3-bp153.2.3.1
  • librecad-parts >= 2.2.0~rc3-bp153.2.3.1
Patchnames:
openSUSE-2022-67
openSUSE Tumbleweed
  • libdxfrw-devel >= 1.0.1+git.20211110-1.1
  • libdxfrw-tools >= 1.0.1+git.20211110-1.1
  • libdxfrw1 >= 1.0.1+git.20211110-1.1
Patchnames:
openSUSE Tumbleweed GA libdxfrw-devel-1.0.1+git.20211110-1.1