Upstream information

CVE-2021-21706 at MITRE

Description

In PHP versions 7.3.x below 7.3.31, 7.4.x below 7.4.24 and 8.0.x below 8.0.11, in Microsoft Windows environment, ZipArchive::extractTo may be tricked into writing a file outside target directory when extracting a ZIP file, thus potentially causing files to be created or overwritten, subject to OS permissions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1191314 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • php7 >= 7.4.24-1.1
  • php7-bcmath >= 7.4.24-1.1
  • php7-bz2 >= 7.4.24-1.1
  • php7-calendar >= 7.4.24-1.1
  • php7-cli >= 7.4.24-1.1
  • php7-ctype >= 7.4.24-1.1
  • php7-curl >= 7.4.24-1.1
  • php7-dba >= 7.4.24-1.1
  • php7-devel >= 7.4.24-1.1
  • php7-dom >= 7.4.24-1.1
  • php7-enchant >= 7.4.24-1.1
  • php7-exif >= 7.4.24-1.1
  • php7-fileinfo >= 7.4.24-1.1
  • php7-ftp >= 7.4.24-1.1
  • php7-gd >= 7.4.24-1.1
  • php7-gettext >= 7.4.24-1.1
  • php7-gmp >= 7.4.24-1.1
  • php7-iconv >= 7.4.24-1.1
  • php7-intl >= 7.4.24-1.1
  • php7-json >= 7.4.24-1.1
  • php7-ldap >= 7.4.24-1.1
  • php7-mbstring >= 7.4.24-1.1
  • php7-mysql >= 7.4.24-1.1
  • php7-odbc >= 7.4.24-1.1
  • php7-opcache >= 7.4.24-1.1
  • php7-openssl >= 7.4.24-1.1
  • php7-pcntl >= 7.4.24-1.1
  • php7-pdo >= 7.4.24-1.1
  • php7-pgsql >= 7.4.24-1.1
  • php7-phar >= 7.4.24-1.1
  • php7-posix >= 7.4.24-1.1
  • php7-readline >= 7.4.24-1.1
  • php7-shmop >= 7.4.24-1.1
  • php7-snmp >= 7.4.24-1.1
  • php7-soap >= 7.4.24-1.1
  • php7-sockets >= 7.4.24-1.1
  • php7-sodium >= 7.4.24-1.1
  • php7-sqlite >= 7.4.24-1.1
  • php7-sysvmsg >= 7.4.24-1.1
  • php7-sysvsem >= 7.4.24-1.1
  • php7-sysvshm >= 7.4.24-1.1
  • php7-tidy >= 7.4.24-1.1
  • php7-tokenizer >= 7.4.24-1.1
  • php7-xmlreader >= 7.4.24-1.1
  • php7-xmlrpc >= 7.4.24-1.1
  • php7-xmlwriter >= 7.4.24-1.1
  • php7-xsl >= 7.4.24-1.1
  • php7-zip >= 7.4.24-1.1
  • php7-zlib >= 7.4.24-1.1
  • php8 >= 8.0.11-1.1
  • php8-bcmath >= 8.0.11-1.1
  • php8-bz2 >= 8.0.11-1.1
  • php8-calendar >= 8.0.11-1.1
  • php8-cli >= 8.0.11-1.1
  • php8-ctype >= 8.0.11-1.1
  • php8-curl >= 8.0.11-1.1
  • php8-dba >= 8.0.11-1.1
  • php8-devel >= 8.0.11-1.1
  • php8-dom >= 8.0.11-1.1
  • php8-enchant >= 8.0.11-1.1
  • php8-exif >= 8.0.11-1.1
  • php8-fileinfo >= 8.0.11-1.1
  • php8-ftp >= 8.0.11-1.1
  • php8-gd >= 8.0.11-1.1
  • php8-gettext >= 8.0.11-1.1
  • php8-gmp >= 8.0.11-1.1
  • php8-iconv >= 8.0.11-1.1
  • php8-intl >= 8.0.11-1.1
  • php8-ldap >= 8.0.11-1.1
  • php8-mbstring >= 8.0.11-1.1
  • php8-mysql >= 8.0.11-1.1
  • php8-odbc >= 8.0.11-1.1
  • php8-opcache >= 8.0.11-1.1
  • php8-openssl >= 8.0.11-1.1
  • php8-pcntl >= 8.0.11-1.1
  • php8-pdo >= 8.0.11-1.1
  • php8-pgsql >= 8.0.11-1.1
  • php8-phar >= 8.0.11-1.1
  • php8-posix >= 8.0.11-1.1
  • php8-readline >= 8.0.11-1.1
  • php8-shmop >= 8.0.11-1.1
  • php8-snmp >= 8.0.11-1.1
  • php8-soap >= 8.0.11-1.1
  • php8-sockets >= 8.0.11-1.1
  • php8-sodium >= 8.0.11-1.1
  • php8-sqlite >= 8.0.11-1.1
  • php8-sysvmsg >= 8.0.11-1.1
  • php8-sysvsem >= 8.0.11-1.1
  • php8-sysvshm >= 8.0.11-1.1
  • php8-tidy >= 8.0.11-1.1
  • php8-tokenizer >= 8.0.11-1.1
  • php8-xmlreader >= 8.0.11-1.1
  • php8-xmlwriter >= 8.0.11-1.1
  • php8-xsl >= 8.0.11-1.1
  • php8-zip >= 8.0.11-1.1
  • php8-zlib >= 8.0.11-1.1
Patchnames:
openSUSE Tumbleweed GA php7-7.4.24-1.1
openSUSE Tumbleweed GA php8-8.0.11-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 php7 Not affected
SUSE Enterprise Storage 6 php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php5 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php72 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php74 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 php7 Not affected
SUSE Linux Enterprise Point of Service 11 SP3 php53 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS php53 Not affected
SUSE Linux Enterprise Server 15 ESPOS php7 Not affected
SUSE Linux Enterprise Server 15 LTSS php7 Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS php7 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 php7 Not affected