Upstream information

CVE-2021-21157 at MITRE

Description

Use after free in Web Sockets in Google Chrome on Linux prior to 88.0.4324.182 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

SUSE information

SUSE Bugzilla entry: 1182358 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 15 SP2
  • chromedriver >= 89.0.4389.72-bp152.2.62.1
  • chromium >= 89.0.4389.72-bp152.2.62.1
  • libQt5Pdf5 >= 5.15.3-bp152.3.3.1
  • libQt5PdfWidgets5 >= 5.15.3-bp152.3.3.1
  • libqt5-qtpdf-devel >= 5.15.3-bp152.3.3.1
  • libqt5-qtpdf-examples >= 5.15.3-bp152.3.3.1
  • libqt5-qtpdf-imports >= 5.15.3-bp152.3.3.1
  • libqt5-qtpdf-private-headers-devel >= 5.15.3-bp152.3.3.1
  • libqt5-qtwebengine >= 5.15.3-bp152.3.3.1
  • libqt5-qtwebengine-devel >= 5.15.3-bp152.3.3.1
  • libqt5-qtwebengine-examples >= 5.15.3-bp152.3.3.1
  • libqt5-qtwebengine-private-headers-devel >= 5.15.3-bp152.3.3.1
Patchnames:
openSUSE-2021-1016
openSUSE-2021-401
openSUSE Leap 15.2
  • chromedriver >= 89.0.4389.72-lp152.2.77.1
  • chromium >= 89.0.4389.72-lp152.2.77.1
  • libQt5Pdf5 >= 5.15.3-lp152.3.3.4
  • libQt5PdfWidgets5 >= 5.15.3-lp152.3.3.4
  • libqt5-qtpdf-devel >= 5.15.3-lp152.3.3.4
  • libqt5-qtpdf-examples >= 5.15.3-lp152.3.3.4
  • libqt5-qtpdf-imports >= 5.15.3-lp152.3.3.4
  • libqt5-qtpdf-private-headers-devel >= 5.15.3-lp152.3.3.4
  • libqt5-qtwebengine >= 5.15.3-lp152.3.3.4
  • libqt5-qtwebengine-devel >= 5.15.3-lp152.3.3.4
  • libqt5-qtwebengine-examples >= 5.15.3-lp152.3.3.4
  • libqt5-qtwebengine-private-headers-devel >= 5.15.3-lp152.3.3.4
Patchnames:
openSUSE-2021-392
openSUSE-2021-973
openSUSE Leap 15.2 NonFree
  • opera >= 74.0.3911.203-lp152.2.37.1
Patchnames:
openSUSE-2021-413
openSUSE Tumbleweed
  • chromedriver >= 93.0.4577.82-1.1
  • chromium >= 93.0.4577.82-1.1
  • libQt5Pdf5 >= 5.15.6-2.1
  • libQt5PdfWidgets5 >= 5.15.6-2.1
  • libqt5-qtpdf-devel >= 5.15.6-2.1
  • libqt5-qtpdf-examples >= 5.15.6-2.1
  • libqt5-qtpdf-imports >= 5.15.6-2.1
  • libqt5-qtpdf-private-headers-devel >= 5.15.6-2.1
  • libqt5-qtwebengine >= 5.15.6-2.1
  • libqt5-qtwebengine-devel >= 5.15.6-2.1
  • libqt5-qtwebengine-examples >= 5.15.6-2.1
  • libqt5-qtwebengine-private-headers-devel >= 5.15.6-2.1
Patchnames:
openSUSE Tumbleweed GA chromedriver-93.0.4577.82-1.1
openSUSE Tumbleweed GA libQt5Pdf5-5.15.6-2.1