Upstream information

CVE-2021-20718 at MITRE

Description

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1186291 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • apache2-mod_auth_openidc >= 2.4.0-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-1900
SUSE Linux Enterprise Server 12 SP4-LTSS
  • apache2-mod_auth_openidc >= 2.4.0-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-1900
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • apache2-mod_auth_openidc >= 2.4.0-3.14.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-1900
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • apache2-mod_auth_openidc >= 2.4.0-3.14.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-1900
SUSE OpenStack Cloud 9
  • apache2-mod_auth_openidc >= 2.4.0-3.14.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-1900
SUSE OpenStack Cloud Crowbar 9
  • apache2-mod_auth_openidc >= 2.4.0-3.14.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-1900


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 apache2-mod_auth_openidc Not affected
SUSE Enterprise Storage 6 apache2-mod_auth_openidc Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 apache2-mod_auth_openidc Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS apache2-mod_auth_openidc Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 apache2-mod_auth_openidc Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server 12 SP4 LTSS apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server 12 SP5 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux apache2-mod_auth_openidc Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS apache2-mod_auth_openidc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 apache2-mod_auth_openidc Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 apache2-mod_auth_openidc Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 apache2-mod_auth_openidc Not affected
SUSE Manager Proxy 4.0 apache2-mod_auth_openidc Not affected
SUSE Manager Retail Branch Server 4.0 apache2-mod_auth_openidc Not affected
SUSE Manager Server 4.0 apache2-mod_auth_openidc Not affected
SUSE OpenStack Cloud 9 apache2-mod_auth_openidc Released
SUSE OpenStack Cloud Crowbar 9 apache2-mod_auth_openidc Released