Upstream information

CVE-2021-20237 at MITRE

Description

An uncontrolled resource consumption (memory leak) flaw was found in ZeroMQ's src/xpub.cpp in versions before 4.3.3. This flaw allows a remote unauthenticated attacker to send crafted PUB messages that consume excessive memory if the CURVE/ZAP authentication is disabled on the server, causing a denial of service. The highest threat from this vulnerability is to system availability.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.9
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1189510 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 zeromq Affected
SUSE Enterprise Storage 6 zeromq Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS zeromq Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS zeromq Affected
SUSE Linux Enterprise Module for Advanced Systems Management 12 zeromq Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 zeromq Analysis
SUSE Linux Enterprise Module for Basesystem 15 SP2 zeromq Affected
SUSE Linux Enterprise Point of Service Image Server 12 zeromq Unsupported
SUSE Linux Enterprise Server 15 LTSS zeromq Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux zeromq Affected
SUSE Linux Enterprise Server 15 SP1 LTSS zeromq Affected
SUSE Linux Enterprise Server ESPOS 15 zeromq Affected
SUSE Linux Enterprise Server for SAP Applications 15 zeromq Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 zeromq Affected
SUSE Linux Enterprise Workstation Extension 12 zeromq Not affected
SUSE Manager Client Tools Beta for RHEL and ES 8 zeromq Not affected
SUSE Manager Client Tools Beta for SLE 12 zeromq Not affected
SUSE Manager Client Tools for RHEL and ES 8 zeromq Not affected
SUSE Manager Client Tools for SLE 12 zeromq Not affected
SUSE Manager Proxy 4.0 zeromq Unsupported
SUSE Manager Retail Branch Server 4.0 zeromq Unsupported
SUSE Manager Server 4.0 zeromq Unsupported