Upstream information

CVE-2021-20233 at MITRE

Description

A flaw was found in grub2 in versions prior to 2.06. Setparam_prefix() in the menu rendering code performs a length calculation on the assumption that expressing a quoted single quote will require 3 characters, while it actually requires 4 characters which allows an attacker to corrupt memory by one byte for each quote in the input. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.2 7.5
Vector CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low High
Privileges Required High High
User Interaction None None
Scope Changed Changed
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1182263 [RESOLVED / FIXED], 1183135 [RESOLVED / DUPLICATE], 1192833 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • grub2 >= 2.02-4.69.1
  • grub2-i386-pc >= 2.02-4.69.1
  • grub2-snapper-plugin >= 2.02-4.69.1
  • grub2-systemd-sleep-plugin >= 2.02-4.69.1
  • grub2-x86_64-efi >= 2.02-4.69.1
  • grub2-x86_64-xen >= 2.02-4.69.1
Patchnames:
HPE-Helion-OpenStack-8-2021-682
Image SLES12-SP4-Azure-BYOS
Image SLES12-SP4-GCE-BYOS
Image SLES12-SP4-OCI-BYOS
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
Image SLES12-SP5-Azure-BYOS
Image SLES12-SP5-Azure-Basic-On-Demand
Image SLES12-SP5-Azure-HPC-BYOS
Image SLES12-SP5-Azure-HPC-On-Demand
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-Azure-Standard-On-Demand
Image SLES12-SP5-GCE-BYOS
Image SLES12-SP5-GCE-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-OCI-BYOS-BYOS
Image SLES12-SP5-OCI-BYOS-SAP-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • grub2 >= 2.02-12.47.1
  • grub2-i386-pc >= 2.02-12.47.1
  • grub2-x86_64-efi >= 2.02-12.47.1
Image SLES12-SP4-EC2-HVM-BYOS
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP5-EC2-BYOS
Image SLES12-SP5-EC2-ECS-On-Demand
Image SLES12-SP5-EC2-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
  • grub2 >= 2.02-12.47.1
  • grub2-i386-pc >= 2.02-12.47.1
  • grub2-x86_64-efi >= 2.02-12.47.1
  • grub2-x86_64-xen >= 2.02-12.47.1
Image SLES15-Azure-BYOS
Image SLES15-GCE-BYOS
Image SLES15-OCI-BYOS
Image SLES15-SAP-Azure
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SAP-GCE
Image SLES15-SAP-GCE-BYOS
Image SLES15-SAP-OCI-BYOS
  • grub2 >= 2.02-19.66.1
  • grub2-i386-pc >= 2.02-19.66.1
  • grub2-x86_64-efi >= 2.02-19.66.1
Image SLES15-EC2-CHOST-HVM-BYOS
  • grub2 >= 2.02-19.66.1
  • grub2-i386-pc >= 2.02-19.66.1
  • grub2-x86_64-xen >= 2.02-19.66.1
Image SLES15-EC2-HVM-BYOS
Image SLES15-SAP-EC2-HVM
Image SLES15-SAP-EC2-HVM-BYOS
  • grub2 >= 2.02-19.66.1
  • grub2-i386-pc >= 2.02-19.66.1
  • grub2-x86_64-efi >= 2.02-19.66.1
  • grub2-x86_64-xen >= 2.02-19.66.1
Image SLES15-SP1-Azure-BYOS
Image SLES15-SP1-Azure-HPC-BYOS
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-GCE-BYOS
Image SLES15-SP1-Manager-4-0-Azure-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-Azure-BYOS-Server
Image SLES15-SP1-Manager-4-0-GCE-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-GCE-BYOS-Server
Image SLES15-SP1-OCI-BYOS
Image SLES15-SP1-SAP-Azure
Image SLES15-SP1-SAP-Azure-BYOS
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP1-SAP-GCE
Image SLES15-SP1-SAP-GCE-BYOS
Image SLES15-SP1-SAP-OCI-BYOS
Image SLES15-SP1-SAPCAL-Azure
Image SLES15-SP1-SAPCAL-GCE
  • grub2 >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-EC2-HPC-HVM-BYOS
Image SLES15-SP1-EC2-HVM-BYOS
Image SLES15-SP1-Manager-4-0-EC2-HVM-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-EC2-HVM-BYOS-Server
Image SLES15-SP1-SAP-EC2-HVM
Image SLES15-SP1-SAP-EC2-HVM-BYOS
Image SLES15-SP1-SAPCAL-EC2-HVM
  • grub2 >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Image SLES15-SP2-Azure-Basic
Image SLES15-SP2-Azure-Standard
Image SLES15-SP2-BYOS-Azure
Image SLES15-SP2-BYOS-GCE
Image SLES15-SP2-BYOS-OCI
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP2-GCE
Image SLES15-SP2-HPC-Azure
Image SLES15-SP2-HPC-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Proxy-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Proxy-BYOS-GCE
Image SLES15-SP2-Manager-4-1-Server-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Server-BYOS-GCE
Image SLES15-SP2-SAP-Azure
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-BYOS-Azure
Image SLES15-SP2-SAP-BYOS-GCE
Image SLES15-SP2-SAP-BYOS-OCI
Image SLES15-SP2-SAP-GCE
  • grub2 >= 2.04-9.34.1
  • grub2-i386-pc >= 2.04-9.34.1
  • grub2-x86_64-efi >= 2.04-9.34.1
Image SLES15-SP2-BYOS-EC2-HVM
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-EC2-ECS-HVM
Image SLES15-SP2-EC2-HVM
Image SLES15-SP2-HPC-BYOS-EC2-HVM
Image SLES15-SP2-Manager-4-1-Proxy-BYOS-EC2-HVM
Image SLES15-SP2-Manager-4-1-Server-BYOS-EC2-HVM
Image SLES15-SP2-SAP-BYOS-EC2-HVM
Image SLES15-SP2-SAP-EC2-HVM
  • grub2 >= 2.04-9.34.1
  • grub2-i386-pc >= 2.04-9.34.1
  • grub2-x86_64-efi >= 2.04-9.34.1
  • grub2-x86_64-xen >= 2.04-9.34.1
Image SLES15-SP2-CHOST-BYOS-Aliyun
Image SLES15-SP2-CHOST-BYOS-OpenStack
  • grub2 >= 2.04-9.34.1
  • grub2-i386-pc >= 2.04-9.34.1
SUSE CaaS Platform 4.0
  • grub2 >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-684
SUSE Enterprise Storage 6
  • grub2 >= 2.02-26.43.1
  • grub2-arm64-efi >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-Storage-6-2021-684
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • grub2 >= 2.04-9.34.1
  • grub2-arm64-efi >= 2.04-9.34.1
  • grub2-i386-pc >= 2.04-9.34.1
  • grub2-powerpc-ieee1275 >= 2.04-9.34.1
  • grub2-s390x-emu >= 2.04-9.34.1
  • grub2-snapper-plugin >= 2.04-9.34.1
  • grub2-systemd-sleep-plugin >= 2.04-9.34.1
  • grub2-x86_64-efi >= 2.04-9.34.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-683
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • grub2 >= 2.04-20.4
  • grub2-arm64-efi >= 2.04-20.4
  • grub2-i386-pc >= 2.04-20.4
  • grub2-powerpc-ieee1275 >= 2.04-20.4
  • grub2-s390x-emu >= 2.04-20.4
  • grub2-snapper-plugin >= 2.04-20.4
  • grub2-systemd-sleep-plugin >= 2.04-20.4
  • grub2-x86_64-efi >= 2.04-20.4
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA grub2-2.04-20.4
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • grub2 >= 2.02-26.43.1
  • grub2-arm64-efi >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-684
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • grub2 >= 2.02-26.43.1
  • grub2-arm64-efi >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-684
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • grub2 >= 2.04-9.34.1
  • grub2-arm64-efi >= 2.04-9.34.1
  • grub2-i386-pc >= 2.04-9.34.1
  • grub2-powerpc-ieee1275 >= 2.04-9.34.1
  • grub2-s390x-emu >= 2.04-9.34.1
  • grub2-snapper-plugin >= 2.04-9.34.1
  • grub2-systemd-sleep-plugin >= 2.04-9.34.1
  • grub2-x86_64-efi >= 2.04-9.34.1
  • grub2-x86_64-xen >= 2.04-9.34.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-683
SUSE-SLE-Module-Server-Applications-15-SP2-2021-683
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • grub2 >= 2.04-20.4
  • grub2-arm64-efi >= 2.04-20.4
  • grub2-i386-pc >= 2.04-20.4
  • grub2-powerpc-ieee1275 >= 2.04-20.4
  • grub2-s390x-emu >= 2.04-20.4
  • grub2-snapper-plugin >= 2.04-20.4
  • grub2-systemd-sleep-plugin >= 2.04-20.4
  • grub2-x86_64-efi >= 2.04-20.4
  • grub2-x86_64-xen >= 2.04-20.4
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA grub2-2.04-20.4
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA grub2-x86_64-xen-2.04-20.4
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • grub2 >= 2.02-19.66.1
  • grub2-arm64-efi >= 2.02-19.66.1
  • grub2-i386-pc >= 2.02-19.66.1
  • grub2-snapper-plugin >= 2.02-19.66.1
  • grub2-systemd-sleep-plugin >= 2.02-19.66.1
  • grub2-x86_64-efi >= 2.02-19.66.1
  • grub2-x86_64-xen >= 2.02-19.66.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-685
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • grub2-x86_64-xen >= 2.04-9.34.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2021-683
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • grub2-x86_64-xen >= 2.04-20.4
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA grub2-x86_64-xen-2.04-20.4
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • grub2 >= 2.02-115.59.1
  • grub2-i386-pc >= 2.02-115.59.1
  • grub2-snapper-plugin >= 2.02-115.59.1
  • grub2-systemd-sleep-plugin >= 2.02-115.59.1
  • grub2-x86_64-efi >= 2.02-115.59.1
  • grub2-x86_64-xen >= 2.02-115.59.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2021-679
SUSE Linux Enterprise Server 11 SP4-LTSS
  • grub2-x86_64-efi >= 2.02-0.66.26.1
  • grub2-x86_64-xen >= 2.02-0.66.26.1
Patchnames:
slessp4-grub2-14659
SUSE Linux Enterprise Server 12 SP2-BCL
  • grub2 >= 2.02-115.59.1
  • grub2-i386-pc >= 2.02-115.59.1
  • grub2-snapper-plugin >= 2.02-115.59.1
  • grub2-systemd-sleep-plugin >= 2.02-115.59.1
  • grub2-x86_64-efi >= 2.02-115.59.1
  • grub2-x86_64-xen >= 2.02-115.59.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2021-679
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • grub2 >= 2.02-115.59.1
  • grub2-i386-pc >= 2.02-115.59.1
  • grub2-snapper-plugin >= 2.02-115.59.1
  • grub2-systemd-sleep-plugin >= 2.02-115.59.1
  • grub2-x86_64-efi >= 2.02-115.59.1
  • grub2-x86_64-xen >= 2.02-115.59.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2021-679
SUSE Linux Enterprise Server 12 SP2-LTSS
  • grub2 >= 2.02-115.59.1
  • grub2-i386-pc >= 2.02-115.59.1
  • grub2-powerpc-ieee1275 >= 2.02-115.59.1
  • grub2-s390x-emu >= 2.02-115.59.1
  • grub2-snapper-plugin >= 2.02-115.59.1
  • grub2-systemd-sleep-plugin >= 2.02-115.59.1
  • grub2-x86_64-efi >= 2.02-115.59.1
  • grub2-x86_64-xen >= 2.02-115.59.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2021-679
SUSE Linux Enterprise Server 12 SP3-BCL
  • grub2 >= 2.02-4.69.1
  • grub2-i386-pc >= 2.02-4.69.1
  • grub2-snapper-plugin >= 2.02-4.69.1
  • grub2-systemd-sleep-plugin >= 2.02-4.69.1
  • grub2-x86_64-efi >= 2.02-4.69.1
  • grub2-x86_64-xen >= 2.02-4.69.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2021-682
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • grub2 >= 2.02-4.69.1
  • grub2-arm64-efi >= 2.02-4.69.1
  • grub2-i386-pc >= 2.02-4.69.1
  • grub2-snapper-plugin >= 2.02-4.69.1
  • grub2-systemd-sleep-plugin >= 2.02-4.69.1
  • grub2-x86_64-efi >= 2.02-4.69.1
  • grub2-x86_64-xen >= 2.02-4.69.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2021-682
SUSE Linux Enterprise Server 12 SP3-LTSS
  • grub2 >= 2.02-4.69.1
  • grub2-arm64-efi >= 2.02-4.69.1
  • grub2-i386-pc >= 2.02-4.69.1
  • grub2-powerpc-ieee1275 >= 2.02-4.69.1
  • grub2-s390x-emu >= 2.02-4.69.1
  • grub2-snapper-plugin >= 2.02-4.69.1
  • grub2-systemd-sleep-plugin >= 2.02-4.69.1
  • grub2-x86_64-efi >= 2.02-4.69.1
  • grub2-x86_64-xen >= 2.02-4.69.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2021-682
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • grub2 >= 2.02-12.47.1
  • grub2-arm64-efi >= 2.02-12.47.1
  • grub2-i386-pc >= 2.02-12.47.1
  • grub2-snapper-plugin >= 2.02-12.47.1
  • grub2-systemd-sleep-plugin >= 2.02-12.47.1
  • grub2-x86_64-efi >= 2.02-12.47.1
  • grub2-x86_64-xen >= 2.02-12.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-681
SUSE Linux Enterprise Server 12 SP4-LTSS
  • grub2 >= 2.02-12.47.1
  • grub2-arm64-efi >= 2.02-12.47.1
  • grub2-i386-pc >= 2.02-12.47.1
  • grub2-powerpc-ieee1275 >= 2.02-12.47.1
  • grub2-s390x-emu >= 2.02-12.47.1
  • grub2-snapper-plugin >= 2.02-12.47.1
  • grub2-systemd-sleep-plugin >= 2.02-12.47.1
  • grub2-x86_64-efi >= 2.02-12.47.1
  • grub2-x86_64-xen >= 2.02-12.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-681
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • grub2 >= 2.02-12.47.1
  • grub2-arm64-efi >= 2.02-12.47.1
  • grub2-i386-pc >= 2.02-12.47.1
  • grub2-powerpc-ieee1275 >= 2.02-12.47.1
  • grub2-s390x-emu >= 2.02-12.47.1
  • grub2-snapper-plugin >= 2.02-12.47.1
  • grub2-systemd-sleep-plugin >= 2.02-12.47.1
  • grub2-x86_64-efi >= 2.02-12.47.1
  • grub2-x86_64-xen >= 2.02-12.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-681
SUSE Linux Enterprise Server 15 SP1-BCL
  • grub2 >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-684
SUSE Linux Enterprise Server 15 SP1-LTSS
  • grub2 >= 2.02-26.43.1
  • grub2-arm64-efi >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-powerpc-ieee1275 >= 2.02-26.43.1
  • grub2-s390x-emu >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-684
SUSE Linux Enterprise Server 15-LTSS
  • grub2 >= 2.02-19.66.1
  • grub2-arm64-efi >= 2.02-19.66.1
  • grub2-i386-pc >= 2.02-19.66.1
  • grub2-powerpc-ieee1275 >= 2.02-19.66.1
  • grub2-s390x-emu >= 2.02-19.66.1
  • grub2-snapper-plugin >= 2.02-19.66.1
  • grub2-systemd-sleep-plugin >= 2.02-19.66.1
  • grub2-x86_64-efi >= 2.02-19.66.1
  • grub2-x86_64-xen >= 2.02-19.66.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-685
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • grub2 >= 2.02-115.59.1
  • grub2-i386-pc >= 2.02-115.59.1
  • grub2-powerpc-ieee1275 >= 2.02-115.59.1
  • grub2-snapper-plugin >= 2.02-115.59.1
  • grub2-systemd-sleep-plugin >= 2.02-115.59.1
  • grub2-x86_64-efi >= 2.02-115.59.1
  • grub2-x86_64-xen >= 2.02-115.59.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2021-679
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • grub2 >= 2.02-4.69.1
  • grub2-i386-pc >= 2.02-4.69.1
  • grub2-powerpc-ieee1275 >= 2.02-4.69.1
  • grub2-snapper-plugin >= 2.02-4.69.1
  • grub2-systemd-sleep-plugin >= 2.02-4.69.1
  • grub2-x86_64-efi >= 2.02-4.69.1
  • grub2-x86_64-xen >= 2.02-4.69.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2021-682
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • grub2 >= 2.02-12.47.1
  • grub2-i386-pc >= 2.02-12.47.1
  • grub2-powerpc-ieee1275 >= 2.02-12.47.1
  • grub2-snapper-plugin >= 2.02-12.47.1
  • grub2-systemd-sleep-plugin >= 2.02-12.47.1
  • grub2-x86_64-efi >= 2.02-12.47.1
  • grub2-x86_64-xen >= 2.02-12.47.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-681
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • grub2 >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-powerpc-ieee1275 >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-684
SUSE Linux Enterprise Server for SAP Applications 15
  • grub2 >= 2.02-19.66.1
  • grub2-i386-pc >= 2.02-19.66.1
  • grub2-powerpc-ieee1275 >= 2.02-19.66.1
  • grub2-snapper-plugin >= 2.02-19.66.1
  • grub2-systemd-sleep-plugin >= 2.02-19.66.1
  • grub2-x86_64-efi >= 2.02-19.66.1
  • grub2-x86_64-xen >= 2.02-19.66.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-685
SUSE Manager Proxy 4.0
  • grub2 >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-684
SUSE Manager Retail Branch Server 4.0
  • grub2 >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-684
SUSE Manager Server 4.0
  • grub2 >= 2.02-26.43.1
  • grub2-i386-pc >= 2.02-26.43.1
  • grub2-powerpc-ieee1275 >= 2.02-26.43.1
  • grub2-s390x-emu >= 2.02-26.43.1
  • grub2-snapper-plugin >= 2.02-26.43.1
  • grub2-systemd-sleep-plugin >= 2.02-26.43.1
  • grub2-x86_64-efi >= 2.02-26.43.1
  • grub2-x86_64-xen >= 2.02-26.43.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-684
SUSE OpenStack Cloud 7
  • grub2 >= 2.02-115.59.1
  • grub2-i386-pc >= 2.02-115.59.1
  • grub2-s390x-emu >= 2.02-115.59.1
  • grub2-snapper-plugin >= 2.02-115.59.1
  • grub2-systemd-sleep-plugin >= 2.02-115.59.1
  • grub2-x86_64-efi >= 2.02-115.59.1
  • grub2-x86_64-xen >= 2.02-115.59.1
Patchnames:
SUSE-OpenStack-Cloud-7-2021-679
SUSE OpenStack Cloud 8
  • grub2 >= 2.02-4.69.1
  • grub2-i386-pc >= 2.02-4.69.1
  • grub2-snapper-plugin >= 2.02-4.69.1
  • grub2-systemd-sleep-plugin >= 2.02-4.69.1
  • grub2-x86_64-efi >= 2.02-4.69.1
  • grub2-x86_64-xen >= 2.02-4.69.1
Patchnames:
SUSE-OpenStack-Cloud-8-2021-682
SUSE OpenStack Cloud 9
  • grub2 >= 2.02-12.47.1
  • grub2-i386-pc >= 2.02-12.47.1
  • grub2-snapper-plugin >= 2.02-12.47.1
  • grub2-systemd-sleep-plugin >= 2.02-12.47.1
  • grub2-x86_64-efi >= 2.02-12.47.1
  • grub2-x86_64-xen >= 2.02-12.47.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-681
SUSE OpenStack Cloud Crowbar 8
  • grub2 >= 2.02-4.69.1
  • grub2-i386-pc >= 2.02-4.69.1
  • grub2-snapper-plugin >= 2.02-4.69.1
  • grub2-systemd-sleep-plugin >= 2.02-4.69.1
  • grub2-x86_64-efi >= 2.02-4.69.1
  • grub2-x86_64-xen >= 2.02-4.69.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-682
SUSE OpenStack Cloud Crowbar 9
  • grub2 >= 2.02-12.47.1
  • grub2-i386-pc >= 2.02-12.47.1
  • grub2-snapper-plugin >= 2.02-12.47.1
  • grub2-systemd-sleep-plugin >= 2.02-12.47.1
  • grub2-x86_64-efi >= 2.02-12.47.1
  • grub2-x86_64-xen >= 2.02-12.47.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-681
openSUSE Leap 15.2
  • grub2 >= 2.04-lp152.7.22.7
  • grub2-branding-upstream >= 2.04-lp152.7.22.7
  • grub2-i386-efi >= 2.04-lp152.7.22.7
  • grub2-i386-efi-debug >= 2.04-lp152.7.22.7
  • grub2-i386-pc >= 2.04-lp152.7.22.7
  • grub2-i386-pc-debug >= 2.04-lp152.7.22.7
  • grub2-i386-xen >= 2.04-lp152.7.22.7
  • grub2-snapper-plugin >= 2.04-lp152.7.22.7
  • grub2-systemd-sleep-plugin >= 2.04-lp152.7.22.7
  • grub2-x86_64-efi >= 2.04-lp152.7.22.7
  • grub2-x86_64-efi-debug >= 2.04-lp152.7.22.7
  • grub2-x86_64-xen >= 2.04-lp152.7.22.7
Patchnames:
openSUSE-2021-462
openSUSE Leap 15.3
  • grub2 >= 2.04-20.4
  • grub2-arm64-efi >= 2.04-20.4
  • grub2-i386-pc >= 2.04-20.4
  • grub2-powerpc-ieee1275 >= 2.04-20.4
  • grub2-snapper-plugin >= 2.04-20.4
  • grub2-systemd-sleep-plugin >= 2.04-20.4
  • grub2-x86_64-efi >= 2.04-20.4
Patchnames:
openSUSE Leap 15.3 GA grub2-2.04-20.4
openSUSE Tumbleweed
  • grub2 >= 2.06-7.1
  • grub2-branding-upstream >= 2.06-7.1
  • grub2-i386-pc >= 2.06-7.1
  • grub2-i386-pc-debug >= 2.06-7.1
  • grub2-snapper-plugin >= 2.06-7.1
  • grub2-systemd-sleep-plugin >= 2.06-7.1
  • grub2-x86_64-efi >= 2.06-7.1
  • grub2-x86_64-efi-debug >= 2.06-7.1
  • grub2-x86_64-xen >= 2.06-7.1
Patchnames:
openSUSE Tumbleweed GA grub2-2.06-7.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 grub2 Released
SLES15-EC2-CHOST-HVM-BYOS grub2 Released
SLES15-SP1-CHOST-BYOS-Azure grub2 Released
SLES15-SP1-CHOST-BYOS-EC2 grub2 Released
SLES15-SP1-CHOST-BYOS-GCE grub2 Released
SLES15-SP2-CHOST-BYOS-Aliyun grub2 Released
SLES15-SP2-CHOST-BYOS-Azure grub2 Released
SLES15-SP2-CHOST-BYOS-EC2 grub2 Released
SLES15-SP2-CHOST-BYOS-GCE grub2 Released
SLES15-SP2-CHOST-BYOS-OpenStack grub2 Released
SLES15-SP3-CHOST-BYOS-Aliyun grub2 Not affected
SLES15-SP3-CHOST-BYOS-Azure grub2 Not affected
SLES15-SP3-CHOST-BYOS-EC2 grub2 Not affected
SLES15-SP3-CHOST-BYOS-GCE grub2 Not affected
SUSE CaaS Platform 4.0 grub2 Released
SUSE Enterprise Storage 6 grub2 Released
SUSE Linux Enterprise Desktop 15 SP1 grub2 Unsupported
SUSE Linux Enterprise Desktop 15 SP2 grub2 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 grub2 Released
SUSE Linux Enterprise High Performance Computing 15 LTSS grub2 Released
SUSE Linux Enterprise High Performance Computing 15 SP1 grub2 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS grub2 Released
SUSE Linux Enterprise High Performance Computing 15 SP2 grub2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 grub2 Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 grub2 Released
SUSE Linux Enterprise Module for Server Applications 15 SP1 grub2 Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP2 grub2 Released
SUSE Linux Enterprise Point of Service Image Server 12 SP2 grub2 Released
SUSE Linux Enterprise Server 11 SP4 LTSS grub2 Released
SUSE Linux Enterprise Server 12 SP2 BCL grub2 Released
SUSE Linux Enterprise Server 12 SP2 ESPOS grub2 Released
SUSE Linux Enterprise Server 12 SP2 LTSS grub2 Released
SUSE Linux Enterprise Server 12 SP3 BCL grub2 Released
SUSE Linux Enterprise Server 12 SP3 ESPOS grub2 Released
SUSE Linux Enterprise Server 12 SP3 LTSS grub2 Released
SUSE Linux Enterprise Server 12 SP4 ESPOS grub2 Released
SUSE Linux Enterprise Server 12 SP4 LTSS grub2 Released
SUSE Linux Enterprise Server 12 SP5 grub2 Released
SUSE Linux Enterprise Server 15 ESPOS grub2 Released
SUSE Linux Enterprise Server 15 LTSS grub2 Released
SUSE Linux Enterprise Server 15 SP1 grub2 Unsupported
SUSE Linux Enterprise Server 15 SP1 LTSS grub2 Released
SUSE Linux Enterprise Server 15 SP2 grub2 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 grub2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 grub2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 grub2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 grub2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 grub2 Released
SUSE Linux Enterprise Server for SAP Applications 15 grub2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 grub2 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 grub2 Released
SUSE Linux Enterprise Storage 6 grub2 Unsupported
SUSE Linux Enterprise Storage 7 grub2 Released
SUSE Manager Proxy 4.0 grub2 Unsupported
SUSE Manager Proxy 4.1 grub2 Released
SUSE Manager Retail Branch Server 4.0 grub2 Unsupported
SUSE Manager Retail Branch Server 4.1 grub2 Released
SUSE Manager Server 4.0 grub2 Unsupported
SUSE Manager Server 4.1 grub2 Released
SUSE OpenStack Cloud 7 grub2 Released
SUSE OpenStack Cloud 8 grub2 Released
SUSE OpenStack Cloud 9 grub2 Released
SUSE OpenStack Cloud Crowbar 8 grub2 Released
SUSE OpenStack Cloud Crowbar 9 grub2 Released
suse/sle-micro-rancher/5.2 grub2Not affected