Upstream information

CVE-2021-20199 at MITRE

Description

Rootless containers run with Podman, receive all traffic with a source IP address of 127.0.0.1 (including from remote hosts). This impacts containerized applications that trust localhost (127.0.01) connections by default and do not require authentication. This issue affects Podman 1.8.0 onwards.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 3.7
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Attack Vector Network Network
Attack Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact High Low
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1181640 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/bci-init:15.3
Container ses/7.1/ceph/haproxy:2.0.14.2.2.10
Container ses/7.1/ceph/keepalived:2.0.19.2.2.10
Container ses/7.1/cephcsi/cephcsi:3.5.1.0.3.2.10
Container ses/7.1/rook/ceph:1.8.6.0.3.2.5
Container suse/pcp:5.2.2-5.24
Container suse/sle-micro-rancher/5.2:latest
Container suse/sle-micro/5.1/toolbox:11.1-2.2.254
Container suse/sle-micro/5.2/toolbox:11.1-6.2.1
Container trento/trento-db:14.1-rev1.0.0-build2.2.43
Image SLES15-SP3-BYOS-Azure
Image SLES15-SP3-BYOS-EC2-HVM
Image SLES15-SP3-BYOS-GCE
Image SLES15-SP3-CHOST-BYOS-Aliyun
Image SLES15-SP3-CHOST-BYOS-Azure
Image SLES15-SP3-CHOST-BYOS-EC2
Image SLES15-SP3-CHOST-BYOS-GCE
Image SLES15-SP3-EC2-ECS-HVM
Image SLES15-SP3-EC2-HVM
Image SLES15-SP3-GCE
Image SLES15-SP3-HPC-Azure
Image SLES15-SP3-HPC-BYOS-Azure
Image SLES15-SP3-HPC-BYOS-EC2-HVM
Image SLES15-SP3-HPC-BYOS-GCE
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-GCE
Image SLES15-SP3-Manager-4-2-Server-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Server-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Server-BYOS-GCE
Image SLES15-SP3-Micro-5-1-BYOS-Azure
Image SLES15-SP3-Micro-5-1-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-1-BYOS-GCE
Image SLES15-SP3-Micro-5-2-BYOS-Azure
Image SLES15-SP3-Micro-5-2-BYOS-EC2-HVM
Image SLES15-SP3-Micro-5-2-BYOS-GCE
Image SLES15-SP3-SAP-Azure
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-BYOS-Azure
Image SLES15-SP3-SAP-BYOS-EC2-HVM
Image SLES15-SP3-SAP-BYOS-GCE
Image SLES15-SP3-SAP-EC2-HVM
Image SLES15-SP3-SAP-GCE
Image SLES15-SP3-SAPCAL-Azure
Image SLES15-SP3-SAPCAL-EC2-HVM
Image SLES15-SP3-SAPCAL-GCE
  • libseccomp2 >= 2.5.3-150300.10.5.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libcontainers-common >= 20210626-150400.1.3
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libcontainers-common-20210626-150400.1.3
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libcontainers-common >= 20210626-150400.1.3
  • podman >= 3.4.4-150400.2.14
  • podman-cni-config >= 3.4.4-150400.2.14
  • podman-docker >= 3.4.4-150400.2.14
  • podman-remote >= 3.4.4-150400.2.14
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libcontainers-common-20210626-150400.1.3
SUSE Linux Enterprise Module for Containers 15 SP4 GA podman-3.4.4-150400.2.14
SUSE Linux Enterprise Module for Containers 15 SP4
  • podman >= 3.4.4-150400.2.14
  • podman-cni-config >= 3.4.4-150400.2.14
  • podman-docker >= 3.4.4-150400.2.14
  • podman-remote >= 3.4.4-150400.2.14
Patchnames:
SUSE Linux Enterprise Module for Containers 15 SP4 GA podman-3.4.4-150400.2.14
openSUSE Leap 15.3
  • conmon >= 2.0.30-150300.8.3.1
  • libcontainers-common >= 20210626-150300.8.3.1
  • libseccomp-devel >= 2.5.3-150300.10.5.1
  • libseccomp-tools >= 2.5.3-150300.10.5.1
  • libseccomp2 >= 2.5.3-150300.10.5.1
  • libseccomp2-32bit >= 2.5.3-150300.10.5.1
  • podman >= 3.4.4-150300.9.3.2
  • podman-cni-config >= 3.4.4-150300.9.3.2
Patchnames:
openSUSE-SLE-15.3-2022-23018
openSUSE Tumbleweed
  • libcontainers-common >= 20210626-7.1
  • podman >= 3.3.1-2.1
  • podman-cni-config >= 3.3.1-2.1
  • podman-docker >= 3.3.1-2.1
  • podman-remote >= 3.3.1-2.1
Patchnames:
openSUSE Tumbleweed GA libcontainers-common-20210626-7.1
openSUSE Tumbleweed GA podman-3.3.1-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 libcontainers-common Released
SUSE CaaS Platform 4.0 podman Released
SUSE CaaS Platform 4.5 podman Affected
SUSE Enterprise Storage 6 libcontainers-common Released
SUSE Enterprise Storage 6 podman Released
SUSE Enterprise Storage 7 libcontainers-common Released
SUSE Enterprise Storage 7 podman Released
SUSE Enterprise Storage 7.1 podman Released
SUSE Linux Enterprise High Performance Computing 15 SP1 podman Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS libcontainers-common Released
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS podman Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS libcontainers-common Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS podman Released
SUSE Linux Enterprise High Performance Computing 15 SP2 podman Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS libcontainers-common Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS podman Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS libcontainers-common Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS podman Released
SUSE Linux Enterprise High Performance Computing 15 SP3 podman Released
SUSE Linux Enterprise High Performance Computing 15 SP4 podman Already fixed
SUSE Linux Enterprise Micro 5.0 podman Affected
SUSE Linux Enterprise Micro 5.1 podman Released
SUSE Linux Enterprise Micro 5.2 podman Released
SUSE Linux Enterprise Micro 5.3 libcontainers-common Released
SUSE Linux Enterprise Micro 5.3 podman Already fixed
SUSE Linux Enterprise Module for Containers 15 SP1 podman Affected
SUSE Linux Enterprise Module for Containers 15 SP2 podman Affected
SUSE Linux Enterprise Module for Containers 15 SP3 podman Released
SUSE Linux Enterprise Module for Containers 15 SP4 podman Already fixed
SUSE Linux Enterprise Server 15 SP1 podman Affected
SUSE Linux Enterprise Server 15 SP1-LTSS libcontainers-common Released
SUSE Linux Enterprise Server 15 SP1-LTSS podman Released
SUSE Linux Enterprise Server 15 SP2 podman Affected
SUSE Linux Enterprise Server 15 SP2-LTSS libcontainers-common Released
SUSE Linux Enterprise Server 15 SP2-LTSS podman Released
SUSE Linux Enterprise Server 15 SP3 podman Released
SUSE Linux Enterprise Server 15 SP4 podman Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libcontainers-common Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 podman Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libcontainers-common Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 podman Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libcontainers-common Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 podman Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libcontainers-common Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 podman Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 podman Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 podman Already fixed
SUSE Manager Proxy 4.0 podman Affected
SUSE Manager Proxy 4.1 libcontainers-common Released
SUSE Manager Proxy 4.1 podman Affected
SUSE Manager Proxy 4.2 podman Released
SUSE Manager Proxy 4.3 podman Already fixed
SUSE Manager Retail Branch Server 4.0 podman Affected
SUSE Manager Retail Branch Server 4.1 libcontainers-common Released
SUSE Manager Retail Branch Server 4.1 podman Affected
SUSE Manager Retail Branch Server 4.2 podman Released
SUSE Manager Retail Branch Server 4.3 podman Already fixed
SUSE Manager Server 4.0 podman Affected
SUSE Manager Server 4.1 libcontainers-common Released
SUSE Manager Server 4.1 podman Affected
SUSE Manager Server 4.2 podman Released
SUSE Manager Server 4.3 podman Already fixed
suse/sles/15.3/cdi-importer:1.37.1
suse/sles/15.4/cdi-importer:1.43.0
libcontainers-commonIn progress


SUSE Timeline for this CVE

CVE page created: Mon Feb 1 01:04:21 2021
CVE page last modified: Tue Nov 29 04:05:26 2022