Upstream information

CVE-2020-8955 at MITRE

Description

irc_mode_channel_update in plugins/irc/irc-mode.c in WeeChat through 2.7 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a malformed IRC message 324 (channel mode).

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1163889 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP1
  • weechat >= 2.1-bp151.4.3.1
  • weechat-aspell >= 2.1-bp151.4.3.1
  • weechat-devel >= 2.1-bp151.4.3.1
  • weechat-guile >= 2.1-bp151.4.3.1
  • weechat-lang >= 2.1-bp151.4.3.1
  • weechat-lua >= 2.1-bp151.4.3.1
  • weechat-perl >= 2.1-bp151.4.3.1
  • weechat-python >= 2.1-bp151.4.3.1
  • weechat-ruby >= 2.1-bp151.4.3.1
  • weechat-tcl >= 2.1-bp151.4.3.1
Patchnames:
openSUSE-2020-248
SUSE Package Hub 15
  • weechat >= 2.1-bp150.3.3.1
  • weechat-aspell >= 2.1-bp150.3.3.1
  • weechat-devel >= 2.1-bp150.3.3.1
  • weechat-guile >= 2.1-bp150.3.3.1
  • weechat-lang >= 2.1-bp150.3.3.1
  • weechat-lua >= 2.1-bp150.3.3.1
  • weechat-perl >= 2.1-bp150.3.3.1
  • weechat-python >= 2.1-bp150.3.3.1
  • weechat-ruby >= 2.1-bp150.3.3.1
  • weechat-tcl >= 2.1-bp150.3.3.1
Patchnames:
openSUSE-2020-248
openSUSE Leap 15.1
  • weechat >= 2.1-lp151.3.3.1
  • weechat-aspell >= 2.1-lp151.3.3.1
  • weechat-devel >= 2.1-lp151.3.3.1
  • weechat-guile >= 2.1-lp151.3.3.1
  • weechat-lang >= 2.1-lp151.3.3.1
  • weechat-lua >= 2.1-lp151.3.3.1
  • weechat-perl >= 2.1-lp151.3.3.1
  • weechat-python >= 2.1-lp151.3.3.1
  • weechat-ruby >= 2.1-lp151.3.3.1
  • weechat-tcl >= 2.1-lp151.3.3.1
Patchnames:
openSUSE-2020-248
openSUSE Tumbleweed
  • weechat >= 3.2-1.3
  • weechat-devel >= 3.2-1.3
  • weechat-lang >= 3.2-1.3
  • weechat-lua >= 3.2-1.3
  • weechat-perl >= 3.2-1.3
  • weechat-python >= 3.2-1.3
  • weechat-ruby >= 3.2-1.3
  • weechat-spell >= 3.2-1.3
  • weechat-tcl >= 3.2-1.3
Patchnames:
openSUSE Tumbleweed GA weechat-3.2-1.3