Upstream information

CVE-2020-8565 at MITRE

Description

In Kubernetes, if the logging level is set to at least 9, authorization and bearer tokens will be written to log files. This can occur both in API server logs and client tool output like kubectl. This affects <= v1.19.3, <= v1.18.10, <= v1.17.13, < v1.20.0-alpha2.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 4.7
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack Vector Local Local
Attack Complexity Low High
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1177661 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/coredns:1.6.7
  • coredns >= 1.6.7-3.13.1
Container caasp/v4/etcd:3.4.13
  • etcd >= 3.4.13-4.15.1
  • etcdctl >= 3.4.13-4.15.1
Container caasp/v4/helm-tiller:2.16.12
  • helm >= 2.16.12-3.10.1
Container caasp/v4/hyperkube:v1.17.17
  • kubernetes-common >= 1.17.13-4.21.2
Container caasp/v4/kubernetes-client:1.17.17
Container caasp/v4/kured:1.3.0
  • kubernetes-client >= 1.17.13-4.21.2
  • kubernetes-common >= 1.17.13-4.21.2
Container caasp/v4/kucero:1.3.0
  • kubernetes-client >= 1.17.13-4.21.2
  • kubernetes-common >= 1.17.13-4.21.2
  • kucero >= 1.3.0-1.3.1
SUSE CaaS Platform 4.0
  • caasp-release >= 4.2.4-24.36.1
  • cri-o >= 1.16.1-3.37.3
  • cri-o-kubeadm-criconfig >= 1.16.1-3.37.3
  • etcdctl >= 3.4.13-4.15.1
  • helm >= 2.16.12-3.10.1
  • helm3 >= 3.3.3-1.3.1
  • kubernetes-client >= 1.17.13-4.21.2
  • kubernetes-common >= 1.17.13-4.21.2
  • kubernetes-kubeadm >= 1.17.13-4.21.2
  • kubernetes-kubelet >= 1.17.13-4.21.2
  • skuba >= 1.4.11-3.49.2
  • skuba-update >= 1.4.11-3.49.2
  • terraform-provider-aws >= 2.59.0-1.6.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2020-3760
SUSE CaaS Platform 4.5
  • caasp-release >= 4.5.2-1.8.2
  • cri-o-1.18 >= 1.18.4-4.3.2
  • cri-o-1.18-kubeadm-criconfig >= 1.18.4-4.3.2
  • etcdctl >= 3.4.13-3.3.1
  • helm2 >= 2.16.12-3.3.1
  • helm3 >= 3.3.3-3.8.1
  • kubernetes-1.18-kubeadm >= 1.18.10-4.3.1
  • kubernetes-1.18-kubelet >= 1.18.10-4.3.1
  • patterns-caasp-Management >= 4.5-3.3.1
  • skuba >= 2.1.11-3.10.1
  • skuba-update >= 2.1.11-3.10.1
  • velero >= 1.4.2-3.3.1
Patchnames:
SUSE-SUSE-CAASP-4.5-2020-3761
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Containers 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • kubernetes-client >= 1.17.13-4.21.2
  • kubernetes-common >= 1.17.13-4.21.2
Patchnames:
SUSE-SLE-Module-Containers-15-SP1-2020-3760


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 helm Unsupported
SUSE Enterprise Storage 7.1 kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 12 kubernetes Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP5 helm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP6 helm Unsupported
SUSE Linux Enterprise Module for Containers 15 SP5 helm Unsupported
SUSE Linux Enterprise Module for Containers 15 SP6 helm Unsupported
SUSE Linux Enterprise Module for Package Hub 15 SP5 helm Unsupported
SUSE Linux Enterprise Module for Package Hub 15 SP6 helm Unsupported
SUSE Linux Enterprise Module for Public Cloud 12 kubernetes Won't fix
SUSE Linux Enterprise Server 12 SP5 kubernetes Won't fix
SUSE Linux Enterprise Server 15 SP5 helm Unsupported
SUSE Linux Enterprise Server 15 SP6 helm Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 kubernetes Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP5 helm Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP6 helm Unsupported
SUSE Manager Proxy 4.3 helm Unsupported
SUSE Manager Proxy 4.3 kubernetes1.18 Won't fix
SUSE Manager Retail Branch Server 4.3 helm Unsupported
SUSE Manager Retail Branch Server 4.3 kubernetes1.18 Won't fix
SUSE Manager Server 4.3 helm Unsupported
SUSE Manager Server 4.3 kubernetes1.18 Won't fix
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP3 helm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS helm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS helm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP4 helm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4 kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS helm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS helm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS kubernetes1.18 Won't fix
SUSE Linux Enterprise Module for Containers 15 SP2 kubernetes1.18 Won't fix
SUSE Linux Enterprise Module for Containers 15 SP3 helm Unsupported
SUSE Linux Enterprise Module for Containers 15 SP3 kubernetes1.18 Won't fix
SUSE Linux Enterprise Module for Containers 15 SP4 helm Unsupported
SUSE Linux Enterprise Module for Containers 15 SP4 kubernetes1.18 Won't fix
SUSE Linux Enterprise Server 15 SP2 kubernetes1.18 Won't fix
SUSE Linux Enterprise Server 15 SP2-LTSS kubernetes1.18 Won't fix
SUSE Linux Enterprise Server 15 SP3 helm Unsupported
SUSE Linux Enterprise Server 15 SP3 kubernetes1.18 Won't fix
SUSE Linux Enterprise Server 15 SP3-LTSS helm Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS kubernetes1.18 Won't fix
SUSE Linux Enterprise Server 15 SP4 helm Unsupported
SUSE Linux Enterprise Server 15 SP4 kubernetes1.18 Won't fix
SUSE Linux Enterprise Server 15 SP4-LTSS helm Unsupported
SUSE Linux Enterprise Server 15 SP4-LTSS kubernetes1.18 Won't fix
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 kubernetes Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 kubernetes1.18 Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP2 kubernetes1.18 Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP3 helm Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 kubernetes1.18 Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP4 helm Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 kubernetes1.18 Won't fix
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 caasp-release Released
SUSE CaaS Platform 4.0 cri-o Released
SUSE CaaS Platform 4.0 etcd Released
SUSE CaaS Platform 4.0 helm Released
SUSE CaaS Platform 4.0 helm3 Released
SUSE CaaS Platform 4.0 kubernetes Released
SUSE CaaS Platform 4.0 skuba Released
SUSE CaaS Platform 4.0 terraform-provider-aws Released
SUSE CaaS Platform 4.5 caasp-release Released
SUSE CaaS Platform 4.5 cri-o-1.18 Released
SUSE CaaS Platform 4.5 etcd Released
SUSE CaaS Platform 4.5 helm2 Released
SUSE CaaS Platform 4.5 helm3 Released
SUSE CaaS Platform 4.5 kubernetes-1.18 Released
SUSE CaaS Platform 4.5 patterns-caasp-Management Released
SUSE CaaS Platform 4.5 skuba Released
SUSE CaaS Platform 4.5 velero Released
SUSE Enterprise Storage 6 kubernetes Released
SUSE Enterprise Storage 7 kubernetes1.18 Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1 kubernetes Released
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS kubernetes Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS kubernetes Released
SUSE Linux Enterprise Module for Containers 15 SP1 kubernetes Released
SUSE Linux Enterprise Module for Package Hub 15 SP3 helm Unsupported
SUSE Linux Enterprise Module for Package Hub 15 SP4 helm Unsupported
SUSE Linux Enterprise Server 12 kubernetes Won't fix
SUSE Linux Enterprise Server 12 SP3 kubernetes Won't fix
SUSE Linux Enterprise Server 12 SP4 kubernetes Won't fix
SUSE Linux Enterprise Server 15 SP1 kubernetes Released
SUSE Linux Enterprise Server 15 SP1-BCL kubernetes Affected
SUSE Linux Enterprise Server 15 SP1-LTSS kubernetes Released
SUSE Linux Enterprise Server 15 SP2-BCL kubernetes1.18 Won't fix
SUSE Linux Enterprise Server 15 SP3-BCL helm Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL kubernetes1.18 Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 kubernetes Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP3 kubernetes Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP4 kubernetes Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP1 kubernetes Released
SUSE Manager Proxy 4.0 kubernetes Released
SUSE Manager Proxy 4.1 kubernetes1.18 Won't fix
SUSE Manager Proxy 4.2 helm Unsupported
SUSE Manager Proxy 4.2 kubernetes1.18 Won't fix
SUSE Manager Retail Branch Server 4.0 kubernetes Released
SUSE Manager Retail Branch Server 4.1 kubernetes1.18 Won't fix
SUSE Manager Retail Branch Server 4.2 helm Unsupported
SUSE Manager Retail Branch Server 4.2 kubernetes1.18 Won't fix
SUSE Manager Server 4.0 kubernetes Released
SUSE Manager Server 4.1 kubernetes1.18 Won't fix
SUSE Manager Server 4.2 helm Unsupported
SUSE Manager Server 4.2 kubernetes1.18 Won't fix
Container Status
suse/helm helmUnsupported


SUSE Timeline for this CVE

CVE page created: Wed Oct 14 08:31:51 2020
CVE page last modified: Wed May 22 17:42:37 2024