Upstream information

CVE-2020-8184 at MITRE

Description

A reliance on cookies without validation/integrity check security vulnerability exists in rack < 2.2.3, rack < 2.1.4 that makes it is possible for an attacker to forge a secure or host-only cookie prefix.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity Low High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None High
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1173351 [RESOLVED / FIXED], 1177352 [RESOLVED / FIXED], 1193081 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Storage 6
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • rmt-server >= 2.6.5-3.18.1
  • rmt-server-config >= 2.6.5-3.18.1
  • rmt-server-pubcloud >= 2.6.5-3.18.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP1-2020-3160
SUSE-SLE-Module-Server-Applications-15-SP1-2020-3160
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • rmt-server >= 2.6.5-3.3.1
  • rmt-server-config >= 2.6.5-3.3.1
  • rmt-server-pubcloud >= 2.6.5-3.3.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP2-2020-3036
SUSE-SLE-Module-Server-Applications-15-SP2-2020-3036
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • rmt-server >= 2.6.8-1.2
  • rmt-server-config >= 2.6.8-1.2
  • rmt-server-pubcloud >= 2.6.8-1.2
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP3 GA rmt-server-pubcloud-2.6.8-1.2
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA rmt-server-2.6.8-1.2
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • rmt-server >= 2.7.1-150400.1.7
  • rmt-server-config >= 2.7.1-150400.1.7
  • rmt-server-pubcloud >= 2.7.1-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP4 GA rmt-server-pubcloud-2.7.1-150400.1.7
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA rmt-server-2.7.1-150400.1.7
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • rmt-server >= 2.6.5-3.34.1
  • rmt-server-config >= 2.6.5-3.34.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-3147
SUSE Linux Enterprise Module for Public Cloud 15 SP1
  • rmt-server-pubcloud >= 2.6.5-3.18.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP1-2020-3160
SUSE Linux Enterprise Module for Public Cloud 15 SP2
  • rmt-server-pubcloud >= 2.6.5-3.3.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP2-2020-3036
SUSE Linux Enterprise Module for Public Cloud 15 SP3
  • rmt-server-pubcloud >= 2.6.8-1.2
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP3 GA rmt-server-pubcloud-2.6.8-1.2
SUSE Linux Enterprise Module for Public Cloud 15 SP4
  • rmt-server-pubcloud >= 2.7.1-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP4 GA rmt-server-pubcloud-2.7.1-150400.1.7
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • rmt-server >= 2.6.5-3.18.1
  • rmt-server-config >= 2.6.5-3.18.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2020-3160
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • rmt-server >= 2.6.5-3.3.1
  • rmt-server-config >= 2.6.5-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2020-3036
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • rmt-server >= 2.6.8-1.2
  • rmt-server-config >= 2.6.8-1.2
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA rmt-server-2.6.8-1.2
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • rmt-server >= 2.7.1-150400.1.7
  • rmt-server-config >= 2.7.1-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA rmt-server-2.7.1-150400.1.7
SUSE Linux Enterprise Server 15-LTSS
  • rmt-server >= 2.6.5-3.34.1
  • rmt-server-config >= 2.6.5-3.34.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-3147
SUSE Linux Enterprise Server for SAP Applications 15
  • rmt-server >= 2.6.5-3.34.1
  • rmt-server-config >= 2.6.5-3.34.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-3147
SUSE OpenStack Cloud 7
  • ruby2.1-rubygem-rack >= 1.6.13-3.8.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-2678
SUSE OpenStack Cloud 9
  • ansible1 >= 1.9.6-9.7.2
  • ardana-ansible >= 9.0+git.1591138508.e269bdb-3.22.2
  • ardana-cobbler >= 9.0+git.1588181228.bae3b1f-3.13.2
  • ardana-glance >= 9.0+git.1593631708.9354a78-3.13.2
  • ardana-input-model >= 9.0+git.1589740948.c24fc0b-3.19.2
  • ardana-logging >= 9.0+git.1591193994.d93b668-3.13.2
  • ardana-manila >= 9.0+git.1594158642.b5905e4-3.12.2
  • ardana-monasca >= 9.0+git.1589385256.7fbfaaf-3.19.2
  • ardana-mq >= 9.0+git.1593618110.cbd1a37-3.16.2
  • ardana-neutron >= 9.0+git.1590756257.e09d54f-3.22.2
  • ardana-octavia >= 9.0+git.1590079609.a2ae6ab-3.19.2
  • ardana-tempest >= 9.0+git.1593033709.9495bb2-3.16.2
  • grafana >= 6.2.5-3.12.2
  • kibana >= 4.6.3-4.3.2
  • openstack-barbican >= 7.0.1~dev24-3.9.5
  • openstack-barbican-api >= 7.0.1~dev24-3.9.5
  • openstack-barbican-keystone-listener >= 7.0.1~dev24-3.9.5
  • openstack-barbican-retry >= 7.0.1~dev24-3.9.5
  • openstack-barbican-worker >= 7.0.1~dev24-3.9.5
  • openstack-ceilometer >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-agent-central >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-agent-compute >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-agent-ipmi >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-agent-notification >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-polling >= 11.1.1~dev7-3.16.3
  • openstack-cinder >= 13.0.10~dev12-3.22.4
  • openstack-cinder-api >= 13.0.10~dev12-3.22.4
  • openstack-cinder-backup >= 13.0.10~dev12-3.22.4
  • openstack-cinder-scheduler >= 13.0.10~dev12-3.22.4
  • openstack-cinder-volume >= 13.0.10~dev12-3.22.4
  • openstack-dashboard >= 14.1.1~dev6-3.15.5
  • openstack-designate >= 7.0.2~dev2-3.19.3
  • openstack-designate-agent >= 7.0.2~dev2-3.19.3
  • openstack-designate-api >= 7.0.2~dev2-3.19.3
  • openstack-designate-central >= 7.0.2~dev2-3.19.3
  • openstack-designate-producer >= 7.0.2~dev2-3.19.3
  • openstack-designate-sink >= 7.0.2~dev2-3.19.3
  • openstack-designate-worker >= 7.0.2~dev2-3.19.3
  • openstack-heat-templates >= 0.0.0+git.1582270132.8a20477-3.6.2
  • openstack-ironic >= 11.1.5~dev6-3.19.3
  • openstack-ironic-api >= 11.1.5~dev6-3.19.3
  • openstack-ironic-conductor >= 11.1.5~dev6-3.19.3
  • openstack-keystone >= 14.2.1~dev4-3.22.3
  • openstack-magnum >= 7.2.1~dev1-3.13.3
  • openstack-magnum-api >= 7.2.1~dev1-3.13.3
  • openstack-magnum-conductor >= 7.2.1~dev1-3.13.3
  • openstack-manila >= 7.4.2~dev31-4.24.3
  • openstack-manila-api >= 7.4.2~dev31-4.24.3
  • openstack-manila-data >= 7.4.2~dev31-4.24.3
  • openstack-manila-scheduler >= 7.4.2~dev31-4.24.3
  • openstack-manila-share >= 7.4.2~dev31-4.24.3
  • openstack-monasca-agent >= 2.8.2~dev5-3.9.3
  • openstack-neutron >= 13.0.8~dev68-3.25.3
  • openstack-neutron-dhcp-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-ha-tool >= 13.0.8~dev68-3.25.3
  • openstack-neutron-l3-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-linuxbridge-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-macvtap-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-metadata-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-metering-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-openvswitch-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-server >= 13.0.8~dev68-3.25.3
  • openstack-neutron-vsphere >= 2.0.1~dev167-3.3.3
  • openstack-neutron-vsphere-doc >= 2.0.1~dev167-3.3.3
  • openstack-neutron-vsphere-dvs-agent >= 2.0.1~dev167-3.3.3
  • openstack-neutron-vsphere-ovsvapp-agent >= 2.0.1~dev167-3.3.3
  • openstack-nova >= 18.3.1~dev38-3.25.4
  • openstack-nova-api >= 18.3.1~dev38-3.25.4
  • openstack-nova-cells >= 18.3.1~dev38-3.25.4
  • openstack-nova-compute >= 18.3.1~dev38-3.25.4
  • openstack-nova-conductor >= 18.3.1~dev38-3.25.4
  • openstack-nova-console >= 18.3.1~dev38-3.25.4
  • openstack-nova-novncproxy >= 18.3.1~dev38-3.25.4
  • openstack-nova-placement-api >= 18.3.1~dev38-3.25.4
  • openstack-nova-scheduler >= 18.3.1~dev38-3.25.4
  • openstack-nova-serialproxy >= 18.3.1~dev38-3.25.4
  • openstack-nova-vncproxy >= 18.3.1~dev38-3.25.4
  • openstack-octavia >= 3.2.3~dev7-3.25.3
  • openstack-octavia-amphora-agent >= 3.2.3~dev7-3.25.3
  • openstack-octavia-amphora-image-x86_64 >= 0.1.4-7.12.3
  • openstack-octavia-api >= 3.2.3~dev7-3.25.3
  • openstack-octavia-health-manager >= 3.2.3~dev7-3.25.3
  • openstack-octavia-housekeeping >= 3.2.3~dev7-3.25.3
  • openstack-octavia-worker >= 3.2.3~dev7-3.25.3
  • openstack-resource-agents >= 1.0+git.1569436425.8b9c49f-5.3.2
  • python-Django1 >= 1.11.29-3.15.2
  • python-Pillow >= 5.2.0-3.3.2
  • python-ardana-packager >= 0.0.3-9.3.2
  • python-barbican >= 7.0.1~dev24-3.9.5
  • python-ceilometer >= 11.1.1~dev7-3.16.3
  • python-cinder >= 13.0.10~dev12-3.22.4
  • python-designate >= 7.0.2~dev2-3.19.3
  • python-heatclient >= 1.16.3-3.3.3
  • python-heatclient-doc >= 1.16.3-3.3.3
  • python-horizon >= 14.1.1~dev6-3.15.5
  • python-ironic >= 11.1.5~dev6-3.19.3
  • python-keystone >= 14.2.1~dev4-3.22.3
  • python-magnum >= 7.2.1~dev1-3.13.3
  • python-manila >= 7.4.2~dev31-4.24.3
  • python-monasca-agent >= 2.8.2~dev5-3.9.3
  • python-networking-vsphere >= 2.0.1~dev167-3.3.3
  • python-neutron >= 13.0.8~dev68-3.25.3
  • python-neutron-tempest-plugin >= 0.2.0-3.3.2
  • python-nova >= 18.3.1~dev38-3.25.4
  • python-octavia >= 3.2.3~dev7-3.25.3
  • python-octavia-tempest-plugin >= 0.2.0-3.3.2
  • python-openstack_auth >= 14.1.1~dev6-3.15.5
  • python-os-brick >= 2.5.10-3.12.3
  • python-os-brick-common >= 2.5.10-3.12.3
  • python-oslo.messaging >= 8.1.4-3.6.2
  • python-pyroute2 >= 0.5.2-4.3.2
  • python-urllib3 >= 1.23-3.12.2
  • python-waitress >= 1.4.3-3.3.1
  • release-notes-suse-openstack-cloud >= 9.20200610-3.21.4
  • venv-openstack-barbican-x86_64 >= 7.0.1~dev24-3.19.3
  • venv-openstack-cinder-x86_64 >= 13.0.10~dev12-3.19.2
  • venv-openstack-designate-x86_64 >= 7.0.2~dev2-3.19.2
  • venv-openstack-glance-x86_64 >= 17.0.1~dev30-3.17.2
  • venv-openstack-heat-x86_64 >= 11.0.3~dev35-3.19.2
  • venv-openstack-horizon-x86_64 >= 14.1.1~dev6-4.18.3
  • venv-openstack-ironic-x86_64 >= 11.1.5~dev6-4.15.2
  • venv-openstack-keystone-x86_64 >= 14.2.1~dev4-3.19.2
  • venv-openstack-magnum-x86_64 >= 7.2.1~dev1-4.19.2
  • venv-openstack-manila-x86_64 >= 7.4.2~dev31-3.21.2
  • venv-openstack-monasca-ceilometer-x86_64 >= 1.8.2~dev3-3.19.2
  • venv-openstack-monasca-x86_64 >= 2.7.1~dev10-3.17.3
  • venv-openstack-neutron-x86_64 >= 13.0.8~dev68-6.19.2
  • venv-openstack-nova-x86_64 >= 18.3.1~dev38-3.19.3
  • venv-openstack-octavia-x86_64 >= 3.2.3~dev7-4.19.2
  • venv-openstack-sahara-x86_64 >= 9.0.2~dev15-3.19.2
  • venv-openstack-swift-x86_64 >= 2.19.2~dev48-2.14.2
Patchnames:
SUSE-OpenStack-Cloud-9-2020-2161
SUSE OpenStack Cloud Crowbar 8
  • ruby2.1-rubygem-rack >= 1.6.13-3.8.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-2678
SUSE OpenStack Cloud Crowbar 9
  • crowbar-core >= 6.0+git.1594619891.b75a61d0d-3.25.5
  • crowbar-core-branding-upstream >= 6.0+git.1594619891.b75a61d0d-3.25.5
  • crowbar-openstack >= 6.0+git.1591795073.49cb6400e-3.25.3
  • grafana >= 6.2.5-3.12.2
  • kibana >= 4.6.3-4.3.2
  • openstack-barbican >= 7.0.1~dev24-3.9.5
  • openstack-barbican-api >= 7.0.1~dev24-3.9.5
  • openstack-barbican-keystone-listener >= 7.0.1~dev24-3.9.5
  • openstack-barbican-retry >= 7.0.1~dev24-3.9.5
  • openstack-barbican-worker >= 7.0.1~dev24-3.9.5
  • openstack-ceilometer >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-agent-central >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-agent-compute >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-agent-ipmi >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-agent-notification >= 11.1.1~dev7-3.16.3
  • openstack-ceilometer-polling >= 11.1.1~dev7-3.16.3
  • openstack-cinder >= 13.0.10~dev12-3.22.4
  • openstack-cinder-api >= 13.0.10~dev12-3.22.4
  • openstack-cinder-backup >= 13.0.10~dev12-3.22.4
  • openstack-cinder-scheduler >= 13.0.10~dev12-3.22.4
  • openstack-cinder-volume >= 13.0.10~dev12-3.22.4
  • openstack-dashboard >= 14.1.1~dev6-3.15.5
  • openstack-designate >= 7.0.2~dev2-3.19.3
  • openstack-designate-agent >= 7.0.2~dev2-3.19.3
  • openstack-designate-api >= 7.0.2~dev2-3.19.3
  • openstack-designate-central >= 7.0.2~dev2-3.19.3
  • openstack-designate-producer >= 7.0.2~dev2-3.19.3
  • openstack-designate-sink >= 7.0.2~dev2-3.19.3
  • openstack-designate-worker >= 7.0.2~dev2-3.19.3
  • openstack-heat-templates >= 0.0.0+git.1582270132.8a20477-3.6.2
  • openstack-ironic >= 11.1.5~dev6-3.19.3
  • openstack-ironic-api >= 11.1.5~dev6-3.19.3
  • openstack-ironic-conductor >= 11.1.5~dev6-3.19.3
  • openstack-keystone >= 14.2.1~dev4-3.22.3
  • openstack-magnum >= 7.2.1~dev1-3.13.3
  • openstack-magnum-api >= 7.2.1~dev1-3.13.3
  • openstack-magnum-conductor >= 7.2.1~dev1-3.13.3
  • openstack-manila >= 7.4.2~dev31-4.24.3
  • openstack-manila-api >= 7.4.2~dev31-4.24.3
  • openstack-manila-data >= 7.4.2~dev31-4.24.3
  • openstack-manila-scheduler >= 7.4.2~dev31-4.24.3
  • openstack-manila-share >= 7.4.2~dev31-4.24.3
  • openstack-monasca-agent >= 2.8.2~dev5-3.9.3
  • openstack-neutron >= 13.0.8~dev68-3.25.3
  • openstack-neutron-dhcp-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-ha-tool >= 13.0.8~dev68-3.25.3
  • openstack-neutron-l3-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-linuxbridge-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-macvtap-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-metadata-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-metering-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-openvswitch-agent >= 13.0.8~dev68-3.25.3
  • openstack-neutron-server >= 13.0.8~dev68-3.25.3
  • openstack-neutron-vsphere >= 2.0.1~dev167-3.3.3
  • openstack-neutron-vsphere-doc >= 2.0.1~dev167-3.3.3
  • openstack-neutron-vsphere-dvs-agent >= 2.0.1~dev167-3.3.3
  • openstack-neutron-vsphere-ovsvapp-agent >= 2.0.1~dev167-3.3.3
  • openstack-nova >= 18.3.1~dev38-3.25.4
  • openstack-nova-api >= 18.3.1~dev38-3.25.4
  • openstack-nova-cells >= 18.3.1~dev38-3.25.4
  • openstack-nova-compute >= 18.3.1~dev38-3.25.4
  • openstack-nova-conductor >= 18.3.1~dev38-3.25.4
  • openstack-nova-console >= 18.3.1~dev38-3.25.4
  • openstack-nova-novncproxy >= 18.3.1~dev38-3.25.4
  • openstack-nova-placement-api >= 18.3.1~dev38-3.25.4
  • openstack-nova-scheduler >= 18.3.1~dev38-3.25.4
  • openstack-nova-serialproxy >= 18.3.1~dev38-3.25.4
  • openstack-nova-vncproxy >= 18.3.1~dev38-3.25.4
  • openstack-octavia >= 3.2.3~dev7-3.25.3
  • openstack-octavia-amphora-agent >= 3.2.3~dev7-3.25.3
  • openstack-octavia-amphora-image-x86_64 >= 0.1.4-7.12.3
  • openstack-octavia-api >= 3.2.3~dev7-3.25.3
  • openstack-octavia-health-manager >= 3.2.3~dev7-3.25.3
  • openstack-octavia-housekeeping >= 3.2.3~dev7-3.25.3
  • openstack-octavia-worker >= 3.2.3~dev7-3.25.3
  • openstack-resource-agents >= 1.0+git.1569436425.8b9c49f-5.3.2
  • python-Django1 >= 1.11.29-3.15.2
  • python-Pillow >= 5.2.0-3.3.2
  • python-barbican >= 7.0.1~dev24-3.9.5
  • python-ceilometer >= 11.1.1~dev7-3.16.3
  • python-cinder >= 13.0.10~dev12-3.22.4
  • python-designate >= 7.0.2~dev2-3.19.3
  • python-heatclient >= 1.16.3-3.3.3
  • python-heatclient-doc >= 1.16.3-3.3.3
  • python-horizon >= 14.1.1~dev6-3.15.5
  • python-ironic >= 11.1.5~dev6-3.19.3
  • python-keystone >= 14.2.1~dev4-3.22.3
  • python-magnum >= 7.2.1~dev1-3.13.3
  • python-manila >= 7.4.2~dev31-4.24.3
  • python-monasca-agent >= 2.8.2~dev5-3.9.3
  • python-networking-vsphere >= 2.0.1~dev167-3.3.3
  • python-neutron >= 13.0.8~dev68-3.25.3
  • python-neutron-tempest-plugin >= 0.2.0-3.3.2
  • python-nova >= 18.3.1~dev38-3.25.4
  • python-octavia >= 3.2.3~dev7-3.25.3
  • python-octavia-tempest-plugin >= 0.2.0-3.3.2
  • python-openstack_auth >= 14.1.1~dev6-3.15.5
  • python-os-brick >= 2.5.10-3.12.3
  • python-os-brick-common >= 2.5.10-3.12.3
  • python-oslo.messaging >= 8.1.4-3.6.2
  • python-pyroute2 >= 0.5.2-4.3.2
  • python-urllib3 >= 1.23-3.12.2
  • python-waitress >= 1.4.3-3.3.1
  • release-notes-suse-openstack-cloud >= 9.20200610-3.21.4
  • ruby2.1-rubygem-activeresource >= 4.0.0-4.3.1
  • ruby2.1-rubygem-json-1_7 >= 1.7.7-4.3.1
  • ruby2.1-rubygem-puma >= 2.16.0-4.9.1
  • ruby2.1-rubygem-rack >= 1.6.13-3.8.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2020-2161
SUSE-OpenStack-Cloud-Crowbar-9-2020-2678
openSUSE Leap 15.1
  • rmt-server >= 2.6.5-lp151.2.18.2
  • rmt-server-config >= 2.6.5-lp151.2.18.2
  • rmt-server-pubcloud >= 2.6.5-lp151.2.18.2
Patchnames:
openSUSE-2020-2000
openSUSE Leap 15.2
  • rmt-server >= 2.6.5-lp152.2.3.1
  • rmt-server-config >= 2.6.5-lp152.2.3.1
  • rmt-server-pubcloud >= 2.6.5-lp152.2.3.1
Patchnames:
openSUSE-2020-1993
openSUSE Tumbleweed
  • rmt-server >= 2.6.13-1.1
  • rmt-server-config >= 2.6.13-1.1
  • rmt-server-pubcloud >= 2.6.13-1.1
  • ruby2.7-rubygem-rack >= 2.2.3-1.7
  • ruby3.0-rubygem-rack >= 2.2.3-1.7
  • ruby3.1-rubygem-rack >= 2.2.3.1-1.1
Patchnames:
openSUSE Tumbleweed GA rmt-server-2.6.13-1.1
openSUSE Tumbleweed GA ruby2.7-rubygem-rack-2.2.3-1.7
openSUSE Tumbleweed GA ruby3.1-rubygem-rack-2.2.3.1-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 15 rubygem-rack Affected
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-rack Affected
SUSE Linux Enterprise High Availability Extension 15 SP3 rubygem-rack Affected
SUSE Linux Enterprise High Availability Extension 15 SP4 rubygem-rack Affected
SUSE Linux Enterprise High Performance Computing 12 rubygem-rack-1_4 Affected
SUSE Linux Enterprise High Performance Computing 15 rubygem-rack Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 rubygem-rack Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 rubygem-rack Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 rubygem-rack Affected
SUSE Linux Enterprise Module for Containers 12 rubygem-rack-1_4 Affected
SUSE Linux Enterprise Server 12 rubygem-rack-1_4 Affected
SUSE Linux Enterprise Server 12 SP3 rubygem-rack-1_4 Affected
SUSE Linux Enterprise Server 12 SP4 rubygem-rack-1_4 Affected
SUSE Linux Enterprise Server 12 SP5 rubygem-rack-1_4 Affected
SUSE Linux Enterprise Server 15 rubygem-rack Affected
SUSE Linux Enterprise Server 15 SP1 rubygem-rack Affected
SUSE Linux Enterprise Server 15 SP3 rubygem-rack Affected
SUSE Linux Enterprise Server 15 SP4 rubygem-rack Affected
SUSE Linux Enterprise Server for SAP Applications 12 rubygem-rack-1_4 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 rubygem-rack-1_4 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 rubygem-rack-1_4 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 rubygem-rack-1_4 Affected
SUSE Linux Enterprise Server for SAP Applications 15 rubygem-rack Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rubygem-rack Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rubygem-rack Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 rubygem-rack Affected
SUSE Manager Proxy 4.0 rubygem-rack Affected
SUSE Manager Proxy 4.2 rubygem-rack Affected
SUSE Manager Proxy 4.3 rubygem-rack Affected
SUSE Manager Retail Branch Server 4.0 rubygem-rack Affected
SUSE Manager Retail Branch Server 4.2 rubygem-rack Affected
SUSE Manager Retail Branch Server 4.3 rubygem-rack Affected
SUSE Manager Server 4.0 rubygem-rack Affected
SUSE Manager Server 4.2 rubygem-rack Affected
SUSE Manager Server 4.3 rubygem-rack Affected
SUSE OpenStack Cloud 6 LTSS rubygem-rack Unsupported
SUSE OpenStack Cloud 7 rubygem-rack Released
SUSE OpenStack Cloud Crowbar 8 rubygem-rack Released
SUSE OpenStack Cloud Crowbar 9 rubygem-rack Released