Upstream information

CVE-2020-7788 at MITRE


This affects the package ini before 1.3.6. If an attacker submits a malicious INI file to an application that parses it with ini.parse, they will pollute the prototype on the application. This can be exploited further depending on the context.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 8
  • nodejs >= 16.13.1-3.module+el8.5.0+13548+45d748af
  • nodejs-devel >= 16.13.1-3.module+el8.5.0+13548+45d748af
  • nodejs-docs >= 16.13.1-3.module+el8.5.0+13548+45d748af
  • nodejs-full-i18n >= 16.13.1-3.module+el8.5.0+13548+45d748af
  • nodejs-nodemon >= 2.0.15-1.module+el8.5.0+13548+45d748af
  • nodejs-packaging >= 25-1.module+el8.5.0+10992+fac5fe06
  • npm >= 8.1.2-
SUSE Liberty Linux 9
  • nodejs >= 16.16.0-1.el9_0
  • nodejs-docs >= 16.16.0-1.el9_0
  • nodejs-full-i18n >= 16.16.0-1.el9_0
  • nodejs-libs >= 16.16.0-1.el9_0
  • nodejs-nodemon >= 2.0.19-1.el9_0
  • npm >= 8.11.0-

SUSE Timeline for this CVE

CVE page created: Fri Dec 11 16:42:06 2020
CVE page last modified: Mon Oct 30 18:09:03 2023