Upstream information

CVE-2020-36327 at MITRE

Description

Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.16 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application. NOTE: it is not correct to use CVE-2021-24105 for every "Dependency Confusion" issue in every product.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 7.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1185842 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications rubygem-bundler Not affected
SUSE CaaS Platform 4.0 rubygem-bundler Affected
SUSE Enterprise Storage 6 rubygem-bundler Affected
SUSE Linux Enterprise High Availability Extension 11 SP4 rubygem-bundler Not affected
SUSE Linux Enterprise High Availability Extension 12 SP3 rubygem-bundler Not affected
SUSE Linux Enterprise High Availability Extension 12 SP4 rubygem-bundler Not affected
SUSE Linux Enterprise High Availability Extension 12 SP5 rubygem-bundler Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS rubygem-bundler Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS rubygem-bundler Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 rubygem-bundler Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON rubygem-bundler Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP rubygem-bundler Not affected
SUSE Linux Enterprise Server 15 LTSS rubygem-bundler Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux rubygem-bundler Affected
SUSE Linux Enterprise Server 15 SP1 LTSS rubygem-bundler Affected
SUSE Linux Enterprise Server ESPOS 15 rubygem-bundler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 rubygem-bundler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 rubygem-bundler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 rubygem-bundler Not affected
SUSE Linux Enterprise Server for SAP Applications 15 rubygem-bundler Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rubygem-bundler Affected
SUSE Manager Proxy 4.0 rubygem-bundler Affected
SUSE Manager Retail Branch Server 4.0 rubygem-bundler Affected
SUSE Manager Server 4.0 rubygem-bundler Affected
SUSE OpenStack Cloud 7 rubygem-bundler Not affected
SUSE OpenStack Cloud Crowbar 8 rubygem-bundler Not affected
SUSE OpenStack Cloud Crowbar 9 rubygem-bundler Not affected