Upstream information

CVE-2020-36193 at MITRE

Description

Tar.php in Archive_Tar through 1.4.11 allows write operations with Directory Traversal due to inadequate checking of symbolic links, a related issue to CVE-2020-28948.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1189591 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • php7-pear-Archive_Tar >= 7.2.5-4.82.1
  • php7-wddx >= 7.2.5-4.82.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-2872
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • php7-pear-Archive_Tar >= 7.2.5-4.82.1
  • php7-wddx >= 7.2.5-4.82.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-2872
SUSE Linux Enterprise Module for Web Scripting 12
  • apache2-mod_php72 >= 7.2.5-1.69.1
  • php72 >= 7.2.5-1.69.1
  • php72-bcmath >= 7.2.5-1.69.1
  • php72-bz2 >= 7.2.5-1.69.1
  • php72-calendar >= 7.2.5-1.69.1
  • php72-ctype >= 7.2.5-1.69.1
  • php72-curl >= 7.2.5-1.69.1
  • php72-dba >= 7.2.5-1.69.1
  • php72-dom >= 7.2.5-1.69.1
  • php72-enchant >= 7.2.5-1.69.1
  • php72-exif >= 7.2.5-1.69.1
  • php72-fastcgi >= 7.2.5-1.69.1
  • php72-fileinfo >= 7.2.5-1.69.1
  • php72-fpm >= 7.2.5-1.69.1
  • php72-ftp >= 7.2.5-1.69.1
  • php72-gd >= 7.2.5-1.69.1
  • php72-gettext >= 7.2.5-1.69.1
  • php72-gmp >= 7.2.5-1.69.1
  • php72-iconv >= 7.2.5-1.69.1
  • php72-imap >= 7.2.5-1.69.1
  • php72-intl >= 7.2.5-1.69.1
  • php72-json >= 7.2.5-1.69.1
  • php72-ldap >= 7.2.5-1.69.1
  • php72-mbstring >= 7.2.5-1.69.1
  • php72-mysql >= 7.2.5-1.69.1
  • php72-odbc >= 7.2.5-1.69.1
  • php72-opcache >= 7.2.5-1.69.1
  • php72-openssl >= 7.2.5-1.69.1
  • php72-pcntl >= 7.2.5-1.69.1
  • php72-pdo >= 7.2.5-1.69.1
  • php72-pear >= 7.2.5-1.69.1
  • php72-pear-Archive_Tar >= 7.2.5-1.69.1
  • php72-pgsql >= 7.2.5-1.69.1
  • php72-phar >= 7.2.5-1.69.1
  • php72-posix >= 7.2.5-1.69.1
  • php72-pspell >= 7.2.5-1.69.1
  • php72-readline >= 7.2.5-1.69.1
  • php72-shmop >= 7.2.5-1.69.1
  • php72-snmp >= 7.2.5-1.69.1
  • php72-soap >= 7.2.5-1.69.1
  • php72-sockets >= 7.2.5-1.69.1
  • php72-sodium >= 7.2.5-1.69.1
  • php72-sqlite >= 7.2.5-1.69.1
  • php72-sysvmsg >= 7.2.5-1.69.1
  • php72-sysvsem >= 7.2.5-1.69.1
  • php72-sysvshm >= 7.2.5-1.69.1
  • php72-tidy >= 7.2.5-1.69.1
  • php72-tokenizer >= 7.2.5-1.69.1
  • php72-wddx >= 7.2.5-1.69.1
  • php72-xmlreader >= 7.2.5-1.69.1
  • php72-xmlrpc >= 7.2.5-1.69.1
  • php72-xmlwriter >= 7.2.5-1.69.1
  • php72-xsl >= 7.2.5-1.69.1
  • php72-zip >= 7.2.5-1.69.1
  • php72-zlib >= 7.2.5-1.69.1
  • php74-pear >= 1.10.21-1.6.1
  • php74-pecl >= 1.10.21-1.6.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2021-2926
SUSE-SLE-Module-Web-Scripting-12-2021-3006
SUSE Linux Enterprise Module for Web Scripting 15 SP2
  • php7-pear >= 1.10.21-3.6.1
  • php7-pecl >= 1.10.21-3.6.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP2-2021-3018
SUSE Linux Enterprise Module for Web Scripting 15 SP3
  • php7-pear >= 1.10.21-3.6.1
  • php7-pecl >= 1.10.21-3.6.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP3-2021-3018
SUSE Linux Enterprise Software Development Kit 12 SP5
  • php72-devel >= 7.2.5-1.69.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-2926
openSUSE Leap 15.2
  • php7-pear >= 1.10.21-lp152.2.6.1
  • php7-pecl >= 1.10.21-lp152.2.6.1
Patchnames:
openSUSE-2021-1267
openSUSE Leap 15.3
  • php7-pear >= 1.10.21-3.6.1
  • php7-pecl >= 1.10.21-3.6.1
  • php7-wddx >= 7.2.5-4.82.1
Patchnames:
openSUSE-SLE-15.3-2021-2872
openSUSE-SLE-15.3-2021-3018


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 php7 In progress
SUSE Enterprise Storage 6 php7 In progress
SUSE Linux Enterprise High Performance Computing 15 LTSS php7 In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS php7 Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS php7 In progress
SUSE Linux Enterprise Module for Web and Scripting 12 php5 In progress
SUSE Linux Enterprise Module for Web and Scripting 12 php7 In progress
SUSE Linux Enterprise Module for Web and Scripting 12 php72 Released
SUSE Linux Enterprise Module for Web and Scripting 12 php74 In progress
SUSE Linux Enterprise Module for Web and Scripting 12 php74-pear Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 php7-pear Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 php7-pear Released
SUSE Linux Enterprise Point of Service 11 SP3 php53 In progress
SUSE Linux Enterprise Server 11 SP3 php53 Analysis
SUSE Linux Enterprise Server 11 SP4 php53 Analysis
SUSE Linux Enterprise Server 11 SP4 LTSS php53 In progress
SUSE Linux Enterprise Server 15 ESPOS php7 In progress
SUSE Linux Enterprise Server 15 LTSS php7 In progress
SUSE Linux Enterprise Server 15 SP1 LTSS php7 In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 php7 In progress
SUSE Linux Enterprise Server for SAP Applications 15 php7 In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 php7 In progress
SUSE Linux Enterprise Software Development Kit 12 SP5 php72 Released
SUSE Manager Proxy 4.0 php7 In progress
SUSE Manager Retail Branch Server 4.0 php7 In progress
SUSE Manager Server 4.0 php7 In progress
SUSE Package Hub 15 php7 Released
SUSE Package Hub 15 SP1 php7 Released
SUSE Package Hub 15 SP3 php7 Analysis