Upstream information

CVE-2020-35452 at MITRE

Description

Apache HTTP Server versions 2.4.0 to 2.4.46 A specially crafted Digest nonce can cause a stack overflow in mod_auth_digest. There is no report of this overflow being exploitable, nor the Apache HTTP Server team could create one, though some particular compiler and/or compilation option might make it possible, with limited consequences anyway due to the size (a single byte) and the value (zero byte) of the overflow

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.3 8.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low High
Integrity Impact Low High
Availability Impact Low High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1186922 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
HPE-Helion-OpenStack-8-2021-2006
SUSE CaaS Platform 4.0
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-2004
SUSE Enterprise Storage 6
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-Storage-6-2021-2004
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-2004
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-2004
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-2004
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • apache2 >= 2.4.43-3.22.1
  • apache2-prefork >= 2.4.43-3.22.1
  • apache2-utils >= 2.4.43-3.22.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-2127
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • apache2 >= 2.4.43-3.22.1
  • apache2-prefork >= 2.4.43-3.22.1
  • apache2-utils >= 2.4.43-3.22.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-2127
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • apache2-event >= 2.4.43-3.22.1
  • apache2-example-pages >= 2.4.43-3.22.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-2127
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • apache2-event >= 2.4.43-3.22.1
  • apache2-example-pages >= 2.4.43-3.22.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-2127
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • apache2-devel >= 2.4.43-3.22.1
  • apache2-doc >= 2.4.43-3.22.1
  • apache2-worker >= 2.4.43-3.22.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2021-2127
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • apache2-devel >= 2.4.43-3.22.1
  • apache2-doc >= 2.4.43-3.22.1
  • apache2-worker >= 2.4.43-3.22.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP3-2021-2127
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • apache2-event >= 2.4.43-3.22.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2021-2127
SUSE Linux Enterprise Point of Sale 11 SP3
  • apache2 >= 2.2.34-70.35.1
  • apache2-devel >= 2.2.34-70.35.1
  • apache2-doc >= 2.2.34-70.35.1
  • apache2-example-pages >= 2.2.34-70.35.1
  • apache2-prefork >= 2.2.34-70.35.1
  • apache2-utils >= 2.2.34-70.35.1
  • apache2-worker >= 2.2.34-70.35.1
Patchnames:
sleposp3-apache2-14749
SUSE Linux Enterprise Server 11 SP4-LTSS
  • apache2 >= 2.2.34-70.35.1
  • apache2-doc >= 2.2.34-70.35.1
  • apache2-example-pages >= 2.2.34-70.35.1
  • apache2-prefork >= 2.2.34-70.35.1
  • apache2-utils >= 2.2.34-70.35.1
  • apache2-worker >= 2.2.34-70.35.1
Patchnames:
slessp4-apache2-14749
SUSE Linux Enterprise Server 12 SP2-BCL
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2021-2006
SUSE Linux Enterprise Server 12 SP3-BCL
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2021-2006
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2021-2006
SUSE Linux Enterprise Server 12 SP3-LTSS
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2021-2006
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-2006
SUSE Linux Enterprise Server 12 SP4-LTSS
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-2006
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-2006
SUSE Linux Enterprise Server 15 SP1-BCL
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-2004
SUSE Linux Enterprise Server 15 SP1-LTSS
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-2004
SUSE Linux Enterprise Server 15-LTSS
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-2004
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2021-2006
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-2006
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-2004
SUSE Linux Enterprise Server for SAP Applications 15
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-2004
SUSE Linux Enterprise Software Development Kit 12 SP5
  • apache2-devel >= 2.4.23-29.74.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-2006
SUSE Manager Proxy 4.0
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-2004
SUSE Manager Retail Branch Server 4.0
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-2004
SUSE Manager Server 4.0
  • apache2 >= 2.4.33-3.50.1
  • apache2-devel >= 2.4.33-3.50.1
  • apache2-doc >= 2.4.33-3.50.1
  • apache2-prefork >= 2.4.33-3.50.1
  • apache2-utils >= 2.4.33-3.50.1
  • apache2-worker >= 2.4.33-3.50.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-2004
SUSE OpenStack Cloud 8
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-OpenStack-Cloud-8-2021-2006
SUSE OpenStack Cloud 9
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-2006
SUSE OpenStack Cloud Crowbar 8
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-2006
SUSE OpenStack Cloud Crowbar 9
  • apache2 >= 2.4.23-29.74.1
  • apache2-doc >= 2.4.23-29.74.1
  • apache2-example-pages >= 2.4.23-29.74.1
  • apache2-prefork >= 2.4.23-29.74.1
  • apache2-utils >= 2.4.23-29.74.1
  • apache2-worker >= 2.4.23-29.74.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-2006
openSUSE Leap 15.2
  • apache2 >= 2.4.43-lp152.2.15.1
  • apache2-debuginfo >= 2.4.43-lp152.2.15.1
  • apache2-debugsource >= 2.4.43-lp152.2.15.1
  • apache2-devel >= 2.4.43-lp152.2.15.1
  • apache2-doc >= 2.4.43-lp152.2.15.1
  • apache2-event >= 2.4.43-lp152.2.15.1
  • apache2-event-debuginfo >= 2.4.43-lp152.2.15.1
  • apache2-example-pages >= 2.4.43-lp152.2.15.1
  • apache2-prefork >= 2.4.43-lp152.2.15.1
  • apache2-prefork-debuginfo >= 2.4.43-lp152.2.15.1
  • apache2-utils >= 2.4.43-lp152.2.15.1
  • apache2-utils-debuginfo >= 2.4.43-lp152.2.15.1
  • apache2-worker >= 2.4.43-lp152.2.15.1
  • apache2-worker-debuginfo >= 2.4.43-lp152.2.15.1
Patchnames:
openSUSE-2021-908
openSUSE Leap 15.3
  • apache2 >= 2.4.43-3.22.1
  • apache2-devel >= 2.4.43-3.22.1
  • apache2-doc >= 2.4.43-3.22.1
  • apache2-event >= 2.4.43-3.22.1
  • apache2-example-pages >= 2.4.43-3.22.1
  • apache2-prefork >= 2.4.43-3.22.1
  • apache2-utils >= 2.4.43-3.22.1
  • apache2-worker >= 2.4.43-3.22.1
Patchnames:
openSUSE-SLE-15.3-2021-2127


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 apache2 Released
SUSE CaaS Platform 4.0 apache2 In progress
SUSE Enterprise Storage 6 apache2 In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 apache2 Released
SUSE Linux Enterprise High Performance Computing 15 LTSS apache2 In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS apache2 In progress
SUSE Linux Enterprise Module for Basesystem 15 SP2 apache2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 apache2 Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 apache2 Released
SUSE Linux Enterprise Module for Server Applications 15 SP3 apache2 Released
SUSE Linux Enterprise Point of Service 11 SP3 apache2 Released
SUSE Linux Enterprise Server 11 SP4 LTSS apache2 Released
SUSE Linux Enterprise Server 12 SP2 BCL apache2 Released
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON apache2 Released
SUSE Linux Enterprise Server 12 SP2 LTSS SAP apache2 Released
SUSE Linux Enterprise Server 12 SP3 BCL apache2 Released
SUSE Linux Enterprise Server 12 SP3 ESPOS apache2 Released
SUSE Linux Enterprise Server 12 SP3 LTSS apache2 Released
SUSE Linux Enterprise Server 12 SP4 ESPOS apache2 Released
SUSE Linux Enterprise Server 12 SP4 LTSS apache2 Released
SUSE Linux Enterprise Server 12 SP5 apache2 Released
SUSE Linux Enterprise Server 15 LTSS apache2 In progress
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux apache2 In progress
SUSE Linux Enterprise Server 15 SP1 LTSS apache2 In progress
SUSE Linux Enterprise Server ESPOS 15 apache2 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 apache2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 apache2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 apache2 Released
SUSE Linux Enterprise Server for SAP Applications 15 apache2 In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 apache2 In progress
SUSE Linux Enterprise Software Development Kit 12 SP5 apache2 Released
SUSE Manager Proxy 4.0 apache2 In progress
SUSE Manager Retail Branch Server 4.0 apache2 In progress
SUSE Manager Server 4.0 apache2 In progress
SUSE OpenStack Cloud 8 apache2 Released
SUSE OpenStack Cloud 9 apache2 Released
SUSE OpenStack Cloud Crowbar 8 apache2 Released
SUSE OpenStack Cloud Crowbar 9 apache2 Released
SUSE Package Hub 15 apache2 Released