Upstream information

CVE-2020-29385 at MITRE

Description

GNOME gdk-pixbuf (aka GdkPixbuf) before 2.42.2 allows a denial of service (infinite loop) in lzw.c in the function write_indexes. if c->self_code equals 10, self->code_table[10].extends will assign the value 11 to c. The next execution in the loop will assign self->code_table[11].extends to c, which will give the value of 10. This will make the loop run infinitely. This bug can, for example, be triggered by calling this function with a GIF image with LZW compression that is crafted in a special way.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 6.2
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1180393 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • gdk-pixbuf-devel >= 2.40.0-3.3.1
  • gdk-pixbuf-lang >= 2.40.0-3.3.1
  • gdk-pixbuf-query-loaders >= 2.40.0-3.3.1
  • gdk-pixbuf-thumbnailer >= 2.40.0-3.3.1
  • libgdk_pixbuf-2_0-0 >= 2.40.0-3.3.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.40.0-3.3.1
  • typelib-1_0-GdkPixdata-2_0 >= 2.40.0-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-184
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • gdk-pixbuf-devel >= 2.40.0-3.3.1
  • gdk-pixbuf-lang >= 2.40.0-3.3.1
  • gdk-pixbuf-query-loaders >= 2.40.0-3.3.1
  • gdk-pixbuf-thumbnailer >= 2.40.0-3.3.1
  • libgdk_pixbuf-2_0-0 >= 2.40.0-3.3.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.40.0-3.3.1
  • typelib-1_0-GdkPixdata-2_0 >= 2.40.0-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • gdk-pixbuf-query-loaders-32bit >= 2.40.0-3.3.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.40.0-3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-184
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • gdk-pixbuf-query-loaders-32bit >= 2.40.0-3.3.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.40.0-3.3.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • gdk-pixbuf-devel-32bit >= 2.40.0-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-184
openSUSE Leap 15.2
  • gdk-pixbuf-devel >= 2.40.0-lp152.2.3.1
  • gdk-pixbuf-devel-32bit >= 2.40.0-lp152.2.3.1
  • gdk-pixbuf-lang >= 2.40.0-lp152.2.3.1
  • gdk-pixbuf-query-loaders >= 2.40.0-lp152.2.3.1
  • gdk-pixbuf-query-loaders-32bit >= 2.40.0-lp152.2.3.1
  • gdk-pixbuf-thumbnailer >= 2.40.0-lp152.2.3.1
  • libgdk_pixbuf-2_0-0 >= 2.40.0-lp152.2.3.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.40.0-lp152.2.3.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.40.0-lp152.2.3.1
  • typelib-1_0-GdkPixdata-2_0 >= 2.40.0-lp152.2.3.1
Patchnames:
openSUSE-2021-150
openSUSE Tumbleweed
  • gdk-pixbuf-devel >= 2.42.6-3.2
  • gdk-pixbuf-devel-32bit >= 2.42.6-3.2
  • gdk-pixbuf-lang >= 2.42.6-3.2
  • gdk-pixbuf-query-loaders >= 2.42.6-3.2
  • gdk-pixbuf-query-loaders-32bit >= 2.42.6-3.2
  • gdk-pixbuf-thumbnailer >= 2.42.6-3.2
  • libgdk_pixbuf-2_0-0 >= 2.42.6-3.2
  • libgdk_pixbuf-2_0-0-32bit >= 2.42.6-3.2
  • typelib-1_0-GdkPixbuf-2_0 >= 2.42.6-3.2
  • typelib-1_0-GdkPixdata-2_0 >= 2.42.6-3.2
Patchnames:
openSUSE Tumbleweed GA gdk-pixbuf-devel-2.42.6-3.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 gdk-pixbuf Not affected
SUSE Enterprise Storage 5 gdk-pixbuf Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 gdk-pixbuf Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS gdk-pixbuf Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 gdk-pixbuf Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 gdk-pixbuf Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 gdk-pixbuf Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 gdk-pixbuf Released
SUSE Linux Enterprise Point of Service Image Server 12 SP2 gdk-pixbuf Not affected
SUSE Linux Enterprise Server 12 SP2 ESPOS gdk-pixbuf Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS gdk-pixbuf Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS gdk-pixbuf Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS gdk-pixbuf Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS gdk-pixbuf Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS gdk-pixbuf Not affected
SUSE Linux Enterprise Server 12 SP5 gdk-pixbuf Not affected
SUSE Linux Enterprise Server 15 ESPOS gdk-pixbuf Not affected
SUSE Linux Enterprise Server 15 LTSS gdk-pixbuf Not affected
SUSE Linux Enterprise Server BCL 12 SP2 gdk-pixbuf Not affected
SUSE Linux Enterprise Server BCL 12 SP3 gdk-pixbuf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gdk-pixbuf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gdk-pixbuf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gdk-pixbuf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gdk-pixbuf Not affected
SUSE Linux Enterprise Server for SAP Applications 15 gdk-pixbuf Not affected
SUSE OpenStack Cloud 7 gdk-pixbuf Not affected
SUSE OpenStack Cloud 8 gdk-pixbuf Not affected
SUSE OpenStack Cloud 9 gdk-pixbuf Not affected
SUSE OpenStack Cloud Crowbar 8 gdk-pixbuf Not affected
SUSE OpenStack Cloud Crowbar 9 gdk-pixbuf Not affected