Upstream information

CVE-2020-29040 at MITRE

Description

An issue was discovered in Xen through 4.14.x allowing x86 HVM guest OS users to cause a denial of service (stack corruption), cause a data leak, or possibly gain privileges because of an off-by-one error. NOTE: this issue is caused by an incorrect fix for CVE-2020-27671.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 7.9
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Changed Changed
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1178963 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • xen-libs >= 4.14.1_16-1.6
  • xen-tools-domU >= 4.14.1_16-1.6
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • xen >= 4.14.1_16-1.6
  • xen-devel >= 4.14.1_16-1.6
  • xen-tools >= 4.14.1_16-1.6
  • xen-tools-xendomains-wait-disk >= 4.14.1_16-1.6
openSUSE Tumbleweed
  • xen >= 4.15.1_01-1.2
  • xen-devel >= 4.15.1_01-1.2
  • xen-doc-html >= 4.15.1_01-1.2
  • xen-libs >= 4.15.1_01-1.2
  • xen-libs-32bit >= 4.15.1_01-1.2
  • xen-tools >= 4.15.1_01-1.2
  • xen-tools-domU >= 4.15.1_01-1.2
  • xen-tools-xendomains-wait-disk >= 4.15.1_01-1.2
Patchnames:
openSUSE Tumbleweed GA xen-4.15.1_01-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 xen In progress
SUSE CaaS Platform 4.0 xen In progress
SUSE Enterprise Storage 5 xen Unsupported
SUSE Enterprise Storage 6 xen In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 xen Released
SUSE Linux Enterprise High Performance Computing 15 LTSS xen In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS xen In progress
SUSE Linux Enterprise Module for Basesystem 15 SP1 xen Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 xen Released
SUSE Linux Enterprise Module for Server Applications 15 SP1 xen Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 xen Released
SUSE Linux Enterprise Point of Service 11 SP3 xen Affected
SUSE Linux Enterprise Point of Service Image Server 12 xen Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS xen In progress
SUSE Linux Enterprise Server 12 SP2 BCL xen In progress
SUSE Linux Enterprise Server 12 SP2 ESPOS xen Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS xen Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON xen In progress
SUSE Linux Enterprise Server 12 SP2 LTSS SAP xen In progress
SUSE Linux Enterprise Server 12 SP3 BCL xen In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS xen In progress
SUSE Linux Enterprise Server 12 SP3 LTSS xen In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS xen In progress
SUSE Linux Enterprise Server 12 SP4 LTSS xen In progress
SUSE Linux Enterprise Server 12 SP5 xen Released
SUSE Linux Enterprise Server 15 LTSS xen In progress
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux xen In progress
SUSE Linux Enterprise Server 15 SP1 LTSS xen In progress
SUSE Linux Enterprise Server ESPOS 15 xen In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 xen Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 xen In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 xen In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 xen Released
SUSE Linux Enterprise Server for SAP Applications 15 xen In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 xen In progress
SUSE Manager Proxy 4.0 xen In progress
SUSE Manager Retail Branch Server 4.0 xen In progress
SUSE Manager Server 4.0 xen In progress
SUSE OpenStack Cloud 7 xen Unsupported
SUSE OpenStack Cloud 8 xen In progress
SUSE OpenStack Cloud 9 xen In progress
SUSE OpenStack Cloud Crowbar 8 xen In progress
SUSE OpenStack Cloud Crowbar 9 xen In progress