Upstream information

CVE-2020-27616 at MITRE

Description

ati_2d_blt in hw/display/ati_2d.c in QEMU 4.2.1 can encounter an outside-limits situation in a calculation. A guest can crash the QEMU process.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v3 Scores
  SUSE
Base Score 2.8
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:N/A:L
Access Vector Local
Access Complexity High
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entries: 1178400 [NEW], 1188609 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • qemu-tools >= 4.2.1-11.16.3
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1243
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • qemu-arm >= 4.2.1-11.16.3
  • qemu-audio-alsa >= 4.2.1-11.16.3
  • qemu-audio-pa >= 4.2.1-11.16.3
  • qemu-block-dmg >= 4.2.1-11.16.3
  • qemu-extra >= 4.2.1-11.16.3
  • qemu-linux-user >= 4.2.1-11.16.1
  • qemu-microvm >= 4.2.1-11.16.3
  • qemu-ppc >= 4.2.1-11.16.3
  • qemu-s390 >= 4.2.1-11.16.3
  • qemu-seabios >= 1.12.1+-11.16.3
  • qemu-sgabios >= 8-11.16.3
  • qemu-testsuite >= 4.2.1-11.16.6
  • qemu-ui-curses >= 4.2.1-11.16.3
  • qemu-ui-gtk >= 4.2.1-11.16.3
  • qemu-vhost-user-gpu >= 4.2.1-11.16.3
  • qemu-x86 >= 4.2.1-11.16.3
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1243
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • qemu >= 4.2.1-11.16.3
  • qemu-arm >= 4.2.1-11.16.3
  • qemu-audio-alsa >= 4.2.1-11.16.3
  • qemu-audio-pa >= 4.2.1-11.16.3
  • qemu-block-curl >= 4.2.1-11.16.3
  • qemu-block-iscsi >= 4.2.1-11.16.3
  • qemu-block-rbd >= 4.2.1-11.16.3
  • qemu-block-ssh >= 4.2.1-11.16.3
  • qemu-guest-agent >= 4.2.1-11.16.3
  • qemu-ipxe >= 1.0.0+-11.16.3
  • qemu-kvm >= 4.2.1-11.16.3
  • qemu-lang >= 4.2.1-11.16.3
  • qemu-microvm >= 4.2.1-11.16.3
  • qemu-ppc >= 4.2.1-11.16.3
  • qemu-s390 >= 4.2.1-11.16.3
  • qemu-seabios >= 1.12.1+-11.16.3
  • qemu-sgabios >= 8-11.16.3
  • qemu-ui-curses >= 4.2.1-11.16.3
  • qemu-ui-gtk >= 4.2.1-11.16.3
  • qemu-ui-spice-app >= 4.2.1-11.16.3
  • qemu-vgabios >= 1.12.1+-11.16.3
  • qemu-x86 >= 4.2.1-11.16.3
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2021-1243
SUSE MicroOS 5.0
  • qemu >= 4.2.1-11.16.3
  • qemu-arm >= 4.2.1-11.16.3
  • qemu-ipxe >= 1.0.0+-11.16.3
  • qemu-seabios >= 1.12.1+-11.16.3
  • qemu-sgabios >= 8-11.16.3
  • qemu-tools >= 4.2.1-11.16.3
  • qemu-vgabios >= 1.12.1+-11.16.3
  • qemu-x86 >= 4.2.1-11.16.3
Patchnames:
SUSE-SUSE-MicroOS-5.0-2021-1243
openSUSE Leap 15.2
  • qemu >= 4.2.1-lp152.9.12.1
  • qemu-arm >= 4.2.1-lp152.9.12.1
  • qemu-audio-alsa >= 4.2.1-lp152.9.12.1
  • qemu-audio-pa >= 4.2.1-lp152.9.12.1
  • qemu-audio-sdl >= 4.2.1-lp152.9.12.1
  • qemu-block-curl >= 4.2.1-lp152.9.12.1
  • qemu-block-dmg >= 4.2.1-lp152.9.12.1
  • qemu-block-gluster >= 4.2.1-lp152.9.12.1
  • qemu-block-iscsi >= 4.2.1-lp152.9.12.1
  • qemu-block-nfs >= 4.2.1-lp152.9.12.1
  • qemu-block-rbd >= 4.2.1-lp152.9.12.1
  • qemu-block-ssh >= 4.2.1-lp152.9.12.1
  • qemu-extra >= 4.2.1-lp152.9.12.1
  • qemu-guest-agent >= 4.2.1-lp152.9.12.1
  • qemu-ipxe >= 1.0.0+-lp152.9.12.1
  • qemu-ksm >= 4.2.1-lp152.9.12.1
  • qemu-kvm >= 4.2.1-lp152.9.12.1
  • qemu-lang >= 4.2.1-lp152.9.12.1
  • qemu-linux-user >= 4.2.1-lp152.9.12.1
  • qemu-microvm >= 4.2.1-lp152.9.12.1
  • qemu-ppc >= 4.2.1-lp152.9.12.1
  • qemu-s390 >= 4.2.1-lp152.9.12.1
  • qemu-seabios >= 1.12.1+-lp152.9.12.1
  • qemu-sgabios >= 8-lp152.9.12.1
  • qemu-testsuite >= 4.2.1-lp152.9.12.1
  • qemu-tools >= 4.2.1-lp152.9.12.1
  • qemu-ui-curses >= 4.2.1-lp152.9.12.1
  • qemu-ui-gtk >= 4.2.1-lp152.9.12.1
  • qemu-ui-sdl >= 4.2.1-lp152.9.12.1
  • qemu-ui-spice-app >= 4.2.1-lp152.9.12.1
  • qemu-vgabios >= 1.12.1+-lp152.9.12.1
  • qemu-vhost-user-gpu >= 4.2.1-lp152.9.12.1
  • qemu-x86 >= 4.2.1-lp152.9.12.1
Patchnames:
openSUSE-2021-600


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLE-HPC (12) qemu Not affected
SLES (12) qemu Not affected
SLES-BCL (12) qemu Not affected
SLES-ESPOS (12) qemu Not affected
SLES-LTSS (12) qemu Not affected
SLES-LTSS (15) qemu Not affected
SLES_SAP (12) qemu Not affected
SLES_SAP (15) qemu Not affected
SLE_HPC-ESPOS (15) qemu Not affected
SLE_HPC-LTSS (15) qemu Not affected
SUSE_SLES_LTSS (11) kvm Not affected
hpe-helion-openstack (8) qemu Not affected
ses (5) qemu Unsupported
sle-module-basesystem (15) qemu Released
sle-module-server-applications (15) qemu Released
sle-pos (11) kvm Not affected
sle-pos (11) qemu Not affected
sle-pos (12) qemu Unsupported
suse-openstack-cloud (7) qemu Not affected
suse-openstack-cloud (8) qemu Not affected
suse-openstack-cloud (9) qemu Not affected
suse-openstack-cloud-crowbar (8) qemu Not affected
suse-openstack-cloud-crowbar (9) qemu Not affected