Upstream information

CVE-2020-25125 at MITRE

Description

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error. NOTE: GnuPG 2.3.x is unaffected. GnuPG 2.2.23 is a fixed version.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1176034 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • dirmngr >= 2.2.27-1.2
  • gpg2 >= 2.2.27-1.2
  • gpg2-lang >= 2.2.27-1.2
openSUSE Tumbleweed
  • dirmngr >= 2.2.27-2.4
  • gpg2 >= 2.2.27-2.4
  • gpg2-lang >= 2.2.27-2.4
Patchnames:
openSUSE Tumbleweed GA dirmngr-2.2.27-2.4


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 3.0 gpg2 Not affected
SUSE Container as a Service Platform 1.0 gpg2 Not affected
SUSE Container as a Service Platform 2.0 gpg2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 gpg2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 gpg2 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS gpg2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 gpg2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 gpg2 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS gpg2 Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS gpg2 Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS gpg2 Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS gpg2 Not affected
SUSE Linux Enterprise Server 12 SP5 gpg2 Not affected
SUSE Linux Enterprise Server 15 ESPOS gpg2 Not affected
SUSE Linux Enterprise Server 15 LTSS gpg2 Not affected
SUSE Linux Enterprise Server BCL 12 SP2 gpg2 Not affected
SUSE Linux Enterprise Server BCL 12 SP3 gpg2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gpg2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gpg2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gpg2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gpg2 Not affected