Upstream information

CVE-2020-24994 at MITRE

Description

Stack overflow in the parse_tag function in libass/ass_parse.c in libass before 0.15.0 allows remote attackers to cause a denial of service or remote code execution via a crafted file.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1184153 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • libass-devel >= 0.14.0-3.6.1
  • libass9 >= 0.14.0-3.6.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-1664
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • libass-devel >= 0.14.0-3.6.1
  • libass9 >= 0.14.0-3.6.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-1664
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • libass9-32bit >= 0.14.0-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1664
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • libass9-32bit >= 0.14.0-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-1664
openSUSE Leap 15.2
  • libass-devel >= 0.14.0-lp152.4.6.1
  • libass9 >= 0.14.0-lp152.4.6.1
  • libass9-32bit >= 0.14.0-lp152.4.6.1
Patchnames:
openSUSE-2021-773
openSUSE Leap 15.3
  • libass-devel >= 0.14.0-3.6.1
  • libass9 >= 0.14.0-3.6.1
  • libass9-32bit >= 0.14.0-3.6.1
Patchnames:
openSUSE-SLE-15.3-2021-1664


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libass Affected
SUSE CaaS Platform 4.0 libass In progress
SUSE Enterprise Storage 6 libass In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 libass Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS libass In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS libass In progress
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 libass Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 libass Released
SUSE Linux Enterprise Point of Service Image Server 12 libass Unsupported
SUSE Linux Enterprise Server 12 SP2 BCL libass Affected
SUSE Linux Enterprise Server 12 SP2 ESPOS libass Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS libass Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON libass Affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP libass Affected
SUSE Linux Enterprise Server 12 SP3 BCL libass Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS libass Affected
SUSE Linux Enterprise Server 12 SP3 LTSS libass Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS libass Affected
SUSE Linux Enterprise Server 12 SP4 LTSS libass Affected
SUSE Linux Enterprise Server 12 SP5 libass Affected
SUSE Linux Enterprise Server 15 LTSS libass In progress
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux libass In progress
SUSE Linux Enterprise Server 15 SP1 LTSS libass In progress
SUSE Linux Enterprise Server ESPOS 15 libass In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libass Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libass Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libass Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libass Affected
SUSE Linux Enterprise Server for SAP Applications 15 libass In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libass In progress
SUSE Manager Proxy 4.0 libass In progress
SUSE Manager Retail Branch Server 4.0 libass In progress
SUSE Manager Server 4.0 libass In progress
SUSE OpenStack Cloud 7 libass Unsupported
SUSE OpenStack Cloud 8 libass Affected
SUSE OpenStack Cloud 9 libass Affected
SUSE OpenStack Cloud Crowbar 8 libass Affected
SUSE OpenStack Cloud Crowbar 9 libass Affected