Upstream information

CVE-2020-24455 at MITRE

Description

Missing initialization of a variable in the TPM2 source may allow a privileged user to potentially enable an escalation of privilege via local access. This affects tpm2-tss before 3.0.1 and before 2.4.3.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.7 4.1
Vector CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H
Access Vector Local Local
Access Complexity Low High
Privileges Required High High
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1184895 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libtss2-esys0 >= 2.4.5-1.11
  • libtss2-fapi0 >= 2.4.5-1.11
  • libtss2-mu0 >= 2.4.5-1.11
  • libtss2-rc0 >= 2.4.5-1.11
  • libtss2-sys0 >= 2.4.5-1.11
  • libtss2-tcti-device0 >= 2.4.5-1.11
  • libtss2-tcti-mssim0 >= 2.4.5-1.11
  • libtss2-tctildr0 >= 2.4.5-1.11
  • tpm2-0-tss >= 2.4.5-1.11
  • tpm2-0-tss-devel >= 2.4.5-1.11


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 tpm2-0-tss Not affected
SUSE CaaS Platform 4.0 tpm2-0-tss Not affected
SUSE Enterprise Storage 6 tpm2-0-tss Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 tpm2-0-tss Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS tpm2-0-tss Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS tpm2-0-tss Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 tpm2-0-tss Not affected
SUSE Linux Enterprise Server 12 SP2 BCL tpm2-0-tss Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON tpm2-0-tss Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS SAP tpm2-0-tss Not affected
SUSE Linux Enterprise Server 12 SP3 BCL tpm2-0-tss Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS tpm2-0-tss Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS tpm2-0-tss Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS tpm2-0-tss Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS tpm2-0-tss Not affected
SUSE Linux Enterprise Server 12 SP5 tpm2-0-tss Not affected
SUSE Linux Enterprise Server 15 LTSS tpm2-0-tss Not affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux tpm2-0-tss Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS tpm2-0-tss Not affected
SUSE Linux Enterprise Server ESPOS 15 tpm2-0-tss Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 tpm2-0-tss Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 tpm2-0-tss Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 tpm2-0-tss Not affected
SUSE Linux Enterprise Server for SAP Applications 15 tpm2-0-tss Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 tpm2-0-tss Not affected
SUSE Manager Proxy 4.0 tpm2-0-tss Not affected
SUSE Manager Retail Branch Server 4.0 tpm2-0-tss Not affected
SUSE Manager Server 4.0 tpm2-0-tss Not affected
SUSE OpenStack Cloud 8 tpm2-0-tss Not affected
SUSE OpenStack Cloud 9 tpm2-0-tss Not affected
SUSE OpenStack Cloud Crowbar 8 tpm2-0-tss Not affected
SUSE OpenStack Cloud Crowbar 9 tpm2-0-tss Not affected