Upstream information

CVE-2020-19609 at MITRE

Description

Artifex MuPDF before 1.18.0 has a heap based buffer over-write in tiff_expand_colormap() function when parsing TIFF files allowing attackers to cause a denial of service.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

SUSE Bugzilla entry: 1190176 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 15 SP1
  • mupdf >= 1.12.0-bp151.4.3.1
  • mupdf-devel-static >= 1.12.0-bp151.4.3.1
Patchnames:
openSUSE-2021-1341
SUSE Package Hub for SUSE Linux Enterprise 15 SP2
  • mupdf >= 1.12.0-bp152.4.3.1
  • mupdf-devel-static >= 1.12.0-bp152.4.3.1
Patchnames:
openSUSE-2021-1341
SUSE Package Hub for SUSE Linux Enterprise 15 SP3
  • mupdf >= 1.12.0-bp153.2.3.1
  • mupdf-devel-static >= 1.12.0-bp153.2.3.1
Patchnames:
openSUSE-2021-1341
openSUSE Leap 15.2
  • mupdf >= 1.12.0-lp152.6.3.1
  • mupdf-devel-static >= 1.12.0-lp152.6.3.1
Patchnames:
openSUSE-2021-1341
openSUSE Leap 15.3
  • mupdf >= 1.12.0-bp153.2.3.1
  • mupdf-devel-static >= 1.12.0-bp153.2.3.1
Patchnames:
openSUSE-2021-1341