Upstream information

CVE-2020-16156 at MITRE

Description

CPAN 2.28 allows Signature Verification Bypass.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 8.1
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Access Vector Local Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1193771 [RESOLVED / WONTFIX]

SUSE Security Advisories:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 perl Affected
SLES15-EC2-CHOST-HVM-BYOS perl Won't fix
SLES15-SP1-CHOST-BYOS-Azure perl Won't fix
SLES15-SP1-CHOST-BYOS-EC2 perl Won't fix
SLES15-SP1-CHOST-BYOS-GCE perl Won't fix
SLES15-SP2-CHOST-BYOS-Aliyun perl Won't fix
SLES15-SP2-CHOST-BYOS-Azure perl Won't fix
SLES15-SP2-CHOST-BYOS-EC2 perl Won't fix
SLES15-SP2-CHOST-BYOS-GCE perl Won't fix
SLES15-SP3-CHOST-BYOS-Aliyun perl Won't fix
SLES15-SP3-CHOST-BYOS-Azure perl Won't fix
SLES15-SP3-CHOST-BYOS-EC2 perl Won't fix
SLES15-SP3-CHOST-BYOS-GCE perl Won't fix
SLES15-SP4-CHOST-BYOS perl Won't fix
SLES15-SP4-CHOST-BYOS-Aliyun perl Won't fix
SLES15-SP4-CHOST-BYOS-Azure perl Won't fix
SLES15-SP4-CHOST-BYOS-EC2 perl Won't fix
SLES15-SP4-CHOST-BYOS-GCE perl Won't fix
SUSE CaaS Platform 4.0 perl Won't fix
SUSE CaaS Platform 4.5 perl Affected
SUSE Enterprise Storage 6 perl Won't fix
SUSE Enterprise Storage 7 perl Won't fix
SUSE Linux Enterprise Desktop 15 SP2 perl Affected
SUSE Linux Enterprise Desktop 15 SP3 perl Won't fix
SUSE Linux Enterprise Desktop 15 SP4 perl Won't fix
SUSE Linux Enterprise High Performance Computing 12 SP5 perl Won't fix
SUSE Linux Enterprise High Performance Computing 15 LTSS perl Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS perl Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS perl Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP2 perl Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS perl Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS perl Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP3 perl Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP4 perl Won't fix
SUSE Linux Enterprise Micro 5.0 perl Affected
SUSE Linux Enterprise Micro 5.1 perl Won't fix
SUSE Linux Enterprise Micro 5.2 perl Won't fix
SUSE Linux Enterprise Module for Basesystem 15 SP2 perl Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 perl Won't fix
SUSE Linux Enterprise Module for Basesystem 15 SP4 perl Won't fix
SUSE Linux Enterprise Module for Development Tools 15 SP2 perl Affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 perl Won't fix
SUSE Linux Enterprise Module for Development Tools 15 SP4 perl Won't fix
SUSE Linux Enterprise Real Time 15 SP2 perl Affected
SUSE Linux Enterprise Server 11 SP1 perl Unsupported
SUSE Linux Enterprise Server 11 SP3 perl Not affected
SUSE Linux Enterprise Server 12 SP2 BCL perl Won't fix
SUSE Linux Enterprise Server 12 SP3 BCL perl Won't fix
SUSE Linux Enterprise Server 12 SP3 ESPOS perl Affected
SUSE Linux Enterprise Server 12 SP3 LTSS perl Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS perl Won't fix
SUSE Linux Enterprise Server 12 SP4 LTSS perl Won't fix
SUSE Linux Enterprise Server 12 SP5 perl Won't fix
SUSE Linux Enterprise Server 15 ESPOS perl Won't fix
SUSE Linux Enterprise Server 15 LTSS perl Won't fix
SUSE Linux Enterprise Server 15 SP1 LTSS perl Won't fix
SUSE Linux Enterprise Server 15 SP2 perl Affected
SUSE Linux Enterprise Server 15 SP2 LTSS perl Won't fix
SUSE Linux Enterprise Server 15 SP3 perl Won't fix
SUSE Linux Enterprise Server 15 SP4 perl Won't fix
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 perl Won't fix
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 perl Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP3 perl Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 perl Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP5 perl Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 perl Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP1 perl Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP2 perl Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 perl Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP4 perl Won't fix
SUSE Linux Enterprise Storage 7 perl Affected
SUSE Linux Enterprise Storage 7.1 perl Won't fix
SUSE Manager Proxy 4.1 perl Affected
SUSE Manager Proxy 4.2 perl Won't fix
SUSE Manager Proxy 4.3 perl Won't fix
SUSE Manager Retail Branch Server 4.1 perl Affected
SUSE Manager Retail Branch Server 4.2 perl Won't fix
SUSE Manager Retail Branch Server 4.3 perl Won't fix
SUSE Manager Server 4.1 perl Affected
SUSE Manager Server 4.2 perl Won't fix
SUSE Manager Server 4.3 perl Won't fix
SUSE OpenStack Cloud 8 perl Affected
SUSE OpenStack Cloud 9 perl Won't fix
SUSE OpenStack Cloud Crowbar 8 perl Affected
SUSE OpenStack Cloud Crowbar 9 perl Won't fix
SUSE Package Hub 15 SP4 perl Won't fix
bci/dotnet-aspnet:5.0
bci/dotnet-runtime:5.0
bci/dotnet-sdk:5.0
ses/7.1/ceph/haproxy
ses/7.1/ceph/keepalived
suse/pcp
suse/rmt-mariadb
suse/rmt-mariadb:10.6
suse/rmt-nginx
suse/rmt-nginx:1.21
suse/sle-micro/5.0/toolbox
suse/sle-micro/5.1/toolbox
suse/sle-micro/5.2/toolbox
suse/sle-micro/5.3/toolbox
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.3/libguestfs-tools:0.45.0
suse/sles/15.3/virt-launcher:0.45.0
suse/sles/15.4/libguestfs-tools:0.49.0
suse/sles/15.4/virt-launcher:0.49.0
perlWon't fix