Upstream information

CVE-2020-15900 at MITRE

Description

A memory corruption issue was found in Artifex Ghostscript 9.50 and 9.52. Use of a non-standard PostScript operator can allow overriding of file access controls. The 'rsearch' calculation for the 'post' size resulted in a size that was too large, and could underflow to max uint32_t. This was fixed in commit 5d499272b95a6b890a1397e11d20937de000d31b.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1174415 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
HPE-Helion-OpenStack-8-2020-2097
SUSE Enterprise Storage 5
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-Storage-5-2020-2097
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • ghostscript >= 9.52-3.32.1
  • ghostscript-devel >= 9.52-3.32.1
  • ghostscript-x11 >= 9.52-3.32.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-2095
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • ghostscript >= 9.52-3.32.1
  • ghostscript-devel >= 9.52-3.32.1
  • ghostscript-x11 >= 9.52-3.32.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-2095
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • ghostscript >= 9.52-3.32.1
  • ghostscript-devel >= 9.52-3.32.1
  • ghostscript-x11 >= 9.52-3.32.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2020-2095
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ghostscript-mini >= 9.52-3.32.1
  • ghostscript-mini-devel >= 9.52-3.32.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-2095
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • ghostscript-mini >= 9.52-3.32.1
  • ghostscript-mini-devel >= 9.52-3.32.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-2095
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-2097
SUSE Linux Enterprise Server 12 SP2-BCL
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-2097
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-2097
SUSE Linux Enterprise Server 12 SP2-LTSS
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-2097
SUSE Linux Enterprise Server 12 SP3-BCL
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-2097
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-2097
SUSE Linux Enterprise Server 12 SP3-LTSS
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-2097
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2020-2097
SUSE Linux Enterprise Server 12 SP4-LTSS
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2020-2097
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-2097
SUSE Linux Enterprise Server 15-LTSS
  • ghostscript >= 9.52-3.32.1
  • ghostscript-devel >= 9.52-3.32.1
  • ghostscript-x11 >= 9.52-3.32.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-2095
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-2097
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-2097
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2020-2097
SUSE Linux Enterprise Server for SAP Applications 15
  • ghostscript >= 9.52-3.32.1
  • ghostscript-devel >= 9.52-3.32.1
  • ghostscript-x11 >= 9.52-3.32.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-2095
SUSE Linux Enterprise Software Development Kit 12 SP5
  • ghostscript-devel >= 9.52-23.39.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-2097
SUSE OpenStack Cloud 7
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-2097
SUSE OpenStack Cloud 8
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-2097
SUSE OpenStack Cloud 9
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-OpenStack-Cloud-9-2020-2097
SUSE OpenStack Cloud Crowbar 8
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-2097
SUSE OpenStack Cloud Crowbar 9
  • ghostscript >= 9.52-23.39.1
  • ghostscript-x11 >= 9.52-23.39.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2020-2097
openSUSE Leap 15.1
  • ghostscript >= 9.52-lp151.3.15.1
  • ghostscript-debuginfo >= 9.52-lp151.3.15.1
  • ghostscript-debugsource >= 9.52-lp151.3.15.1
  • ghostscript-devel >= 9.52-lp151.3.15.1
  • ghostscript-mini >= 9.52-lp151.3.15.1
  • ghostscript-mini-debuginfo >= 9.52-lp151.3.15.1
  • ghostscript-mini-debugsource >= 9.52-lp151.3.15.1
  • ghostscript-mini-devel >= 9.52-lp151.3.15.1
  • ghostscript-x11 >= 9.52-lp151.3.15.1
  • ghostscript-x11-debuginfo >= 9.52-lp151.3.15.1
Patchnames:
openSUSE-2020-1142
openSUSE Leap 15.2
  • ghostscript >= 9.52-lp152.2.4.1
  • ghostscript-debuginfo >= 9.52-lp152.2.4.1
  • ghostscript-debugsource >= 9.52-lp152.2.4.1
  • ghostscript-devel >= 9.52-lp152.2.4.1
  • ghostscript-mini >= 9.52-lp152.2.4.1
  • ghostscript-mini-debuginfo >= 9.52-lp152.2.4.1
  • ghostscript-mini-debugsource >= 9.52-lp152.2.4.1
  • ghostscript-mini-devel >= 9.52-lp152.2.4.1
  • ghostscript-x11 >= 9.52-lp152.2.4.1
  • ghostscript-x11-debuginfo >= 9.52-lp152.2.4.1
Patchnames:
openSUSE-2020-1146


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 ghostscript-library Unsupported
SLED-10-SP4 ghostscript-library Unsupported
SLES for SAP Applications ghostscript-library Not affected
SLES-10-SP3 ghostscript-library Unsupported
SLES-10-SP4 ghostscript-library Unsupported
SLES_LTSS-10-SP4 ghostscript-library Unsupported
SUSE CaaS Platform 4.0 ghostscript Released
SUSE Enterprise Storage 6 ghostscript Released
SUSE Linux Enterprise Desktop 11 ghostscript-library Unsupported
SUSE Linux Enterprise Desktop 11 SP1 ghostscript-library Not affected
SUSE Linux Enterprise Desktop 11 SP2 ghostscript-library Not affected
SUSE Linux Enterprise Desktop 11 SP3 ghostscript-library Not affected
SUSE Linux Enterprise Desktop 11 SP4 ghostscript-library Not affected
SUSE Linux Enterprise Desktop 12 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP1 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP2 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP3 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP4 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP5 ghostscript Affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search ghostscript-library Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 ghostscript Affected
SUSE Linux Enterprise High Performance Computing 12 SP3 ghostscript Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 ghostscript Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 ghostscript Released
SUSE Linux Enterprise High Performance Computing 15 LTSS ghostscript Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 ghostscript Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 ghostscript Released
SUSE Linux Enterprise Server 11 ghostscript-library Unsupported
SUSE Linux Enterprise Server 11 SP1 ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP1 LTSS ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP2 ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP2 for VMware ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP3 ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP3 for VMware ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS ghostscript-library Not affected
SUSE Linux Enterprise Server 12 ghostscript Affected
SUSE Linux Enterprise Server 12 LTSS ghostscript Affected
SUSE Linux Enterprise Server 12 SP1 ghostscript Affected
SUSE Linux Enterprise Server 12 SP1 LTSS ghostscript Affected
SUSE Linux Enterprise Server 12 SP2 ghostscript Affected
SUSE Linux Enterprise Server 12 SP2 BCL ghostscript Released
SUSE Linux Enterprise Server 12 SP2 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP3 ghostscript Affected
SUSE Linux Enterprise Server 12 SP3 BCL ghostscript Released
SUSE Linux Enterprise Server 12 SP3 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP4 ghostscript Affected
SUSE Linux Enterprise Server 12 SP4 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP5 ghostscript Released
SUSE Linux Enterprise Server 15 LTSS ghostscript Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux ghostscript Released
SUSE Linux Enterprise Server 15 SP1 LTSS ghostscript Released
SUSE Linux Enterprise Server ESPOS 15 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 ghostscript Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 15 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ghostscript Released
SUSE Linux Enterprise Server for SAP Business All-in-One ghostscript-library Not affected
SUSE Linux Enterprise Server for the Raspberry Pi ghostscript Affected
SUSE Linux Enterprise Software Development Kit 11 ghostscript-library Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP1 ghostscript-library Not affected
SUSE Linux Enterprise Software Development Kit 11 SP2 ghostscript-library Not affected
SUSE Linux Enterprise Software Development Kit 11 SP3 ghostscript-library Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 ghostscript-library Not affected
SUSE Linux Enterprise Software Development Kit 12 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 ghostscript Released
SUSE Manager Proxy 4.0 ghostscript Released
SUSE Manager Retail Branch Server 4.0 ghostscript Released
SUSE Manager Server 4.0 ghostscript Released