Upstream information

CVE-2020-15705 at MITRE

Description

GRUB2 fails to validate kernel signature when booted directly without shim, allowing secure boot to be bypassed. This only affects systems where the kernel signing certificate has been imported directly into the secure boot database and the GRUB image is booted directly without the use of shim. This issue affects GRUB2 version 2.04 and prior versions.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.4 7.8
Vector CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity High Low
Privileges Required High Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1174421 [NEW]

SUSE Security Advisories:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 grub2 Affected
CaaS Platform 2.0 grub2 Affected
CaaS Platform 3.0 grub2 Affected
SUSE Business Critical Linux 12 SP2 grub2 Affected
SUSE Business Critical Linux 12 SP3 grub2 Affected
SUSE Linux Enterprise High Performance Computing 12 grub2 Affected
SUSE Linux Enterprise High Performance Computing ESPOS 15 GA grub2 Affected
SUSE Linux Enterprise High Performance Computing LTSS 15 GA grub2 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 grub2 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 grub2 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 grub2 Affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 grub2 Affected
SUSE Linux Enterprise Server 11 SP4 LTSS grub2 Affected
SUSE Linux Enterprise Server 12 SP2 LTSS grub2 Affected
SUSE Linux Enterprise Server 12 SP3 LTSS grub2 Affected
SUSE Linux Enterprise Server 12 SP4 grub2 Affected
SUSE Linux Enterprise Server 12 SP4 LTSS grub2 Affected
SUSE Linux Enterprise Server 12 SP5 grub2 Affected
SUSE Linux Enterprise Server 15 GA LTSS grub2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 grub2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 grub2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 grub2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 grub2 Affected