Upstream information

CVE-2020-14370 at MITRE

Description

An information disclosure vulnerability was found in containers/podman in versions before 2.0.5. When using the deprecated Varlink API or the Docker-compatible REST API, if multiple containers are created in a short duration, the environment variables from the first container will get leaked into subsequent containers. An attacker who has control over the subsequent containers could use this flaw to gain access to sensitive information stored in such variables.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 6.5
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1176804 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 7
  • podman >= 2.1.1-4.28.1
Patchnames:
SUSE-Storage-7-2020-3378
SUSE Linux Enterprise Module for Containers 15 SP1
  • podman >= 2.1.1-4.28.1
  • podman-cni-config >= 2.1.1-4.28.1
Patchnames:
SUSE-SLE-Module-Containers-15-SP1-2020-3378
SUSE Linux Enterprise Module for Containers 15 SP2
  • podman >= 2.1.1-4.28.1
  • podman-cni-config >= 2.1.1-4.28.1
Patchnames:
SUSE-SLE-Module-Containers-15-SP2-2020-3378
SUSE Linux Enterprise Module for Containers 15 SP3
  • podman >= 2.1.1-4.28.1
  • podman-cni-config >= 2.1.1-4.28.1
openSUSE Leap 15.1
  • podman >= 2.1.1-lp151.3.25.1
  • podman-cni-config >= 2.1.1-lp151.3.25.1
Patchnames:
openSUSE-2020-2039
openSUSE Leap 15.2
  • podman >= 2.1.1-lp152.4.6.1
  • podman-cni-config >= 2.1.1-lp152.4.6.1
Patchnames:
openSUSE-2020-2063
openSUSE Tumbleweed
  • podman >= 3.3.1-2.1
  • podman-cni-config >= 3.3.1-2.1
  • podman-docker >= 3.3.1-2.1
  • podman-remote >= 3.3.1-2.1
Patchnames:
openSUSE Tumbleweed GA podman-3.3.1-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 podman In progress
SUSE Enterprise Storage 6 podman In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS podman In progress
SUSE Linux Enterprise Module for Containers 15 SP1 podman Released
SUSE Linux Enterprise Module for Containers 15 SP2 podman Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux podman In progress
SUSE Linux Enterprise Server 15 SP1 LTSS podman In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 podman In progress
SUSE Manager Proxy 4.0 podman In progress
SUSE Manager Retail Branch Server 4.0 podman In progress
SUSE Manager Server 4.0 podman In progress