Upstream information

CVE-2020-12762 at MITRE

Description

json-c through 0.14 has an integer overflow and out-of-bounds write via a large JSON file, as demonstrated by printbuf_memappend.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1171479 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
SUSE CaaS Platform 4.0
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Enterprise Storage 6
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Enterprise Storage 7
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise Server 15 SP1-BCL
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise Server 15 SP1-LTSS
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise Server 15 SP2-BCL
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise Server 15 SP2-LTSS
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise Server 15-LTSS
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise Server for SAP Applications 15
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Manager Proxy 4.1
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Manager Retail Branch Server 4.1
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE Manager Server 4.1
  • libjson-c-devel >= 0.13-3.3.1
  • libjson-c3 >= 0.13-3.3.1
  • libjson-c3-32bit >= 0.13-3.3.1
SUSE MicroOS 5.0
  • libjson-c3 >= 0.13-3.3.1
SUSE MicroOS 5.1
  • libjson-c3 >= 0.13-3.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Public Cloud Module for SUSE Linux Enterprise 11 json-c Affected
SUSE CaaS Platform 3.0 json-c Affected
SUSE CaaS Platform 4.0 json-c In progress
SUSE CaaS Platform 4.5 json-c Affected
SUSE Container as a Service Platform 1.0 json-c Affected
SUSE Container as a Service Platform 2.0 json-c Affected
SUSE Enterprise Storage 6 json-c In progress
SUSE Enterprise Storage 7 json-c In progress
SUSE Linux Enterprise High Performance Computing 12 SP4 json-c Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 json-c Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS json-c In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS json-c In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS json-c In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS json-c In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS json-c In progress
SUSE Linux Enterprise Micro 5.0 json-c In progress
SUSE Linux Enterprise Micro 5.1 json-c In progress
SUSE Linux Enterprise Module for Basesystem 15 SP1 json-c Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 json-c In progress
SUSE Linux Enterprise Module for Basesystem 15 SP3 json-c In progress
SUSE Linux Enterprise Module for Basesystem 15 SP4 json-c In progress
SUSE Linux Enterprise Server 12 SP1 LTSS json-c Unsupported
SUSE Linux Enterprise Server 12 SP2 BCL json-c Affected
SUSE Linux Enterprise Server 12 SP2 LTSS json-c Unsupported
SUSE Linux Enterprise Server 12 SP3 BCL json-c Affected
SUSE Linux Enterprise Server 12 SP3 LTSS json-c Affected
SUSE Linux Enterprise Server 12 SP4 json-c Affected
SUSE Linux Enterprise Server 12 SP4 LTSS json-c Affected
SUSE Linux Enterprise Server 12 SP5 json-c Affected
SUSE Linux Enterprise Server 15 ESPOS json-c In progress
SUSE Linux Enterprise Server 15 LTSS json-c In progress
SUSE Linux Enterprise Server 15 SP1 LTSS json-c In progress
SUSE Linux Enterprise Server 15 SP2 LTSS json-c In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 json-c In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 json-c In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 json-c Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 json-c Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 json-c Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 json-c Affected
SUSE Linux Enterprise Server for SAP Applications 15 json-c In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 json-c In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP2 json-c In progress
SUSE Linux Enterprise Software Development Kit 12 SP4 json-c Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 json-c Affected
SUSE Manager Proxy 4.1 json-c In progress
SUSE Manager Retail Branch Server 4.1 json-c In progress
SUSE Manager Server 4.1 json-c In progress