Upstream information

CVE-2020-12695 at MITRE

Description

The Open Connectivity Foundation UPnP specification before 2020-04-17 does not forbid the acceptance of a subscription request with a delivery URL on a different network segment than the fully qualified event-subscription URL, aka the CallStranger issue.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:M/Au:N/C:P/I:N/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact Low
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entries: 1172700 [RESOLVED / FIXED], 1179447 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • libgupnp-1_2-1 >= 1.4.3-150400.1.6
  • typelib-1_0-GUPnP-1_0 >= 1.4.3-150400.1.6
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libgupnp-1_2-1-1.4.3-150400.1.6
SUSE Linux Enterprise Workstation Extension 15 SP4 GA typelib-1_0-GUPnP-1_0-1.4.3-150400.1.6
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libgupnp-1_2-1 >= 1.4.3-150400.1.6
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libgupnp-1_2-1-1.4.3-150400.1.6
SUSE Linux Enterprise Workstation Extension 15 SP4
  • typelib-1_0-GUPnP-1_0 >= 1.4.3-150400.1.6
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP4 GA typelib-1_0-GUPnP-1_0-1.4.3-150400.1.6
SUSE Package Hub 15 SP1
  • minidlna >= 1.3.0-bp151.2.3.1
Patchnames:
openSUSE-2020-2226
SUSE Package Hub 15 SP2
  • hostapd >= 2.9-bp152.2.3.1
  • minidlna >= 1.3.0-bp152.4.3.1
Patchnames:
openSUSE-2020-2204
openSUSE-2021-545
openSUSE Leap 15.1
  • minidlna >= 1.3.0-lp151.3.3.1
Patchnames:
openSUSE-2020-2194
openSUSE Leap 15.2
  • hostapd >= 2.9-lp152.2.3.1
  • minidlna >= 1.3.0-lp152.4.3.1
Patchnames:
openSUSE-2020-2160
openSUSE-2021-519
openSUSE Leap 15.4
  • libgupnp-1_2-1 >= 1.4.3-150400.1.6
Patchnames:
openSUSE Leap 15.4 GA libgupnp-1_2-1-1.4.3-150400.1.6
openSUSE Tumbleweed
  • hostapd >= 2.9-6.2
  • libgupnp-1_2-0 >= 1.2.7-2.2
  • libgupnp-1_2-0-32bit >= 1.2.7-2.2
  • libgupnp-devel >= 1.2.7-2.2
  • minidlna >= 1.3.0-2.7
  • typelib-1_0-GUPnP-1_0 >= 1.2.7-2.2
Patchnames:
openSUSE Tumbleweed GA hostapd-2.9-6.2
openSUSE Tumbleweed GA libgupnp-1_2-0-1.2.7-2.2
openSUSE Tumbleweed GA minidlna-1.3.0-2.7