Upstream information

CVE-2020-11988 at MITRE

Description

Apache XmlGraphics Commons 2.4 and earlier is vulnerable to server-side request forgery, caused by improper input validation by the XMPParser. By using a specially-crafted argument, an attacker could exploit this vulnerability to cause the underlying server to make arbitrary GET requests. Users should upgrade to 2.6 or later.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.2 5.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact High Low
Integrity Impact Low None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1182754 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.5 xmlgraphics-commons Affected
SUSE Enterprise Storage 7 xmlgraphics-commons Affected
SUSE Linux Enterprise Desktop 15 SP2 xmlgraphics-commons Affected
SUSE Linux Enterprise Desktop 15 SP3 xmlgraphics-commons Affected
SUSE Linux Enterprise Desktop 15 SP4 xmlgraphics-commons Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 xmlgraphics-commons Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS xmlgraphics-commons Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS xmlgraphics-commons Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 xmlgraphics-commons Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 xmlgraphics-commons Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 xmlgraphics-commons Affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 xmlgraphics-commons Affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 xmlgraphics-commons Affected
SUSE Linux Enterprise Real Time 15 SP2 xmlgraphics-commons Affected
SUSE Linux Enterprise Server 15 SP2 xmlgraphics-commons Affected
SUSE Linux Enterprise Server 15 SP2 LTSS xmlgraphics-commons Affected
SUSE Linux Enterprise Server 15 SP3 xmlgraphics-commons Affected
SUSE Linux Enterprise Server 15 SP4 xmlgraphics-commons Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 xmlgraphics-commons Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 xmlgraphics-commons Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 xmlgraphics-commons Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 xmlgraphics-commons Affected
SUSE Linux Enterprise Storage 7 xmlgraphics-commons Affected
SUSE Linux Enterprise Storage 7.1 xmlgraphics-commons Affected
SUSE Manager Proxy 4.1 xmlgraphics-commons Affected
SUSE Manager Proxy 4.2 xmlgraphics-commons Affected
SUSE Manager Proxy 4.3 xmlgraphics-commons Affected
SUSE Manager Retail Branch Server 4.1 xmlgraphics-commons Affected
SUSE Manager Retail Branch Server 4.2 xmlgraphics-commons Affected
SUSE Manager Retail Branch Server 4.3 xmlgraphics-commons Affected
SUSE Manager Server 4.1 xmlgraphics-commons Affected
SUSE Manager Server 4.2 xmlgraphics-commons Affected
SUSE Manager Server 4.3 xmlgraphics-commons Affected