Upstream information

CVE-2020-11958 at MITRE

Description

re2c 1.3 has a heap-based buffer overflow in Scanner::fill in parse/scanner.cc via a long lexeme.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1170036 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 re2c Not affected
SUSE Enterprise Storage 7.1 re2c Not affected
SUSE Linux Enterprise Desktop 15 SP4 re2c Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 re2c Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 re2c Not affected
SUSE Linux Enterprise Real Time 15 SP3 re2c Not affected
SUSE Linux Enterprise Server 12 SP5 re2c Not affected
SUSE Linux Enterprise Server 12-LTSS re2c Not affected
SUSE Linux Enterprise Server 15 SP4 re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 re2c Not affected
SUSE Manager Proxy 4.2 re2c Not affected
SUSE Manager Proxy 4.3 re2c Not affected
SUSE Manager Retail Branch Server 4.2 re2c Not affected
SUSE Manager Retail Branch Server 4.3 re2c Not affected
SUSE Manager Server 4.2 re2c Not affected
SUSE Manager Server 4.3 re2c Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP4 re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS re2c Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS re2c Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS re2c Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS re2c Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 re2c Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 re2c Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 re2c Not affected
SUSE Linux Enterprise Server 12 SP2-BCL re2c Not affected
SUSE Linux Enterprise Server 12 SP4 re2c Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS re2c Not affected
SUSE Linux Enterprise Server 15 SP1 re2c Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS re2c Not affected
SUSE Linux Enterprise Server 15 SP2 re2c Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS re2c Not affected
SUSE Linux Enterprise Server 15 SP3 re2c Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS re2c Not affected
SUSE Linux Enterprise Server 15-ESPOS re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 15 re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 re2c Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 re2c Not affected
SUSE CaaS Platform 4.0 re2c Not affected
SUSE Enterprise Storage 6 re2c Not affected
SUSE Linux Enterprise Desktop 12 re2c Not affected
SUSE Linux Enterprise Desktop 12 SP1 re2c Not affected
SUSE Linux Enterprise Desktop 12 SP2 re2c Not affected
SUSE Linux Enterprise Desktop 12 SP3 re2c Not affected
SUSE Linux Enterprise Desktop 12 SP4 re2c Not affected
SUSE Linux Enterprise Desktop 15 re2c Not affected
SUSE Linux Enterprise Desktop 15 SP1 re2c Not affected
SUSE Linux Enterprise Desktop 15 SP2 re2c Not affected
SUSE Linux Enterprise Desktop 15 SP3 re2c Not affected
SUSE Linux Enterprise Module for Basesystem 15 re2c Not affected
SUSE Linux Enterprise Real Time 15 SP2 re2c Not affected
SUSE Linux Enterprise Server 11 SP3 re2c Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS re2c Not affected
SUSE Linux Enterprise Server 11 SP4 re2c Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS re2c Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS re2c Not affected
SUSE Linux Enterprise Server 12 re2c Not affected
SUSE Linux Enterprise Server 12 SP1 re2c Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS re2c Not affected
SUSE Linux Enterprise Server 12 SP2 re2c Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS re2c Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS re2c Not affected
SUSE Linux Enterprise Server 12 SP3 re2c Not affected
SUSE Linux Enterprise Server 12 SP3-BCL re2c Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS re2c Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS re2c Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS re2c Not affected
SUSE Linux Enterprise Server 15 re2c Not affected
SUSE Linux Enterprise Server 15 SP1-BCL re2c Not affected
SUSE Linux Enterprise Server 15 SP2-BCL re2c Not affected
SUSE Linux Enterprise Server 15 SP3-BCL re2c Not affected
SUSE Linux Enterprise Server 15-LTSS re2c Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 re2c Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 re2c Not affected
SUSE Manager Proxy 4.0 re2c Not affected
SUSE Manager Proxy 4.1 re2c Not affected
SUSE Manager Retail Branch Server 4.0 re2c Not affected
SUSE Manager Retail Branch Server 4.1 re2c Not affected
SUSE Manager Server 4.0 re2c Not affected
SUSE Manager Server 4.1 re2c Not affected
SUSE OpenStack Cloud 7 re2c Not affected
SUSE OpenStack Cloud 8 re2c Not affected
SUSE OpenStack Cloud 9 re2c Not affected
SUSE OpenStack Cloud Crowbar 8 re2c Not affected
SUSE OpenStack Cloud Crowbar 9 re2c Not affected


SUSE Timeline for this CVE

CVE page created: Tue Apr 21 10:38:51 2020
CVE page last modified: Sat Jan 28 01:23:59 2023