Upstream information

CVE-2020-11810 at MITRE

Description

An issue was discovered in OpenVPN 2.4.x before 2.4.9. An attacker can inject a data channel v2 (P_DATA_V2) packet using a victim's peer-id. Normally such packets are dropped, but if this packet arrives before the data channel crypto parameters have been initialized, the victim's connection will be dropped. This requires careful timing due to the small time window (usually within a few seconds) between the victim client connection starting and the server PUSH_REPLY response back to the client. This attack will only work if Negotiable Cipher Parameters (NCP) is in use.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v3 Scores
  SUSE
Base Score 3.7
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1169925 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • openvpn >= 2.4.3-5.7.1
  • openvpn-auth-pam-plugin >= 2.4.3-5.7.1
  • openvpn-devel >= 2.4.3-5.7.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1577
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • openvpn >= 2.4.3-5.7.1
  • openvpn-auth-pam-plugin >= 2.4.3-5.7.1
  • openvpn-devel >= 2.4.3-5.7.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-1577
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • openvpn-down-root-plugin >= 2.4.3-5.7.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1577
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • openvpn-down-root-plugin >= 2.4.3-5.7.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-1577
openSUSE Leap 15.2
  • openvpn >= 2.4.3-lp152.6.3.1
  • openvpn-auth-pam-plugin >= 2.4.3-lp152.6.3.1
  • openvpn-devel >= 2.4.3-lp152.6.3.1
  • openvpn-down-root-plugin >= 2.4.3-lp152.6.3.1
Patchnames:
openSUSE-2021-734
openSUSE Tumbleweed
  • openvpn >= 2.5.3-1.2
  • openvpn-auth-pam-plugin >= 2.5.3-1.2
  • openvpn-devel >= 2.5.3-1.2
  • openvpn-down-root-plugin >= 2.5.3-1.2
Patchnames:
openSUSE Tumbleweed GA openvpn-2.5.3-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 openvpn In progress
SUSE Enterprise Storage 6 openvpn In progress
SUSE Linux Enterprise Desktop 12 SP2 openvpn Not affected
SUSE Linux Enterprise Desktop 12 SP3 openvpn Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 openvpn Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openvpn Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS openvpn In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS openvpn In progress
SUSE Linux Enterprise Module for Basesystem 15 SP1 openvpn Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 openvpn Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 openvpn Released
SUSE Linux Enterprise Server 11 SP4 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS openvpn Not affected
SUSE Linux Enterprise Server 12 SP4 openvpn Not affected
SUSE Linux Enterprise Server 12 SP5 openvpn Not affected
SUSE Linux Enterprise Server 15 ESPOS openvpn In progress
SUSE Linux Enterprise Server 15 LTSS openvpn In progress
SUSE Linux Enterprise Server 15 SP1 LTSS openvpn In progress
SUSE Linux Enterprise Server BCL 12 SP2 openvpn Not affected
SUSE Linux Enterprise Server BCL 12 SP3 openvpn Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openvpn In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openvpn Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openvpn Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openvpn Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openvpn Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openvpn In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openvpn In progress
SUSE Manager Proxy 4.0 openvpn In progress
SUSE Manager Retail Branch Server 4.0 openvpn In progress
SUSE Manager Server 4.0 openvpn In progress