Upstream information

CVE-2020-11078 at MITRE

Description

In httplib2 before version 0.18.0, an attacker controlling unescaped part of uri for `httplib2.Http.request()` could change request headers and body, send additional hidden requests to same server. This vulnerability impacts software that uses httplib2 with uri constructed by string concatenation, as opposed to proper urllib building with escaping. This has been fixed in 0.18.0.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.8
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction None None
Scope Changed Changed
Confidentiality Impact None None
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1171998 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • python-httplib2 >= 0.19.0-7.3.1
Patchnames:
HPE-Helion-OpenStack-8-2021-1808
Image caasp4/caasp-k8s-sidecar-image
Image caasp45/caasp-k8s-sidecar-image
  • python3-httplib2 >= 0.19.0-3.3.1
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • python3-httplib2 >= 0.19.0-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1806
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • python3-httplib2 >= 0.19.0-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-1806
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • python2-httplib2 >= 0.19.0-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1806
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP3
  • python2-httplib2 >= 0.19.0-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP3-2021-1806
SUSE Linux Enterprise Module for Public Cloud 12
  • python-httplib2 >= 0.19.0-7.7.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2021-1807
SUSE Linux Enterprise Module for Public Cloud 15
  • python3-httplib2 >= 0.19.0-1.8.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-2021-1637
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • python2-httplib2 >= 0.19.0-3.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2021-1806
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • python2-httplib2 >= 0.19.0-3.3.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2021-1806
SUSE OpenStack Cloud 7
  • python-httplib2 >= 0.19.0-7.7.1
Patchnames:
SUSE-OpenStack-Cloud-7-2021-1807
SUSE OpenStack Cloud 8
  • python-httplib2 >= 0.19.0-7.3.1
Patchnames:
SUSE-OpenStack-Cloud-8-2021-1808
SUSE OpenStack Cloud 9
  • python-httplib2 >= 0.19.0-8.3.4
Patchnames:
SUSE-OpenStack-Cloud-9-2021-1779
SUSE OpenStack Cloud Crowbar 8
  • python-httplib2 >= 0.19.0-7.3.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-1808
SUSE OpenStack Cloud Crowbar 9
  • python-httplib2 >= 0.19.0-8.3.4
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-1779
SUSE Package Hub for SUSE Linux Enterprise 15 SP2
  • python2-httplib2 >= 0.19.0-bp152.3.3.1
Patchnames:
openSUSE-2021-796
openSUSE Leap 15.2
  • python2-httplib2 >= 0.19.0-lp152.6.3.1
  • python3-httplib2 >= 0.19.0-lp152.6.3.1
Patchnames:
openSUSE-2021-772
openSUSE Leap 15.3
  • python2-httplib2 >= 0.19.0-3.3.1
  • python3-httplib2 >= 0.19.0-3.3.1
Patchnames:
openSUSE-SLE-15.3-2021-1806


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 python-httplib2 In progress
HPE Helion OpenStack Cloud 8 python-httplib2 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 python-httplib2 Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 python-httplib2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 python-httplib2 Released
SUSE Linux Enterprise Module for Public Cloud 12 python-httplib2 In progress
SUSE Linux Enterprise Module for Public Cloud 15 python-httplib2 In progress
SUSE Manager Server 3.2 python-httplib2 Affected
SUSE OpenStack Cloud 6 LTSS python-httplib2 Affected
SUSE OpenStack Cloud 7 python-httplib2 In progress
SUSE OpenStack Cloud 8 python-httplib2 In progress
SUSE OpenStack Cloud 9 python-httplib2 In progress
SUSE OpenStack Cloud Crowbar 8 python-httplib2 In progress
SUSE OpenStack Cloud Crowbar 9 python-httplib2 In progress
SUSE Package Hub 15 python-httplib2 Released