Upstream information

CVE-2020-0570 at MITRE

Description

Uncontrolled search path in the QT Library before 5.14.0, 5.12.7 and 5.9.10 may allow an authenticated user to potentially enable elevation of privilege via local access.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.3 7.3
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1161167 [IN_PROGRESS], 1162191 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libQt5Concurrent-devel >= 5.12.7-2.25
  • libQt5Concurrent5 >= 5.12.7-2.25
  • libQt5Core-devel >= 5.12.7-2.25
  • libQt5Core-private-headers-devel >= 5.12.7-2.25
  • libQt5Core5 >= 5.12.7-2.25
  • libQt5DBus-devel >= 5.12.7-2.25
  • libQt5DBus-private-headers-devel >= 5.12.7-2.25
  • libQt5DBus5 >= 5.12.7-2.25
  • libQt5Gui-devel >= 5.12.7-2.25
  • libQt5Gui-private-headers-devel >= 5.12.7-2.25
  • libQt5Gui5 >= 5.12.7-2.25
  • libQt5KmsSupport-devel-static >= 5.12.7-2.25
  • libQt5KmsSupport-private-headers-devel >= 5.12.7-2.25
  • libQt5Network-devel >= 5.12.7-2.25
  • libQt5Network-private-headers-devel >= 5.12.7-2.25
  • libQt5Network5 >= 5.12.7-2.25
  • libQt5OpenGL-devel >= 5.12.7-2.25
  • libQt5OpenGL-private-headers-devel >= 5.12.7-2.25
  • libQt5OpenGL5 >= 5.12.7-2.25
  • libQt5OpenGLExtensions-devel-static >= 5.12.7-2.25
  • libQt5PlatformHeaders-devel >= 5.12.7-2.25
  • libQt5PlatformSupport-devel-static >= 5.12.7-2.25
  • libQt5PlatformSupport-private-headers-devel >= 5.12.7-2.25
  • libQt5PrintSupport-devel >= 5.12.7-2.25
  • libQt5PrintSupport-private-headers-devel >= 5.12.7-2.25
  • libQt5PrintSupport5 >= 5.12.7-2.25
  • libQt5Sql-devel >= 5.12.7-2.25
  • libQt5Sql-private-headers-devel >= 5.12.7-2.25
  • libQt5Sql5 >= 5.12.7-2.25
  • libQt5Sql5-mysql >= 5.12.7-2.25
  • libQt5Sql5-postgresql >= 5.12.7-2.25
  • libQt5Sql5-sqlite >= 5.12.7-2.25
  • libQt5Sql5-unixODBC >= 5.12.7-2.25
  • libQt5Test-devel >= 5.12.7-2.25
  • libQt5Test-private-headers-devel >= 5.12.7-2.25
  • libQt5Test5 >= 5.12.7-2.25
  • libQt5Widgets-devel >= 5.12.7-2.25
  • libQt5Widgets-private-headers-devel >= 5.12.7-2.25
  • libQt5Widgets5 >= 5.12.7-2.25
  • libQt5Xml-devel >= 5.12.7-2.25
  • libQt5Xml5 >= 5.12.7-2.25
  • libqt5-qtbase-common-devel >= 5.12.7-2.25
  • libqt5-qtbase-devel >= 5.12.7-2.25
  • libqt5-qtbase-platformtheme-gtk3 >= 5.12.7-2.25
  • libqt5-qtbase-private-headers-devel >= 5.12.7-2.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libQt5Concurrent-devel-5.12.7-2.25
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA libQt5OpenGLExtensions-devel-static-5.12.7-2.25
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libQt5Concurrent-devel >= 5.12.7-4.12.2
  • libQt5Concurrent5 >= 5.12.7-4.12.2
  • libQt5Core-devel >= 5.12.7-4.12.2
  • libQt5Core-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Core5 >= 5.12.7-4.12.2
  • libQt5DBus-devel >= 5.12.7-4.12.2
  • libQt5DBus-private-headers-devel >= 5.12.7-4.12.2
  • libQt5DBus5 >= 5.12.7-4.12.2
  • libQt5Gui-devel >= 5.12.7-4.12.2
  • libQt5Gui-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Gui5 >= 5.12.7-4.12.2
  • libQt5KmsSupport-devel-static >= 5.12.7-4.12.2
  • libQt5KmsSupport-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Network-devel >= 5.12.7-4.12.2
  • libQt5Network-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Network5 >= 5.12.7-4.12.2
  • libQt5OpenGL-devel >= 5.12.7-4.12.2
  • libQt5OpenGL-private-headers-devel >= 5.12.7-4.12.2
  • libQt5OpenGL5 >= 5.12.7-4.12.2
  • libQt5OpenGLExtensions-devel-static >= 5.12.7-4.12.2
  • libQt5PlatformHeaders-devel >= 5.12.7-4.12.2
  • libQt5PlatformSupport-devel-static >= 5.12.7-4.12.2
  • libQt5PlatformSupport-private-headers-devel >= 5.12.7-4.12.2
  • libQt5PrintSupport-devel >= 5.12.7-4.12.2
  • libQt5PrintSupport-private-headers-devel >= 5.12.7-4.12.2
  • libQt5PrintSupport5 >= 5.12.7-4.12.2
  • libQt5Sql-devel >= 5.12.7-4.12.2
  • libQt5Sql-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Sql5 >= 5.12.7-4.12.2
  • libQt5Sql5-mysql >= 5.12.7-4.12.2
  • libQt5Sql5-postgresql >= 5.12.7-4.12.2
  • libQt5Sql5-sqlite >= 5.12.7-4.12.2
  • libQt5Sql5-unixODBC >= 5.12.7-4.12.2
  • libQt5Test-devel >= 5.12.7-4.12.2
  • libQt5Test-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Test5 >= 5.12.7-4.12.2
  • libQt5Widgets-devel >= 5.12.7-4.12.2
  • libQt5Widgets-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Widgets5 >= 5.12.7-4.12.2
  • libQt5Xml-devel >= 5.12.7-4.12.2
  • libQt5Xml5 >= 5.12.7-4.12.2
  • libqt5-qtbase-common-devel >= 5.12.7-4.12.2
  • libqt5-qtbase-devel >= 5.12.7-4.12.2
  • libqt5-qtbase-platformtheme-gtk3 >= 5.12.7-4.12.2
  • libqt5-qtbase-private-headers-devel >= 5.12.7-4.12.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libQt5Concurrent-devel-5.12.7-4.12.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA libQt5OpenGLExtensions-devel-static-5.12.7-4.12.2
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libQt5Concurrent-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Concurrent5 >= 5.15.2+kde294-150400.4.8
  • libQt5Core-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Core-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Core5 >= 5.15.2+kde294-150400.4.8
  • libQt5DBus-devel >= 5.15.2+kde294-150400.4.8
  • libQt5DBus-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5DBus5 >= 5.15.2+kde294-150400.4.8
  • libQt5Gui-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Gui-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Gui5 >= 5.15.2+kde294-150400.4.8
  • libQt5KmsSupport-devel-static >= 5.15.2+kde294-150400.4.8
  • libQt5KmsSupport-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Network-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Network-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Network5 >= 5.15.2+kde294-150400.4.8
  • libQt5OpenGL-devel >= 5.15.2+kde294-150400.4.8
  • libQt5OpenGL-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5OpenGL5 >= 5.15.2+kde294-150400.4.8
  • libQt5OpenGLExtensions-devel-static >= 5.15.2+kde294-150400.4.8
  • libQt5PlatformHeaders-devel >= 5.15.2+kde294-150400.4.8
  • libQt5PlatformSupport-devel-static >= 5.15.2+kde294-150400.4.8
  • libQt5PlatformSupport-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5PrintSupport-devel >= 5.15.2+kde294-150400.4.8
  • libQt5PrintSupport-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5PrintSupport5 >= 5.15.2+kde294-150400.4.8
  • libQt5Sql-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Sql-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5 >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-mysql >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-postgresql >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-sqlite >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-unixODBC >= 5.15.2+kde294-150400.4.8
  • libQt5Test-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Test-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Test5 >= 5.15.2+kde294-150400.4.8
  • libQt5Widgets-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Widgets-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Widgets5 >= 5.15.2+kde294-150400.4.8
  • libQt5Xml-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Xml5 >= 5.15.2+kde294-150400.4.8
  • libqt5-qtbase-common-devel >= 5.15.2+kde294-150400.4.8
  • libqt5-qtbase-devel >= 5.15.2+kde294-150400.4.8
  • libqt5-qtbase-platformtheme-gtk3 >= 5.15.2+kde294-150400.4.8
  • libqt5-qtbase-private-headers-devel >= 5.15.2+kde294-150400.4.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libQt5Concurrent-devel-5.15.2+kde294-150400.4.8
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libQt5OpenGLExtensions-devel-static-5.15.2+kde294-150400.4.8
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libQt5Concurrent-devel >= 5.12.7-2.25
  • libQt5Concurrent5 >= 5.12.7-2.25
  • libQt5Core-devel >= 5.12.7-2.25
  • libQt5Core-private-headers-devel >= 5.12.7-2.25
  • libQt5Core5 >= 5.12.7-2.25
  • libQt5DBus-devel >= 5.12.7-2.25
  • libQt5DBus-private-headers-devel >= 5.12.7-2.25
  • libQt5DBus5 >= 5.12.7-2.25
  • libQt5Gui-devel >= 5.12.7-2.25
  • libQt5Gui-private-headers-devel >= 5.12.7-2.25
  • libQt5Gui5 >= 5.12.7-2.25
  • libQt5KmsSupport-devel-static >= 5.12.7-2.25
  • libQt5KmsSupport-private-headers-devel >= 5.12.7-2.25
  • libQt5Network-devel >= 5.12.7-2.25
  • libQt5Network-private-headers-devel >= 5.12.7-2.25
  • libQt5Network5 >= 5.12.7-2.25
  • libQt5OpenGL-devel >= 5.12.7-2.25
  • libQt5OpenGL-private-headers-devel >= 5.12.7-2.25
  • libQt5OpenGL5 >= 5.12.7-2.25
  • libQt5PlatformHeaders-devel >= 5.12.7-2.25
  • libQt5PlatformSupport-devel-static >= 5.12.7-2.25
  • libQt5PlatformSupport-private-headers-devel >= 5.12.7-2.25
  • libQt5PrintSupport-devel >= 5.12.7-2.25
  • libQt5PrintSupport-private-headers-devel >= 5.12.7-2.25
  • libQt5PrintSupport5 >= 5.12.7-2.25
  • libQt5Sql-devel >= 5.12.7-2.25
  • libQt5Sql-private-headers-devel >= 5.12.7-2.25
  • libQt5Sql5 >= 5.12.7-2.25
  • libQt5Sql5-sqlite >= 5.12.7-2.25
  • libQt5Test-devel >= 5.12.7-2.25
  • libQt5Test-private-headers-devel >= 5.12.7-2.25
  • libQt5Test5 >= 5.12.7-2.25
  • libQt5Widgets-devel >= 5.12.7-2.25
  • libQt5Widgets-private-headers-devel >= 5.12.7-2.25
  • libQt5Widgets5 >= 5.12.7-2.25
  • libQt5Xml-devel >= 5.12.7-2.25
  • libQt5Xml5 >= 5.12.7-2.25
  • libqt5-qtbase-common-devel >= 5.12.7-2.25
  • libqt5-qtbase-devel >= 5.12.7-2.25
  • libqt5-qtbase-private-headers-devel >= 5.12.7-2.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libQt5Concurrent-devel-5.12.7-2.25
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libQt5Concurrent-devel >= 5.12.7-4.12.2
  • libQt5Concurrent5 >= 5.12.7-4.12.2
  • libQt5Core-devel >= 5.12.7-4.12.2
  • libQt5Core-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Core5 >= 5.12.7-4.12.2
  • libQt5DBus-devel >= 5.12.7-4.12.2
  • libQt5DBus-private-headers-devel >= 5.12.7-4.12.2
  • libQt5DBus5 >= 5.12.7-4.12.2
  • libQt5Gui-devel >= 5.12.7-4.12.2
  • libQt5Gui-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Gui5 >= 5.12.7-4.12.2
  • libQt5KmsSupport-devel-static >= 5.12.7-4.12.2
  • libQt5KmsSupport-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Network-devel >= 5.12.7-4.12.2
  • libQt5Network-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Network5 >= 5.12.7-4.12.2
  • libQt5OpenGL-devel >= 5.12.7-4.12.2
  • libQt5OpenGL-private-headers-devel >= 5.12.7-4.12.2
  • libQt5OpenGL5 >= 5.12.7-4.12.2
  • libQt5PlatformHeaders-devel >= 5.12.7-4.12.2
  • libQt5PlatformSupport-devel-static >= 5.12.7-4.12.2
  • libQt5PlatformSupport-private-headers-devel >= 5.12.7-4.12.2
  • libQt5PrintSupport-devel >= 5.12.7-4.12.2
  • libQt5PrintSupport-private-headers-devel >= 5.12.7-4.12.2
  • libQt5PrintSupport5 >= 5.12.7-4.12.2
  • libQt5Sql-devel >= 5.12.7-4.12.2
  • libQt5Sql-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Sql5 >= 5.12.7-4.12.2
  • libQt5Sql5-sqlite >= 5.12.7-4.12.2
  • libQt5Test-devel >= 5.12.7-4.12.2
  • libQt5Test-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Test5 >= 5.12.7-4.12.2
  • libQt5Widgets-devel >= 5.12.7-4.12.2
  • libQt5Widgets-private-headers-devel >= 5.12.7-4.12.2
  • libQt5Widgets5 >= 5.12.7-4.12.2
  • libQt5Xml-devel >= 5.12.7-4.12.2
  • libQt5Xml5 >= 5.12.7-4.12.2
  • libqt5-qtbase-common-devel >= 5.12.7-4.12.2
  • libqt5-qtbase-devel >= 5.12.7-4.12.2
  • libqt5-qtbase-private-headers-devel >= 5.12.7-4.12.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libQt5Concurrent-devel-5.12.7-4.12.2
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libQt5Concurrent-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Concurrent5 >= 5.15.2+kde294-150400.4.8
  • libQt5Core-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Core-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Core5 >= 5.15.2+kde294-150400.4.8
  • libQt5DBus-devel >= 5.15.2+kde294-150400.4.8
  • libQt5DBus-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5DBus5 >= 5.15.2+kde294-150400.4.8
  • libQt5Gui-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Gui-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Gui5 >= 5.15.2+kde294-150400.4.8
  • libQt5KmsSupport-devel-static >= 5.15.2+kde294-150400.4.8
  • libQt5KmsSupport-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Network-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Network-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Network5 >= 5.15.2+kde294-150400.4.8
  • libQt5OpenGL-devel >= 5.15.2+kde294-150400.4.8
  • libQt5OpenGL-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5OpenGL5 >= 5.15.2+kde294-150400.4.8
  • libQt5PlatformHeaders-devel >= 5.15.2+kde294-150400.4.8
  • libQt5PlatformSupport-devel-static >= 5.15.2+kde294-150400.4.8
  • libQt5PlatformSupport-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5PrintSupport-devel >= 5.15.2+kde294-150400.4.8
  • libQt5PrintSupport-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5PrintSupport5 >= 5.15.2+kde294-150400.4.8
  • libQt5Sql-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Sql-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5 >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-sqlite >= 5.15.2+kde294-150400.4.8
  • libQt5Test-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Test-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Test5 >= 5.15.2+kde294-150400.4.8
  • libQt5Widgets-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Widgets-private-headers-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Widgets5 >= 5.15.2+kde294-150400.4.8
  • libQt5Xml-devel >= 5.15.2+kde294-150400.4.8
  • libQt5Xml5 >= 5.15.2+kde294-150400.4.8
  • libqt5-qtbase-common-devel >= 5.15.2+kde294-150400.4.8
  • libqt5-qtbase-devel >= 5.15.2+kde294-150400.4.8
  • libqt5-qtbase-private-headers-devel >= 5.15.2+kde294-150400.4.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libQt5Concurrent-devel-5.15.2+kde294-150400.4.8
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • libQt5OpenGLExtensions-devel-static >= 5.12.7-2.25
  • libQt5Sql5-mysql >= 5.12.7-2.25
  • libQt5Sql5-postgresql >= 5.12.7-2.25
  • libQt5Sql5-unixODBC >= 5.12.7-2.25
  • libqt5-qtbase-platformtheme-gtk3 >= 5.12.7-2.25
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA libQt5OpenGLExtensions-devel-static-5.12.7-2.25
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • libQt5OpenGLExtensions-devel-static >= 5.12.7-4.12.2
  • libQt5Sql5-mysql >= 5.12.7-4.12.2
  • libQt5Sql5-postgresql >= 5.12.7-4.12.2
  • libQt5Sql5-unixODBC >= 5.12.7-4.12.2
  • libqt5-qtbase-platformtheme-gtk3 >= 5.12.7-4.12.2
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA libQt5OpenGLExtensions-devel-static-5.12.7-4.12.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • libQt5OpenGLExtensions-devel-static >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-mysql >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-postgresql >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-unixODBC >= 5.15.2+kde294-150400.4.8
  • libqt5-qtbase-platformtheme-gtk3 >= 5.15.2+kde294-150400.4.8
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libQt5OpenGLExtensions-devel-static-5.15.2+kde294-150400.4.8
openSUSE Leap 15.2
  • libQt5Concurrent5 >= 5.12.7-lp152.2.5
  • libQt5Core5 >= 5.12.7-lp152.2.5
  • libQt5DBus5 >= 5.12.7-lp152.2.5
  • libQt5Gui5 >= 5.12.7-lp152.2.5
  • libQt5Network5 >= 5.12.7-lp152.2.5
  • libQt5OpenGL5 >= 5.12.7-lp152.2.5
  • libQt5PrintSupport5 >= 5.12.7-lp152.2.5
  • libQt5Sql5 >= 5.12.7-lp152.2.5
  • libQt5Sql5-mysql >= 5.12.7-lp152.2.3
  • libQt5Sql5-sqlite >= 5.12.7-lp152.2.5
  • libQt5Test5 >= 5.12.7-lp152.2.5
  • libQt5Widgets5 >= 5.12.7-lp152.2.5
  • libQt5Xml5 >= 5.12.7-lp152.2.5
  • libqt5-qtbase-platformtheme-gtk3 >= 5.12.7-lp152.2.5
Patchnames:
openSUSE Leap 15.2 GA libQt5Concurrent5-5.12.7-lp152.2.1
openSUSE Leap 15.3
  • libQt5Concurrent5 >= 5.12.7-4.12.2
  • libQt5Core5 >= 5.12.7-4.12.2
  • libQt5DBus5 >= 5.12.7-4.12.2
  • libQt5Gui5 >= 5.12.7-4.12.2
  • libQt5Network5 >= 5.12.7-4.12.2
  • libQt5OpenGL5 >= 5.12.7-4.12.2
  • libQt5PrintSupport5 >= 5.12.7-4.12.2
  • libQt5Sql5 >= 5.12.7-4.12.2
  • libQt5Sql5-mysql >= 5.12.7-4.12.2
  • libQt5Sql5-sqlite >= 5.12.7-4.12.2
  • libQt5Test5 >= 5.12.7-4.12.2
  • libQt5Widgets5 >= 5.12.7-4.12.2
  • libQt5Xml5 >= 5.12.7-4.12.2
  • libqt5-qtbase-platformtheme-gtk3 >= 5.12.7-4.12.2
Patchnames:
openSUSE Leap 15.3 GA libQt5Concurrent5-5.12.7-4.12.2
openSUSE Leap 15.4
  • libQt5Concurrent5 >= 5.15.2+kde294-150400.4.8
  • libQt5Core5 >= 5.15.2+kde294-150400.4.8
  • libQt5DBus5 >= 5.15.2+kde294-150400.4.8
  • libQt5Gui5 >= 5.15.2+kde294-150400.4.8
  • libQt5Network5 >= 5.15.2+kde294-150400.4.8
  • libQt5OpenGL5 >= 5.15.2+kde294-150400.4.8
  • libQt5PrintSupport5 >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5 >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-mysql >= 5.15.2+kde294-150400.4.8
  • libQt5Sql5-sqlite >= 5.15.2+kde294-150400.4.8
  • libQt5Test5 >= 5.15.2+kde294-150400.4.8
  • libQt5Widgets5 >= 5.15.2+kde294-150400.4.8
  • libQt5Xml5 >= 5.15.2+kde294-150400.4.8
  • libqt5-qtbase-platformtheme-gtk3 >= 5.15.2+kde294-150400.4.8
Patchnames:
openSUSE Leap 15.4 GA libQt5Concurrent5-5.15.2+kde294-150400.4.8
openSUSE Tumbleweed
  • libQt5Bootstrap-devel-static >= 5.15.2+kde222-1.3
  • libQt5Bootstrap-devel-static-32bit >= 5.15.2+kde222-1.3
  • libQt5Concurrent-devel >= 5.15.2+kde222-1.3
  • libQt5Concurrent-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5Concurrent5 >= 5.15.2+kde222-1.3
  • libQt5Concurrent5-32bit >= 5.15.2+kde222-1.3
  • libQt5Core-devel >= 5.15.2+kde222-1.3
  • libQt5Core-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5Core-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5Core5 >= 5.15.2+kde222-1.3
  • libQt5Core5-32bit >= 5.15.2+kde222-1.3
  • libQt5DBus-devel >= 5.15.2+kde222-1.3
  • libQt5DBus-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5DBus-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5DBus5 >= 5.15.2+kde222-1.3
  • libQt5DBus5-32bit >= 5.15.2+kde222-1.3
  • libQt5Gui-devel >= 5.15.2+kde222-1.3
  • libQt5Gui-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5Gui-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5Gui5 >= 5.15.2+kde222-1.3
  • libQt5Gui5-32bit >= 5.15.2+kde222-1.3
  • libQt5KmsSupport-devel-static >= 5.15.2+kde222-1.3
  • libQt5KmsSupport-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5Network-devel >= 5.15.2+kde222-1.3
  • libQt5Network-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5Network-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5Network5 >= 5.15.2+kde222-1.3
  • libQt5Network5-32bit >= 5.15.2+kde222-1.3
  • libQt5OpenGL-devel >= 5.15.2+kde222-1.3
  • libQt5OpenGL-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5OpenGL-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5OpenGL5 >= 5.15.2+kde222-1.3
  • libQt5OpenGL5-32bit >= 5.15.2+kde222-1.3
  • libQt5OpenGLExtensions-devel-static >= 5.15.2+kde222-1.3
  • libQt5OpenGLExtensions-devel-static-32bit >= 5.15.2+kde222-1.3
  • libQt5PlatformHeaders-devel >= 5.15.2+kde222-1.3
  • libQt5PlatformSupport-devel-static >= 5.15.2+kde222-1.3
  • libQt5PlatformSupport-devel-static-32bit >= 5.15.2+kde222-1.3
  • libQt5PlatformSupport-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5PrintSupport-devel >= 5.15.2+kde222-1.3
  • libQt5PrintSupport-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5PrintSupport-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5PrintSupport5 >= 5.15.2+kde222-1.3
  • libQt5PrintSupport5-32bit >= 5.15.2+kde222-1.3
  • libQt5Sql-devel >= 5.15.2+kde222-1.3
  • libQt5Sql-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5Sql-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5Sql5 >= 5.15.2+kde222-1.3
  • libQt5Sql5-32bit >= 5.15.2+kde222-1.3
  • libQt5Sql5-mysql >= 5.15.2+kde222-1.3
  • libQt5Sql5-mysql-32bit >= 5.15.2+kde222-1.3
  • libQt5Sql5-postgresql >= 5.15.2+kde222-1.3
  • libQt5Sql5-postgresql-32bit >= 5.15.2+kde222-1.3
  • libQt5Sql5-sqlite >= 5.15.2+kde222-1.3
  • libQt5Sql5-sqlite-32bit >= 5.15.2+kde222-1.3
  • libQt5Sql5-unixODBC >= 5.15.2+kde222-1.3
  • libQt5Sql5-unixODBC-32bit >= 5.15.2+kde222-1.3
  • libQt5Test-devel >= 5.15.2+kde222-1.3
  • libQt5Test-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5Test-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5Test5 >= 5.15.2+kde222-1.3
  • libQt5Test5-32bit >= 5.15.2+kde222-1.3
  • libQt5Widgets-devel >= 5.15.2+kde222-1.3
  • libQt5Widgets-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5Widgets-private-headers-devel >= 5.15.2+kde222-1.3
  • libQt5Widgets5 >= 5.15.2+kde222-1.3
  • libQt5Widgets5-32bit >= 5.15.2+kde222-1.3
  • libQt5Xml-devel >= 5.15.2+kde222-1.3
  • libQt5Xml-devel-32bit >= 5.15.2+kde222-1.3
  • libQt5Xml5 >= 5.15.2+kde222-1.3
  • libQt5Xml5-32bit >= 5.15.2+kde222-1.3
  • libqt5-qtbase-common-devel >= 5.15.2+kde222-1.3
  • libqt5-qtbase-devel >= 5.15.2+kde222-1.3
  • libqt5-qtbase-examples >= 5.15.2+kde222-1.3
  • libqt5-qtbase-examples-32bit >= 5.15.2+kde222-1.3
  • libqt5-qtbase-platformtheme-gtk3 >= 5.15.2+kde222-1.3
  • libqt5-qtbase-platformtheme-xdgdesktopportal >= 5.15.2+kde222-1.3
  • libqt5-qtbase-private-headers-devel >= 5.15.2+kde222-1.3
Patchnames:
openSUSE Tumbleweed GA libQt5Bootstrap-devel-static-32bit-5.15.2+kde222-1.3


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libqt5-qtbase Not affected
SUSE Enterprise Storage 5 libqt5-qtbase Not affected
SUSE Linux Enterprise Desktop 12 SP4 libqt5-qtbase Not affected
SUSE Linux Enterprise Desktop 15 libqt5-qtbase Affected
SUSE Linux Enterprise Desktop 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Desktop 15 SP2 libqt5-qtbase Already fixed
SUSE Linux Enterprise Desktop 15 SP4 libqt5-qtbase Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP4 libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 15 libqt5-qtbase Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 libqt5-qtbase Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 libqt5-qtbase Already fixed
SUSE Linux Enterprise Module for Basesystem 15 libqt5-qtbase Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 libqt5-qtbase Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 libqt5-qtbase Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 libqt5-qtbase Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 libqt5-qtbase Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 libqt5-qtbase Already fixed
SUSE Linux Enterprise Point of Service Image Server 12 SP2 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP2 BCL libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP2 ESPOS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP3 BCL libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP4 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 12 SP5 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 15 libqt5-qtbase Affected
SUSE Linux Enterprise Server 15 ESPOS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 15 LTSS libqt5-qtbase Not affected
SUSE Linux Enterprise Server 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Server 15 SP2 libqt5-qtbase Already fixed
SUSE Linux Enterprise Server 15 SP4 libqt5-qtbase Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libqt5-qtbase Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libqt5-qtbase Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libqt5-qtbase Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libqt5-qtbase Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP4 libqt5-qtbase Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 libqt5-qtbase Not affected
SUSE Linux Enterprise Storage 6 libqt5-qtbase Not affected
SUSE Linux Enterprise Storage 7 libqt5-qtbase Already fixed
SUSE Manager Proxy 4.0 libqt5-qtbase Not affected
SUSE Manager Proxy 4.1 libqt5-qtbase Already fixed
SUSE Manager Proxy 4.3 libqt5-qtbase Already fixed
SUSE Manager Retail Branch Server 4.0 libqt5-qtbase Not affected
SUSE Manager Retail Branch Server 4.1 libqt5-qtbase Already fixed
SUSE Manager Retail Branch Server 4.3 libqt5-qtbase Already fixed
SUSE Manager Server 4.0 libqt5-qtbase Not affected
SUSE Manager Server 4.1 libqt5-qtbase Already fixed
SUSE Manager Server 4.3 libqt5-qtbase Already fixed
SUSE OpenStack Cloud 7 libqt5-qtbase Not affected
SUSE OpenStack Cloud 8 libqt5-qtbase Not affected
SUSE OpenStack Cloud 9 libqt5-qtbase Not affected
SUSE OpenStack Cloud Crowbar 8 libqt5-qtbase Not affected
SUSE OpenStack Cloud Crowbar 9 libqt5-qtbase Not affected