Upstream information

CVE-2020-0110 at MITRE

Description

In psi_write of psi.c, there is a possible out of bounds write due to a missing bounds check. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-148159562References: Upstream kernel

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1171374 [RESOLVED / FIXED], 1174874 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • kernel-default >= 5.3.18-22.2
  • kernel-default-devel >= 5.3.18-22.2
  • kernel-devel >= 5.3.18-22.2
  • kernel-macros >= 5.3.18-22.2
  • kernel-preempt >= 5.3.18-22.2
  • kernel-zfcpdump >= 5.3.18-22.2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • kernel-64kb >= 5.3.18-57.3
  • kernel-64kb-devel >= 5.3.18-57.3
  • kernel-default >= 5.3.18-57.3
  • kernel-default-devel >= 5.3.18-57.3
  • kernel-devel >= 5.3.18-57.3
  • kernel-macros >= 5.3.18-57.3
  • kernel-preempt >= 5.3.18-57.3
  • kernel-zfcpdump >= 5.3.18-57.3
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • kernel-docs >= 5.3.18-22.3
  • kernel-obs-build >= 5.3.18-22.2
  • kernel-preempt-devel >= 5.3.18-22.2
  • kernel-source >= 5.3.18-22.2
  • kernel-syms >= 5.3.18-22.1
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • kernel-docs >= 5.3.18-57.3
  • kernel-obs-build >= 5.3.18-57.3
  • kernel-preempt-devel >= 5.3.18-57.3
  • kernel-source >= 5.3.18-57.3
  • kernel-syms >= 5.3.18-57.1
SUSE Linux Enterprise Module for Legacy 15 SP2
  • reiserfs-kmp-default >= 5.3.18-22.2
SUSE Linux Enterprise Module for Legacy 15 SP3
  • reiserfs-kmp-default >= 5.3.18-57.3
SUSE Linux Enterprise Module for Public Cloud 15 SP2
  • kernel-azure >= 5.3.18-16.2
  • kernel-azure-devel >= 5.3.18-16.2
  • kernel-devel-azure >= 5.3.18-16.1
  • kernel-source-azure >= 5.3.18-16.1
  • kernel-syms-azure >= 5.3.18-16.1
SUSE Linux Enterprise Module for Public Cloud 15 SP3
  • kernel-azure >= 5.3.18-36.1
  • kernel-azure-devel >= 5.3.18-36.1
  • kernel-devel-azure >= 5.3.18-36.1
  • kernel-source-azure >= 5.3.18-36.1
  • kernel-syms-azure >= 5.3.18-36.1
SUSE Linux Enterprise Workstation Extension 15 SP2
  • kernel-default-extra >= 5.3.18-22.2
openSUSE Leap 15.2
  • cluster-md-kmp-rt >= 5.3.18-lp152.3.5.1
  • cluster-md-kmp-rt_debug >= 5.3.18-lp152.3.5.1
  • dlm-kmp-rt >= 5.3.18-lp152.3.5.1
  • dlm-kmp-rt_debug >= 5.3.18-lp152.3.5.1
  • gfs2-kmp-rt >= 5.3.18-lp152.3.5.1
  • gfs2-kmp-rt_debug >= 5.3.18-lp152.3.5.1
  • kernel-devel-rt >= 5.3.18-lp152.3.5.1
  • kernel-rt >= 5.3.18-lp152.3.5.1
  • kernel-rt-devel >= 5.3.18-lp152.3.5.1
  • kernel-rt-extra >= 5.3.18-lp152.3.5.1
  • kernel-rt_debug >= 5.3.18-lp152.3.5.1
  • kernel-rt_debug-devel >= 5.3.18-lp152.3.5.1
  • kernel-rt_debug-extra >= 5.3.18-lp152.3.5.1
  • kernel-source-rt >= 5.3.18-lp152.3.5.1
  • kernel-syms-rt >= 5.3.18-lp152.3.5.1
  • kselftests-kmp-rt >= 5.3.18-lp152.3.5.1
  • kselftests-kmp-rt_debug >= 5.3.18-lp152.3.5.1
  • ocfs2-kmp-rt >= 5.3.18-lp152.3.5.1
  • ocfs2-kmp-rt_debug >= 5.3.18-lp152.3.5.1
  • reiserfs-kmp-rt >= 5.3.18-lp152.3.5.1
  • reiserfs-kmp-rt_debug >= 5.3.18-lp152.3.5.1
Patchnames:
openSUSE-2021-242


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 SP4 kernel-default Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 kernel-source Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 kernel-default Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 kernel-source Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS kernel-default Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS kernel-source Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 kernel-default Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 kernel-source Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 kernel-default Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 kernel-source Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP1 kernel-default Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 kernel-source Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 kernel-default Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP2 kernel-source Already fixed
SUSE Linux Enterprise Module for Public Cloud 15 SP2 kernel-source-azure Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS kernel-default Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS kernel-default Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS kernel-default Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS kernel-default Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP4 kernel-default Not affected
SUSE Linux Enterprise Server 12 SP4 kernel-source Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS kernel-default Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP5 kernel-default Not affected
SUSE Linux Enterprise Server 12 SP5 kernel-source Not affected
SUSE Linux Enterprise Server 15 ESPOS kernel-default Not affected
SUSE Linux Enterprise Server 15 ESPOS kernel-source Not affected
SUSE Linux Enterprise Server 15 LTSS kernel-default Not affected
SUSE Linux Enterprise Server 15 LTSS kernel-source Not affected
SUSE Linux Enterprise Server BCL 12 SP2 kernel-default Not affected
SUSE Linux Enterprise Server BCL 12 SP2 kernel-source Not affected
SUSE Linux Enterprise Server BCL 12 SP3 kernel-default Not affected
SUSE Linux Enterprise Server BCL 12 SP3 kernel-source Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 kernel-default Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 kernel-source Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 kernel-default Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 kernel-source Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 kernel-default Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 kernel-source Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 kernel-default Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 kernel-source Not affected