Upstream information

CVE-2019-9020 at MITRE

Description

An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. Invalid input to the function xmlrpc_decode() can lead to an invalid memory access (heap out of bounds read or read after free). This is related to xml_elem_parse_buf in ext/xmlrpc/libxmlrpc/xml_element.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 4.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1126711 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Web Scripting 12
  • apache2-mod_php5 >= 5.5.14-109.51.6
  • apache2-mod_php7 >= 7.0.7-50.70.1
  • apache2-mod_php72 >= 7.2.5-1.7.1
  • libmemcached11 >= 1.0.18-3.2.1
  • libtidy-0_99-0 >= 1.0.20100204cvs-26.2.1
  • php5 >= 5.5.14-109.51.6
  • php5-bcmath >= 5.5.14-109.51.6
  • php5-bz2 >= 5.5.14-109.51.6
  • php5-calendar >= 5.5.14-109.51.6
  • php5-ctype >= 5.5.14-109.51.6
  • php5-curl >= 5.5.14-109.51.6
  • php5-dba >= 5.5.14-109.51.6
  • php5-dom >= 5.5.14-109.51.6
  • php5-enchant >= 5.5.14-109.51.6
  • php5-exif >= 5.5.14-109.51.6
  • php5-fastcgi >= 5.5.14-109.51.6
  • php5-fileinfo >= 5.5.14-109.51.6
  • php5-fpm >= 5.5.14-109.51.6
  • php5-ftp >= 5.5.14-109.51.6
  • php5-gd >= 5.5.14-109.51.6
  • php5-gettext >= 5.5.14-109.51.6
  • php5-gmp >= 5.5.14-109.51.6
  • php5-iconv >= 5.5.14-109.51.6
  • php5-imap >= 5.5.14-109.51.6
  • php5-intl >= 5.5.14-109.51.6
  • php5-json >= 5.5.14-109.51.6
  • php5-ldap >= 5.5.14-109.51.6
  • php5-mbstring >= 5.5.14-109.51.6
  • php5-mcrypt >= 5.5.14-109.51.6
  • php5-mysql >= 5.5.14-109.51.6
  • php5-odbc >= 5.5.14-109.51.6
  • php5-opcache >= 5.5.14-109.51.6
  • php5-openssl >= 5.5.14-109.51.6
  • php5-pcntl >= 5.5.14-109.51.6
  • php5-pdo >= 5.5.14-109.51.6
  • php5-pear >= 5.5.14-109.51.6
  • php5-pgsql >= 5.5.14-109.51.6
  • php5-phar >= 5.5.14-109.51.6
  • php5-posix >= 5.5.14-109.51.6
  • php5-pspell >= 5.5.14-109.51.6
  • php5-shmop >= 5.5.14-109.51.6
  • php5-snmp >= 5.5.14-109.51.6
  • php5-soap >= 5.5.14-109.51.6
  • php5-sockets >= 5.5.14-109.51.6
  • php5-sqlite >= 5.5.14-109.51.6
  • php5-suhosin >= 5.5.14-109.51.6
  • php5-sysvmsg >= 5.5.14-109.51.6
  • php5-sysvsem >= 5.5.14-109.51.6
  • php5-sysvshm >= 5.5.14-109.51.6
  • php5-tokenizer >= 5.5.14-109.51.6
  • php5-wddx >= 5.5.14-109.51.6
  • php5-xmlreader >= 5.5.14-109.51.6
  • php5-xmlrpc >= 5.5.14-109.51.6
  • php5-xmlwriter >= 5.5.14-109.51.6
  • php5-xsl >= 5.5.14-109.51.6
  • php5-zip >= 5.5.14-109.51.6
  • php5-zlib >= 5.5.14-109.51.6
  • php7 >= 7.0.7-50.70.1
  • php7-bcmath >= 7.0.7-50.70.1
  • php7-bz2 >= 7.0.7-50.70.1
  • php7-calendar >= 7.0.7-50.70.1
  • php7-ctype >= 7.0.7-50.70.1
  • php7-curl >= 7.0.7-50.70.1
  • php7-dba >= 7.0.7-50.70.1
  • php7-dom >= 7.0.7-50.70.1
  • php7-enchant >= 7.0.7-50.70.1
  • php7-exif >= 7.0.7-50.70.1
  • php7-fastcgi >= 7.0.7-50.70.1
  • php7-fileinfo >= 7.0.7-50.70.1
  • php7-fpm >= 7.0.7-50.70.1
  • php7-ftp >= 7.0.7-50.70.1
  • php7-gd >= 7.0.7-50.70.1
  • php7-gettext >= 7.0.7-50.70.1
  • php7-gmp >= 7.0.7-50.70.1
  • php7-iconv >= 7.0.7-50.70.1
  • php7-imap >= 7.0.7-50.70.1
  • php7-intl >= 7.0.7-50.70.1
  • php7-json >= 7.0.7-50.70.1
  • php7-ldap >= 7.0.7-50.70.1
  • php7-mbstring >= 7.0.7-50.70.1
  • php7-mcrypt >= 7.0.7-50.70.1
  • php7-mysql >= 7.0.7-50.70.1
  • php7-odbc >= 7.0.7-50.70.1
  • php7-opcache >= 7.0.7-50.70.1
  • php7-openssl >= 7.0.7-50.70.1
  • php7-pcntl >= 7.0.7-50.70.1
  • php7-pdo >= 7.0.7-50.70.1
  • php7-pear >= 7.0.7-50.70.1
  • php7-pear-Archive_Tar >= 7.0.7-50.70.1
  • php7-pgsql >= 7.0.7-50.70.1
  • php7-phar >= 7.0.7-50.70.1
  • php7-posix >= 7.0.7-50.70.1
  • php7-pspell >= 7.0.7-50.70.1
  • php7-shmop >= 7.0.7-50.70.1
  • php7-snmp >= 7.0.7-50.70.1
  • php7-soap >= 7.0.7-50.70.1
  • php7-sockets >= 7.0.7-50.70.1
  • php7-sqlite >= 7.0.7-50.70.1
  • php7-sysvmsg >= 7.0.7-50.70.1
  • php7-sysvsem >= 7.0.7-50.70.1
  • php7-sysvshm >= 7.0.7-50.70.1
  • php7-tokenizer >= 7.0.7-50.70.1
  • php7-wddx >= 7.0.7-50.70.1
  • php7-xmlreader >= 7.0.7-50.70.1
  • php7-xmlrpc >= 7.0.7-50.70.1
  • php7-xmlwriter >= 7.0.7-50.70.1
  • php7-xsl >= 7.0.7-50.70.1
  • php7-zip >= 7.0.7-50.70.1
  • php7-zlib >= 7.0.7-50.70.1
  • php72 >= 7.2.5-1.7.1
  • php72-bcmath >= 7.2.5-1.7.1
  • php72-bz2 >= 7.2.5-1.7.1
  • php72-calendar >= 7.2.5-1.7.1
  • php72-ctype >= 7.2.5-1.7.1
  • php72-curl >= 7.2.5-1.7.1
  • php72-dba >= 7.2.5-1.7.1
  • php72-dom >= 7.2.5-1.7.1
  • php72-enchant >= 7.2.5-1.7.1
  • php72-exif >= 7.2.5-1.7.1
  • php72-fastcgi >= 7.2.5-1.7.1
  • php72-fileinfo >= 7.2.5-1.7.1
  • php72-fpm >= 7.2.5-1.7.1
  • php72-ftp >= 7.2.5-1.7.1
  • php72-gd >= 7.2.5-1.7.1
  • php72-gettext >= 7.2.5-1.7.1
  • php72-gmp >= 7.2.5-1.7.1
  • php72-iconv >= 7.2.5-1.7.1
  • php72-imap >= 7.2.5-1.7.1
  • php72-intl >= 7.2.5-1.7.1
  • php72-json >= 7.2.5-1.7.1
  • php72-ldap >= 7.2.5-1.7.1
  • php72-mbstring >= 7.2.5-1.7.1
  • php72-memcached >= 3.1.3-1.3.1
  • php72-mysql >= 7.2.5-1.7.1
  • php72-odbc >= 7.2.5-1.7.1
  • php72-opcache >= 7.2.5-1.7.1
  • php72-openssl >= 7.2.5-1.7.1
  • php72-pcntl >= 7.2.5-1.7.1
  • php72-pdo >= 7.2.5-1.7.1
  • php72-pear >= 7.2.5-1.7.1
  • php72-pear-Archive_Tar >= 7.2.5-1.7.1
  • php72-pgsql >= 7.2.5-1.7.1
  • php72-phar >= 7.2.5-1.7.1
  • php72-posix >= 7.2.5-1.7.1
  • php72-pspell >= 7.2.5-1.7.1
  • php72-readline >= 7.2.5-1.7.1
  • php72-shmop >= 7.2.5-1.7.1
  • php72-snmp >= 7.2.5-1.7.1
  • php72-soap >= 7.2.5-1.7.1
  • php72-sockets >= 7.2.5-1.7.1
  • php72-sqlite >= 7.2.5-1.7.1
  • php72-sysvmsg >= 7.2.5-1.7.1
  • php72-sysvsem >= 7.2.5-1.7.1
  • php72-sysvshm >= 7.2.5-1.7.1
  • php72-tidy >= 7.2.5-1.7.1
  • php72-tokenizer >= 7.2.5-1.7.1
  • php72-wddx >= 7.2.5-1.7.1
  • php72-xmlreader >= 7.2.5-1.7.1
  • php72-xmlrpc >= 7.2.5-1.7.1
  • php72-xmlwriter >= 7.2.5-1.7.1
  • php72-xsl >= 7.2.5-1.7.1
  • php72-zip >= 7.2.5-1.7.1
  • php72-zlib >= 7.2.5-1.7.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2019-1041
SUSE-SLE-Module-Web-Scripting-12-2019-823
SUSE-SLE-Module-Web-Scripting-12-2019-985
SUSE Linux Enterprise Module for Web Scripting 15 SP2
  • apache2-mod_php7 >= 7.4.6-1.11
  • php7 >= 7.4.6-1.11
  • php7-bcmath >= 7.4.6-1.11
  • php7-bz2 >= 7.4.6-1.11
  • php7-calendar >= 7.4.6-1.11
  • php7-ctype >= 7.4.6-1.11
  • php7-curl >= 7.4.6-1.11
  • php7-dba >= 7.4.6-1.11
  • php7-devel >= 7.4.6-1.11
  • php7-dom >= 7.4.6-1.11
  • php7-enchant >= 7.4.6-1.11
  • php7-exif >= 7.4.6-1.11
  • php7-fastcgi >= 7.4.6-1.11
  • php7-fileinfo >= 7.4.6-1.11
  • php7-fpm >= 7.4.6-1.11
  • php7-ftp >= 7.4.6-1.11
  • php7-gd >= 7.4.6-1.11
  • php7-gettext >= 7.4.6-1.11
  • php7-gmp >= 7.4.6-1.11
  • php7-iconv >= 7.4.6-1.11
  • php7-intl >= 7.4.6-1.11
  • php7-json >= 7.4.6-1.11
  • php7-ldap >= 7.4.6-1.11
  • php7-mbstring >= 7.4.6-1.11
  • php7-mysql >= 7.4.6-1.11
  • php7-odbc >= 7.4.6-1.11
  • php7-opcache >= 7.4.6-1.11
  • php7-openssl >= 7.4.6-1.11
  • php7-pcntl >= 7.4.6-1.11
  • php7-pdo >= 7.4.6-1.11
  • php7-pgsql >= 7.4.6-1.11
  • php7-phar >= 7.4.6-1.11
  • php7-posix >= 7.4.6-1.11
  • php7-readline >= 7.4.6-1.11
  • php7-shmop >= 7.4.6-1.11
  • php7-snmp >= 7.4.6-1.11
  • php7-soap >= 7.4.6-1.11
  • php7-sockets >= 7.4.6-1.11
  • php7-sodium >= 7.4.6-1.11
  • php7-sqlite >= 7.4.6-1.11
  • php7-sysvmsg >= 7.4.6-1.11
  • php7-sysvsem >= 7.4.6-1.11
  • php7-sysvshm >= 7.4.6-1.11
  • php7-tidy >= 7.4.6-1.11
  • php7-tokenizer >= 7.4.6-1.11
  • php7-xmlreader >= 7.4.6-1.11
  • php7-xmlrpc >= 7.4.6-1.11
  • php7-xmlwriter >= 7.4.6-1.11
  • php7-xsl >= 7.4.6-1.11
  • php7-zip >= 7.4.6-1.11
  • php7-zlib >= 7.4.6-1.11
SUSE Linux Enterprise Module for Web Scripting 15 SP3
  • apache2-mod_php7 >= 7.4.6-3.17.1
  • php7 >= 7.4.6-3.17.1
  • php7-bcmath >= 7.4.6-3.17.1
  • php7-bz2 >= 7.4.6-3.17.1
  • php7-calendar >= 7.4.6-3.17.1
  • php7-ctype >= 7.4.6-3.17.1
  • php7-curl >= 7.4.6-3.17.1
  • php7-dba >= 7.4.6-3.17.1
  • php7-devel >= 7.4.6-3.17.1
  • php7-dom >= 7.4.6-3.17.1
  • php7-enchant >= 7.4.6-3.17.1
  • php7-exif >= 7.4.6-3.17.1
  • php7-fastcgi >= 7.4.6-3.17.1
  • php7-fileinfo >= 7.4.6-3.17.1
  • php7-fpm >= 7.4.6-3.17.1
  • php7-ftp >= 7.4.6-3.17.1
  • php7-gd >= 7.4.6-3.17.1
  • php7-gettext >= 7.4.6-3.17.1
  • php7-gmp >= 7.4.6-3.17.1
  • php7-iconv >= 7.4.6-3.17.1
  • php7-intl >= 7.4.6-3.17.1
  • php7-json >= 7.4.6-3.17.1
  • php7-ldap >= 7.4.6-3.17.1
  • php7-mbstring >= 7.4.6-3.17.1
  • php7-mysql >= 7.4.6-3.17.1
  • php7-odbc >= 7.4.6-3.17.1
  • php7-opcache >= 7.4.6-3.17.1
  • php7-openssl >= 7.4.6-3.17.1
  • php7-pcntl >= 7.4.6-3.17.1
  • php7-pdo >= 7.4.6-3.17.1
  • php7-pgsql >= 7.4.6-3.17.1
  • php7-phar >= 7.4.6-3.17.1
  • php7-posix >= 7.4.6-3.17.1
  • php7-readline >= 7.4.6-3.17.1
  • php7-shmop >= 7.4.6-3.17.1
  • php7-snmp >= 7.4.6-3.17.1
  • php7-soap >= 7.4.6-3.17.1
  • php7-sockets >= 7.4.6-3.17.1
  • php7-sodium >= 7.4.6-3.17.1
  • php7-sqlite >= 7.4.6-3.17.1
  • php7-sysvmsg >= 7.4.6-3.17.1
  • php7-sysvsem >= 7.4.6-3.17.1
  • php7-sysvshm >= 7.4.6-3.17.1
  • php7-tidy >= 7.4.6-3.17.1
  • php7-tokenizer >= 7.4.6-3.17.1
  • php7-xmlreader >= 7.4.6-3.17.1
  • php7-xmlrpc >= 7.4.6-3.17.1
  • php7-xmlwriter >= 7.4.6-3.17.1
  • php7-xsl >= 7.4.6-3.17.1
  • php7-zip >= 7.4.6-3.17.1
  • php7-zlib >= 7.4.6-3.17.1
SUSE Linux Enterprise Module for Web Scripting 15
  • apache2-mod_php7 >= 7.2.5-4.32.1
  • php7 >= 7.2.5-4.32.1
  • php7-bcmath >= 7.2.5-4.32.1
  • php7-bz2 >= 7.2.5-4.32.1
  • php7-calendar >= 7.2.5-4.32.1
  • php7-ctype >= 7.2.5-4.32.1
  • php7-curl >= 7.2.5-4.32.1
  • php7-dba >= 7.2.5-4.32.1
  • php7-devel >= 7.2.5-4.32.1
  • php7-dom >= 7.2.5-4.32.1
  • php7-enchant >= 7.2.5-4.32.1
  • php7-exif >= 7.2.5-4.32.1
  • php7-fastcgi >= 7.2.5-4.32.1
  • php7-fileinfo >= 7.2.5-4.32.1
  • php7-fpm >= 7.2.5-4.32.1
  • php7-ftp >= 7.2.5-4.32.1
  • php7-gd >= 7.2.5-4.32.1
  • php7-gettext >= 7.2.5-4.32.1
  • php7-gmp >= 7.2.5-4.32.1
  • php7-iconv >= 7.2.5-4.32.1
  • php7-intl >= 7.2.5-4.32.1
  • php7-json >= 7.2.5-4.32.1
  • php7-ldap >= 7.2.5-4.32.1
  • php7-mbstring >= 7.2.5-4.32.1
  • php7-mysql >= 7.2.5-4.32.1
  • php7-odbc >= 7.2.5-4.32.1
  • php7-opcache >= 7.2.5-4.32.1
  • php7-openssl >= 7.2.5-4.32.1
  • php7-pcntl >= 7.2.5-4.32.1
  • php7-pdo >= 7.2.5-4.32.1
  • php7-pear >= 7.2.5-4.32.1
  • php7-pear-Archive_Tar >= 7.2.5-4.32.1
  • php7-pgsql >= 7.2.5-4.32.1
  • php7-phar >= 7.2.5-4.32.1
  • php7-posix >= 7.2.5-4.32.1
  • php7-shmop >= 7.2.5-4.32.1
  • php7-snmp >= 7.2.5-4.32.1
  • php7-soap >= 7.2.5-4.32.1
  • php7-sockets >= 7.2.5-4.32.1
  • php7-sodium >= 7.2.5-4.32.1
  • php7-sqlite >= 7.2.5-4.32.1
  • php7-sysvmsg >= 7.2.5-4.32.1
  • php7-sysvsem >= 7.2.5-4.32.1
  • php7-sysvshm >= 7.2.5-4.32.1
  • php7-tokenizer >= 7.2.5-4.32.1
  • php7-wddx >= 7.2.5-4.32.1
  • php7-xmlreader >= 7.2.5-4.32.1
  • php7-xmlrpc >= 7.2.5-4.32.1
  • php7-xmlwriter >= 7.2.5-4.32.1
  • php7-xsl >= 7.2.5-4.32.1
  • php7-zip >= 7.2.5-4.32.1
  • php7-zlib >= 7.2.5-4.32.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-2019-1461
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • php7-embed >= 7.4.6-1.11
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • php7-embed >= 7.4.6-3.17.1
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • php7-embed >= 7.2.5-4.32.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-1461
SUSE Linux Enterprise Point of Sale 11 SP3
  • apache2-mod_php53 >= 5.3.17-112.58.1
  • php53 >= 5.3.17-112.58.1
  • php53-bcmath >= 5.3.17-112.58.1
  • php53-bz2 >= 5.3.17-112.58.1
  • php53-calendar >= 5.3.17-112.58.1
  • php53-ctype >= 5.3.17-112.58.1
  • php53-curl >= 5.3.17-112.58.1
  • php53-dba >= 5.3.17-112.58.1
  • php53-dom >= 5.3.17-112.58.1
  • php53-exif >= 5.3.17-112.58.1
  • php53-fastcgi >= 5.3.17-112.58.1
  • php53-fileinfo >= 5.3.17-112.58.1
  • php53-ftp >= 5.3.17-112.58.1
  • php53-gd >= 5.3.17-112.58.1
  • php53-gettext >= 5.3.17-112.58.1
  • php53-gmp >= 5.3.17-112.58.1
  • php53-iconv >= 5.3.17-112.58.1
  • php53-intl >= 5.3.17-112.58.1
  • php53-json >= 5.3.17-112.58.1
  • php53-ldap >= 5.3.17-112.58.1
  • php53-mbstring >= 5.3.17-112.58.1
  • php53-mcrypt >= 5.3.17-112.58.1
  • php53-mysql >= 5.3.17-112.58.1
  • php53-odbc >= 5.3.17-112.58.1
  • php53-openssl >= 5.3.17-112.58.1
  • php53-pcntl >= 5.3.17-112.58.1
  • php53-pdo >= 5.3.17-112.58.1
  • php53-pear >= 5.3.17-112.58.1
  • php53-pgsql >= 5.3.17-112.58.1
  • php53-pspell >= 5.3.17-112.58.1
  • php53-shmop >= 5.3.17-112.58.1
  • php53-snmp >= 5.3.17-112.58.1
  • php53-soap >= 5.3.17-112.58.1
  • php53-suhosin >= 5.3.17-112.58.1
  • php53-sysvmsg >= 5.3.17-112.58.1
  • php53-sysvsem >= 5.3.17-112.58.1
  • php53-sysvshm >= 5.3.17-112.58.1
  • php53-tokenizer >= 5.3.17-112.58.1
  • php53-wddx >= 5.3.17-112.58.1
  • php53-xmlreader >= 5.3.17-112.58.1
  • php53-xmlrpc >= 5.3.17-112.58.1
  • php53-xmlwriter >= 5.3.17-112.58.1
  • php53-xsl >= 5.3.17-112.58.1
  • php53-zip >= 5.3.17-112.58.1
  • php53-zlib >= 5.3.17-112.58.1
Patchnames:
sleposp3-php53-14013
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • apache2-mod_php53 >= 5.3.17-112.58.1
  • php53 >= 5.3.17-112.58.1
  • php53-bcmath >= 5.3.17-112.58.1
  • php53-bz2 >= 5.3.17-112.58.1
  • php53-calendar >= 5.3.17-112.58.1
  • php53-ctype >= 5.3.17-112.58.1
  • php53-curl >= 5.3.17-112.58.1
  • php53-dba >= 5.3.17-112.58.1
  • php53-dom >= 5.3.17-112.58.1
  • php53-exif >= 5.3.17-112.58.1
  • php53-fastcgi >= 5.3.17-112.58.1
  • php53-fileinfo >= 5.3.17-112.58.1
  • php53-ftp >= 5.3.17-112.58.1
  • php53-gd >= 5.3.17-112.58.1
  • php53-gettext >= 5.3.17-112.58.1
  • php53-gmp >= 5.3.17-112.58.1
  • php53-iconv >= 5.3.17-112.58.1
  • php53-intl >= 5.3.17-112.58.1
  • php53-json >= 5.3.17-112.58.1
  • php53-ldap >= 5.3.17-112.58.1
  • php53-mbstring >= 5.3.17-112.58.1
  • php53-mcrypt >= 5.3.17-112.58.1
  • php53-mysql >= 5.3.17-112.58.1
  • php53-odbc >= 5.3.17-112.58.1
  • php53-openssl >= 5.3.17-112.58.1
  • php53-pcntl >= 5.3.17-112.58.1
  • php53-pdo >= 5.3.17-112.58.1
  • php53-pear >= 5.3.17-112.58.1
  • php53-pgsql >= 5.3.17-112.58.1
  • php53-pspell >= 5.3.17-112.58.1
  • php53-shmop >= 5.3.17-112.58.1
  • php53-snmp >= 5.3.17-112.58.1
  • php53-soap >= 5.3.17-112.58.1
  • php53-suhosin >= 5.3.17-112.58.1
  • php53-sysvmsg >= 5.3.17-112.58.1
  • php53-sysvsem >= 5.3.17-112.58.1
  • php53-sysvshm >= 5.3.17-112.58.1
  • php53-tokenizer >= 5.3.17-112.58.1
  • php53-wddx >= 5.3.17-112.58.1
  • php53-xmlreader >= 5.3.17-112.58.1
  • php53-xmlrpc >= 5.3.17-112.58.1
  • php53-xmlwriter >= 5.3.17-112.58.1
  • php53-xsl >= 5.3.17-112.58.1
  • php53-zip >= 5.3.17-112.58.1
  • php53-zlib >= 5.3.17-112.58.1
Patchnames:
slessp4-php53-14013
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libmemcached >= 1.0.18-3.2.1
  • libmemcached11 >= 1.0.18-3.2.1
  • libmemcachedutil2 >= 1.0.18-3.2.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-823
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libmemcached >= 1.0.18-3.2.1
  • libmemcached11 >= 1.0.18-3.2.1
  • libmemcachedutil2 >= 1.0.18-3.2.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-823
SUSE Linux Enterprise Software Development Kit 11 SP4
  • php53-devel >= 5.3.17-112.58.1
  • php53-imap >= 5.3.17-112.58.1
  • php53-posix >= 5.3.17-112.58.1
  • php53-readline >= 5.3.17-112.58.1
  • php53-sockets >= 5.3.17-112.58.1
  • php53-sqlite >= 5.3.17-112.58.1
  • php53-tidy >= 5.3.17-112.58.1
Patchnames:
sdksp4-php53-14013
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libtidy-0_99-0 >= 1.0.20100204cvs-26.2.1
  • libtidy-0_99-0-devel >= 1.0.20100204cvs-26.2.1
  • php5-devel >= 5.5.14-109.51.6
  • php7-devel >= 7.0.7-50.70.1
  • php72-devel >= 7.2.5-1.7.1
  • tidy >= 1.0.20100204cvs-26.2.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1041
SUSE-SLE-SDK-12-SP3-2019-823
SUSE-SLE-SDK-12-SP3-2019-985
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libmemcached-devel >= 1.0.18-3.2.1
  • libtidy-0_99-0 >= 1.0.20100204cvs-26.2.1
  • libtidy-0_99-0-devel >= 1.0.20100204cvs-26.2.1
  • php5-devel >= 5.5.14-109.51.6
  • php7-devel >= 7.0.7-50.70.1
  • php72-devel >= 7.2.5-1.7.1
  • tidy >= 1.0.20100204cvs-26.2.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1041
SUSE-SLE-SDK-12-SP4-2019-823
SUSE-SLE-SDK-12-SP4-2019-985
SUSE Linux Enterprise Software Development Kit 12 SP5
  • php7-devel >= 7.0.7-50.85.1
  • php72-devel >= 7.2.5-1.26.1
openSUSE Leap 15.0
  • apache2-mod_php7 >= 7.2.5-lp150.2.19.1
  • php7 >= 7.2.5-lp150.2.19.1
  • php7-bcmath >= 7.2.5-lp150.2.19.1
  • php7-bz2 >= 7.2.5-lp150.2.19.1
  • php7-calendar >= 7.2.5-lp150.2.19.1
  • php7-ctype >= 7.2.5-lp150.2.19.1
  • php7-curl >= 7.2.5-lp150.2.19.1
  • php7-dba >= 7.2.5-lp150.2.19.1
  • php7-devel >= 7.2.5-lp150.2.19.1
  • php7-dom >= 7.2.5-lp150.2.19.1
  • php7-embed >= 7.2.5-lp150.2.19.1
  • php7-enchant >= 7.2.5-lp150.2.19.1
  • php7-exif >= 7.2.5-lp150.2.19.1
  • php7-fastcgi >= 7.2.5-lp150.2.19.1
  • php7-fileinfo >= 7.2.5-lp150.2.19.1
  • php7-firebird >= 7.2.5-lp150.2.19.1
  • php7-fpm >= 7.2.5-lp150.2.19.1
  • php7-ftp >= 7.2.5-lp150.2.19.1
  • php7-gd >= 7.2.5-lp150.2.19.1
  • php7-gettext >= 7.2.5-lp150.2.19.1
  • php7-gmp >= 7.2.5-lp150.2.19.1
  • php7-iconv >= 7.2.5-lp150.2.19.1
  • php7-intl >= 7.2.5-lp150.2.19.1
  • php7-json >= 7.2.5-lp150.2.19.1
  • php7-ldap >= 7.2.5-lp150.2.19.1
  • php7-mbstring >= 7.2.5-lp150.2.19.1
  • php7-mysql >= 7.2.5-lp150.2.19.1
  • php7-odbc >= 7.2.5-lp150.2.19.1
  • php7-opcache >= 7.2.5-lp150.2.19.1
  • php7-openssl >= 7.2.5-lp150.2.19.1
  • php7-pcntl >= 7.2.5-lp150.2.19.1
  • php7-pdo >= 7.2.5-lp150.2.19.1
  • php7-pear >= 7.2.5-lp150.2.19.1
  • php7-pear-Archive_Tar >= 7.2.5-lp150.2.19.1
  • php7-pgsql >= 7.2.5-lp150.2.19.1
  • php7-phar >= 7.2.5-lp150.2.19.1
  • php7-posix >= 7.2.5-lp150.2.19.1
  • php7-readline >= 7.2.5-lp150.2.19.1
  • php7-shmop >= 7.2.5-lp150.2.19.1
  • php7-snmp >= 7.2.5-lp150.2.19.1
  • php7-soap >= 7.2.5-lp150.2.19.1
  • php7-sockets >= 7.2.5-lp150.2.19.1
  • php7-sodium >= 7.2.5-lp150.2.19.1
  • php7-sqlite >= 7.2.5-lp150.2.19.1
  • php7-sysvmsg >= 7.2.5-lp150.2.19.1
  • php7-sysvsem >= 7.2.5-lp150.2.19.1
  • php7-sysvshm >= 7.2.5-lp150.2.19.1
  • php7-testresults >= 7.2.5-lp150.2.19.1
  • php7-tidy >= 7.2.5-lp150.2.19.1
  • php7-tokenizer >= 7.2.5-lp150.2.19.1
  • php7-wddx >= 7.2.5-lp150.2.19.1
  • php7-xmlreader >= 7.2.5-lp150.2.19.1
  • php7-xmlrpc >= 7.2.5-lp150.2.19.1
  • php7-xmlwriter >= 7.2.5-lp150.2.19.1
  • php7-xsl >= 7.2.5-lp150.2.19.1
  • php7-zip >= 7.2.5-lp150.2.19.1
  • php7-zlib >= 7.2.5-lp150.2.19.1
Patchnames:
openSUSE-2019-1573
openSUSE Leap 15.1
  • apache2-mod_php7 >= 7.2.5-lp151.6.3.1
  • php7 >= 7.2.5-lp151.6.3.1
  • php7-bcmath >= 7.2.5-lp151.6.3.1
  • php7-bz2 >= 7.2.5-lp151.6.3.1
  • php7-calendar >= 7.2.5-lp151.6.3.1
  • php7-ctype >= 7.2.5-lp151.6.3.1
  • php7-curl >= 7.2.5-lp151.6.3.1
  • php7-dba >= 7.2.5-lp151.6.3.1
  • php7-devel >= 7.2.5-lp151.6.3.1
  • php7-dom >= 7.2.5-lp151.6.3.1
  • php7-embed >= 7.2.5-lp151.6.3.1
  • php7-enchant >= 7.2.5-lp151.6.3.1
  • php7-exif >= 7.2.5-lp151.6.3.1
  • php7-fastcgi >= 7.2.5-lp151.6.3.1
  • php7-fileinfo >= 7.2.5-lp151.6.3.1
  • php7-firebird >= 7.2.5-lp151.6.3.1
  • php7-fpm >= 7.2.5-lp151.6.3.1
  • php7-ftp >= 7.2.5-lp151.6.3.1
  • php7-gd >= 7.2.5-lp151.6.3.1
  • php7-gettext >= 7.2.5-lp151.6.3.1
  • php7-gmp >= 7.2.5-lp151.6.3.1
  • php7-iconv >= 7.2.5-lp151.6.3.1
  • php7-intl >= 7.2.5-lp151.6.3.1
  • php7-json >= 7.2.5-lp151.6.3.1
  • php7-ldap >= 7.2.5-lp151.6.3.1
  • php7-mbstring >= 7.2.5-lp151.6.3.1
  • php7-mysql >= 7.2.5-lp151.6.3.1
  • php7-odbc >= 7.2.5-lp151.6.3.1
  • php7-opcache >= 7.2.5-lp151.6.3.1
  • php7-openssl >= 7.2.5-lp151.6.3.1
  • php7-pcntl >= 7.2.5-lp151.6.3.1
  • php7-pdo >= 7.2.5-lp151.6.3.1
  • php7-pear >= 7.2.5-lp151.6.3.1
  • php7-pear-Archive_Tar >= 7.2.5-lp151.6.3.1
  • php7-pgsql >= 7.2.5-lp151.6.3.1
  • php7-phar >= 7.2.5-lp151.6.3.1
  • php7-posix >= 7.2.5-lp151.6.3.1
  • php7-readline >= 7.2.5-lp151.6.3.1
  • php7-shmop >= 7.2.5-lp151.6.3.1
  • php7-snmp >= 7.2.5-lp151.6.3.1
  • php7-soap >= 7.2.5-lp151.6.3.1
  • php7-sockets >= 7.2.5-lp151.6.3.1
  • php7-sodium >= 7.2.5-lp151.6.3.1
  • php7-sqlite >= 7.2.5-lp151.6.3.1
  • php7-sysvmsg >= 7.2.5-lp151.6.3.1
  • php7-sysvsem >= 7.2.5-lp151.6.3.1
  • php7-sysvshm >= 7.2.5-lp151.6.3.1
  • php7-testresults >= 7.2.5-lp151.6.3.1
  • php7-tidy >= 7.2.5-lp151.6.3.1
  • php7-tokenizer >= 7.2.5-lp151.6.3.1
  • php7-wddx >= 7.2.5-lp151.6.3.1
  • php7-xmlreader >= 7.2.5-lp151.6.3.1
  • php7-xmlrpc >= 7.2.5-lp151.6.3.1
  • php7-xmlwriter >= 7.2.5-lp151.6.3.1
  • php7-xsl >= 7.2.5-lp151.6.3.1
  • php7-zip >= 7.2.5-lp151.6.3.1
  • php7-zlib >= 7.2.5-lp151.6.3.1
Patchnames:
openSUSE-2019-1572
openSUSE Tumbleweed
  • php7 >= 7.4.24-1.1
  • php7-bcmath >= 7.4.24-1.1
  • php7-bz2 >= 7.4.24-1.1
  • php7-calendar >= 7.4.24-1.1
  • php7-cli >= 7.4.24-1.1
  • php7-ctype >= 7.4.24-1.1
  • php7-curl >= 7.4.24-1.1
  • php7-dba >= 7.4.24-1.1
  • php7-devel >= 7.4.24-1.1
  • php7-dom >= 7.4.24-1.1
  • php7-enchant >= 7.4.24-1.1
  • php7-exif >= 7.4.24-1.1
  • php7-fileinfo >= 7.4.24-1.1
  • php7-ftp >= 7.4.24-1.1
  • php7-gd >= 7.4.24-1.1
  • php7-gettext >= 7.4.24-1.1
  • php7-gmp >= 7.4.24-1.1
  • php7-iconv >= 7.4.24-1.1
  • php7-intl >= 7.4.24-1.1
  • php7-json >= 7.4.24-1.1
  • php7-ldap >= 7.4.24-1.1
  • php7-mbstring >= 7.4.24-1.1
  • php7-mysql >= 7.4.24-1.1
  • php7-odbc >= 7.4.24-1.1
  • php7-opcache >= 7.4.24-1.1
  • php7-openssl >= 7.4.24-1.1
  • php7-pcntl >= 7.4.24-1.1
  • php7-pdo >= 7.4.24-1.1
  • php7-pgsql >= 7.4.24-1.1
  • php7-phar >= 7.4.24-1.1
  • php7-posix >= 7.4.24-1.1
  • php7-readline >= 7.4.24-1.1
  • php7-shmop >= 7.4.24-1.1
  • php7-snmp >= 7.4.24-1.1
  • php7-soap >= 7.4.24-1.1
  • php7-sockets >= 7.4.24-1.1
  • php7-sodium >= 7.4.24-1.1
  • php7-sqlite >= 7.4.24-1.1
  • php7-sysvmsg >= 7.4.24-1.1
  • php7-sysvsem >= 7.4.24-1.1
  • php7-sysvshm >= 7.4.24-1.1
  • php7-tidy >= 7.4.24-1.1
  • php7-tokenizer >= 7.4.24-1.1
  • php7-xmlreader >= 7.4.24-1.1
  • php7-xmlrpc >= 7.4.24-1.1
  • php7-xmlwriter >= 7.4.24-1.1
  • php7-xsl >= 7.4.24-1.1
  • php7-zip >= 7.4.24-1.1
  • php7-zlib >= 7.4.24-1.1
  • php8 >= 8.0.11-1.1
  • php8-bcmath >= 8.0.11-1.1
  • php8-bz2 >= 8.0.11-1.1
  • php8-calendar >= 8.0.11-1.1
  • php8-cli >= 8.0.11-1.1
  • php8-ctype >= 8.0.11-1.1
  • php8-curl >= 8.0.11-1.1
  • php8-dba >= 8.0.11-1.1
  • php8-devel >= 8.0.11-1.1
  • php8-dom >= 8.0.11-1.1
  • php8-enchant >= 8.0.11-1.1
  • php8-exif >= 8.0.11-1.1
  • php8-fileinfo >= 8.0.11-1.1
  • php8-ftp >= 8.0.11-1.1
  • php8-gd >= 8.0.11-1.1
  • php8-gettext >= 8.0.11-1.1
  • php8-gmp >= 8.0.11-1.1
  • php8-iconv >= 8.0.11-1.1
  • php8-intl >= 8.0.11-1.1
  • php8-ldap >= 8.0.11-1.1
  • php8-mbstring >= 8.0.11-1.1
  • php8-mysql >= 8.0.11-1.1
  • php8-odbc >= 8.0.11-1.1
  • php8-opcache >= 8.0.11-1.1
  • php8-openssl >= 8.0.11-1.1
  • php8-pcntl >= 8.0.11-1.1
  • php8-pdo >= 8.0.11-1.1
  • php8-pgsql >= 8.0.11-1.1
  • php8-phar >= 8.0.11-1.1
  • php8-posix >= 8.0.11-1.1
  • php8-readline >= 8.0.11-1.1
  • php8-shmop >= 8.0.11-1.1
  • php8-snmp >= 8.0.11-1.1
  • php8-soap >= 8.0.11-1.1
  • php8-sockets >= 8.0.11-1.1
  • php8-sodium >= 8.0.11-1.1
  • php8-sqlite >= 8.0.11-1.1
  • php8-sysvmsg >= 8.0.11-1.1
  • php8-sysvsem >= 8.0.11-1.1
  • php8-sysvshm >= 8.0.11-1.1
  • php8-tidy >= 8.0.11-1.1
  • php8-tokenizer >= 8.0.11-1.1
  • php8-xmlreader >= 8.0.11-1.1
  • php8-xmlwriter >= 8.0.11-1.1
  • php8-xsl >= 8.0.11-1.1
  • php8-zip >= 8.0.11-1.1
  • php8-zlib >= 8.0.11-1.1
Patchnames:
openSUSE Tumbleweed GA php7-7.4.24-1.1
openSUSE Tumbleweed GA php8-8.0.11-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications php53 Affected
SUSE CaaS Platform 4.0 php7 In progress
SUSE Enterprise Storage 6 php7 In progress
SUSE Linux Enterprise High Performance Computing 15 LTSS php7 In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS php7 In progress
SUSE Linux Enterprise Module for Web and Scripting 12 php5 Released
SUSE Linux Enterprise Module for Web and Scripting 12 php7 Released
SUSE Linux Enterprise Module for Web and Scripting 12 php72 In progress
SUSE Linux Enterprise Module for Web and Scripting 12 php74 In progress
SUSE Linux Enterprise Module for Web and Scripting 15 php7 Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 php7 Already fixed
SUSE Linux Enterprise Point of Service 11 SP3 php53 Released
SUSE Linux Enterprise Server 11 SP3 LTSS php53 Affected
SUSE Linux Enterprise Server 11 SP4 php53 Released
SUSE Linux Enterprise Server 11 SP4 LTSS php53 Released
SUSE Linux Enterprise Server 15 ESPOS php7 In progress
SUSE Linux Enterprise Server 15 LTSS php7 In progress
SUSE Linux Enterprise Server 15 SP1 LTSS php7 In progress
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 php7 In progress
SUSE Linux Enterprise Server for SAP Applications 15 php7 In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP1 php7 In progress
SUSE Linux Enterprise Software Development Kit 11 SP4 php53 Released
SUSE Linux Enterprise Software Development Kit 12 SP3 php5 Released
SUSE Linux Enterprise Software Development Kit 12 SP3 php7 Released
SUSE Linux Enterprise Software Development Kit 12 SP4 php5 Released
SUSE Linux Enterprise Software Development Kit 12 SP4 php7 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 php7 Released
SUSE Manager Proxy 4.0 php7 In progress
SUSE Manager Retail Branch Server 4.0 php7 In progress
SUSE Manager Server 4.0 php7 In progress